Every CVE Search/ Get API key

CVE-2018-8032

Moderate severity vulnerability that affects apache axis

6.1 MediumPublic exploitFix available

Apache Axis 1.x up to and including 1.4 is vulnerable to a cross-site scripting (XSS) attack in the default servlet/services.

Attack profile

How easy it is to exploit

Attack vector
Network
Complexity
Low
Privileges needed
None
User interaction
Required

What an attacker can affect

Confidentiality
Low
Integrity
Low
Availability
None

Exploit likelihood

10.6%Up 4.6 points since Apr 14, 2021
90%50%10%1%

What each source reports

NVD Score used 6.1

Apache Axis 1.x up to and including 1.4 is vulnerable to a cross-site scripting (XSS) attack in the default servlet/services.

Record
CVE-2018-8032
CVSS 3.1
6.1 MediumCVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
CVSS 2.0
4.3 MediumAV:N/AC:M/Au:N/C:N/I:P/A:N
Weakness
CWE-79
Updated
2026-11-02
CVE List No score

Apache Axis 1.x up to and including 1.4 is vulnerable to a cross-site scripting (XSS) attack in the default servlet/services.

Record
CVE-2018-8032
Updated
2026-11-02
EUVDEUVD-2018-0560 No score

Apache Axis 1.x up to and including 1.4 is vulnerable to a cross-site scripting (XSS) attack in the default servlet/services.

Record
EUVD-2018-0560
Updated
2026-11-03
GitHub AdvisoriesGHSA-96jq-75wh-2658 6.1

Moderate severity vulnerability that affects apache axis

Apache Axis 1.x up to and including 1.4 is vulnerable to a cross-site scripting (XSS) attack in the default servlet/services.

Record
GHSA-96jq-75wh-2658
CVSS 3.1
6.1 MediumCVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
Weakness
CWE-79
Updated
2026-11-02
OSV 6.1

Apache Axis 1.x up to and including 1.4 is vulnerable to a cross-site scripting (XSS) attack in the default servlet/services.

Record
CVE-2018-8032
CVSS 3.1
6.1 MediumCVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
Updated
2026-11-02
OSVDEBIAN-CVE-2018-8032 6.1

Apache Axis 1.x up to and including 1.4 is vulnerable to a cross-site scripting (XSS) attack in the default servlet/services.

Record
DEBIAN-CVE-2018-8032
CVSS 3.1
6.1 MediumCVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
Updated
2026-11-02
Show 8 moreShow less
OSVGHSA-96jq-75wh-2658 6.1

Moderate severity vulnerability that affects apache axis

Apache Axis 1.x up to and including 1.4 is vulnerable to a cross-site scripting (XSS) attack in the default servlet/services.

Record
GHSA-96jq-75wh-2658
CVSS 3.1
6.1 MediumCVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
Weakness
CWE-79
Updated
2026-11-02
OSVUBUNTU-CVE-2018-8032 6.1

Apache Axis 1.x up to and including 1.4 is vulnerable to a cross-site scripting (XSS) attack in the default servlet/services.

Record
UBUNTU-CVE-2018-8032
CVSS 3.1
6.1 MediumCVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
Updated
2026-11-02
OSVCLSA-2026-1771459786 No score

TuxCare security update for org.apache.axis:axis (3 CVEs)

TuxCare rebuilt org.apache.axis:axis to address 3 CVEs. Fixed in 1.4-tuxcare.1.

Record
CLSA-2026-1771459786
Updated
2026-11-02
OSVMGASA-2018-0431 No score

Updated axis packages fix security vulnerability

Updated axis packages fix security vulnerability:

Apache Axis 1.x up to and including 1.4 is vulnerable to a cross-site scripting (XSS) attack in the default servlet/services (CVE-2018-8032).

Record
MGASA-2018-0431
Updated
2026-11-02
OSVopenSUSE-SU-2024:10646-1 No score

axis-1.4-302.6 on GA media

These are all security issues fixed in the axis-1.4-302.6 package on the GA media of openSUSE Tumbleweed.

Record
openSUSE-SU-2024:10646-1
Updated
2026-11-02
OSVSUSE-SU-2018:3118-1 No score

Security update for axis

This update for axis fixes the following security issue:

  • CVE-2018-8032: Prevent cross-site scripting (XSS) attack in the default servlet/services (bsc#1103658).
Record
SUSE-SU-2018:3118-1
Updated
2026-11-02
OSVSUSE-SU-2018:3119-1 No score

Security update for axis

This update for axis fixes the following security issue:

  • CVE-2018-8032: Prevent cross-site scripting (XSS) attack in the default servlet/services (bsc#1103658).
Record
SUSE-SU-2018:3119-1
Updated
2026-11-02
OSVSUSE-SU-2018:3121-1 No score

Security update for axis

This update for axis fixes the following security issue:

  • CVE-2018-8032: Prevent cross-site scripting (XSS) attack in the default servlet/services (bsc#1103658).
Record
SUSE-SU-2018:3121-1
Updated
2026-11-02

Affected products

Show 27 moreShow less

Affected packages

Affected packages
PackageAffectedFixed
org.apache.axis:axis
Maven
through 1.4 None known
axis:axis
Maven
through 1.4 None known
org.apache.axis:axis
TuxCare:Maven
1.4 up to 1.4-tuxcare.1
1.4-tuxcare.1
axis
Debian:12
before 1.4-28
1.4-28
axis
Debian:13
before 1.4-28
1.4-28
axis
Debian:14
before 1.4-28
1.4-28
axis
Debian:9
before 1.4-25+deb9u1, plus listed versions
1.4-25
1.4-25+deb9u1
axis:axis
Maven
through 1.4, plus listed versions
1.01.11.1-beta1.21.2-RC1
Show 7 moreShow less
1.2-RC21.2-RC31.2-alpha-11.2-beta-21.2-beta-31.2.11.3
None known
axis
Mageia:6
before 1.4-32.1.mga6
1.4-32.1.mga6
axis
SUSE:Linux Enterprise Server 12 SP3
before 1.4-290.3.1
1.4-290.3.1
Show 6 moreShow less
Affected packages
PackageAffectedFixed
axis
SUSE:Linux Enterprise Server for SAP Applications 12 SP3
before 1.4-290.3.1
1.4-290.3.1
axis
SUSE:Linux Enterprise Server 11 SP4
before 1.4-236.236.44.9.1
1.4-236.236.44.9.1
axis
SUSE:Linux Enterprise Server for SAP Applications 11 SP4
before 1.4-236.236.44.9.1
1.4-236.236.44.9.1
axis
SUSE:Linux Enterprise Module for Basesystem 15
before 1.4-5.3.1
1.4-5.3.1
axis
Ubuntu:Pro:16.04:LTS
All versions, plus listed versions
1.4-221.4-231.4-241.4-24ubuntu0.1~esm1
None known
axis
Ubuntu:Pro:18.04:LTS
All versions, plus listed versions
1.4-251.4-25ubuntu0.1~esm1
None known

Public exploits

Links only. Every CVE stores no exploit code.

Public exploits
SourceLinkDate
PoC in GitHubcairuojin/CVE-2018-80322020-03-30

History

History
RecordedChangedSources
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV, PoC in GitHub

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2018-8032 is a medium vulnerability (CVSS 6.1) in Apache Axis, published August 2, 2018. Public exploit code exists. EPSS puts the chance of exploitation in the next 30 days at 10.6%, the 95th percentile. Fixed in org.apache.axis:axis 1.4-tuxcare.1.

References

Show 28 moreShow less
MoveEnter Open