CVE-2018-8035
Cross-site Scripting in Apache UIMA
This vulnerability relates to the user's browser processing of DUCC webpage input data.The javascript comprising Apache UIMA DUCC (<= 2.2.2) which runs in the user's browser does not sufficiently filter user supplied inputs, which may result in unintended execution of user supplied javascript code.
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- Low
- Privileges needed
- None
- User interaction
- Required
What an attacker can affect
- Confidentiality
- Low
- Integrity
- Low
- Availability
- None
Exploit likelihood
What each source reports
NVD Score used
6.1
This vulnerability relates to the user's browser processing of DUCC webpage input data.The javascript comprising Apache UIMA DUCC (<= 2.2.2) which runs in the user's browser does not sufficiently filter user supplied inputs, which may result in unintended execution of user supplied javascript code.
- Record
CVE-2018-8035- CVSS 3.0
- 6.1 Medium
CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N - CVSS 2.0
- 4.3 Medium
AV:N/AC:M/Au:N/C:N/I:P/A:N - Weakness
- CWE-79
- Updated
- 2026-11-02
CVE List No score
This vulnerability relates to the user's browser processing of DUCC webpage input data.The javascript comprising Apache UIMA DUCC (<= 2.2.2) which runs in the user's browser does not sufficiently filter user supplied inputs, which may result in unintended execution of user supplied javascript code.
- Record
CVE-2018-8035- Updated
- 2026-11-02
EUVDEUVD-2019-0479 No score
This vulnerability relates to the user's browser processing of DUCC webpage input data.The javascript comprising Apache UIMA DUCC (<= 2.2.2) which runs in the user's browser does not sufficiently filter user supplied inputs, which may result in unintended execution of user supplied javascript code.
- Record
EUVD-2019-0479- Updated
- 2026-11-03
GitHub AdvisoriesGHSA-vm59-329q-p468
6.1
Cross-site Scripting in Apache UIMA
This vulnerability relates to the user's browser processing of DUCC webpage input data.The javascript comprising Apache UIMA DUCC (<= 2.2.2) which runs in the user's browser does not sufficiently filter user supplied inputs, which may result in unintended execution of user supplied javascript code.
- Record
GHSA-vm59-329q-p468- CVSS 3.0
- 6.1 Medium
CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N - Weakness
- CWE-79
- Updated
- 2026-11-02
OSV
6.1
This vulnerability relates to the user's browser processing of DUCC webpage input data.The javascript comprising Apache UIMA DUCC (<= 2.2.2) which runs in the user's browser does not sufficiently filter user supplied inputs, which may result in unintended execution of user supplied javascript code.
- Record
CVE-2018-8035- CVSS 3.0
- 6.1 Medium
CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N - Updated
- 2026-11-02
OSVGHSA-vm59-329q-p468
6.1
Cross-site Scripting in Apache UIMA
This vulnerability relates to the user's browser processing of DUCC webpage input data.The javascript comprising Apache UIMA DUCC (<= 2.2.2) which runs in the user's browser does not sufficiently filter user supplied inputs, which may result in unintended execution of user supplied javascript code.
- Record
GHSA-vm59-329q-p468- CVSS 3.0
- 6.1 Medium
CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N - Weakness
- CWE-79
- Updated
- 2026-11-02
OSVUBUNTU-CVE-2018-8035
6.1
This vulnerability relates to the user's browser processing of DUCC webpage input data.The javascript comprising Apache UIMA DUCC (<= 2.2.2) which runs in the user's browser does not sufficiently filter user supplied inputs, which may result in unintended execution of user supplied javascript code.
- Record
UBUNTU-CVE-2018-8035- CVSS 3.0
- 6.1 Medium
CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N - Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
org.apache.uima:uima-ducc-webMaven |
through 2.2.2 | 3.0.0 |
org.apache.uima:uima-ducc-webMaven |
before 3.0.0, plus listed versions 1.0.01.1.02.0.02.0.12.1.02.2.02.2.12.2.2 |
3.0.0 |
uimajUbuntu:16.04:LTS |
All versions, plus listed versions 2.7.0-12.8.1-1 |
None known |
uimajUbuntu:18.04:LTS |
All versions, plus listed versions 2.10.1-12.10.1-22.10.2-2~18.04 |
None known |
uimajUbuntu:20.04:LTS |
All versions, plus listed versions 2.10.2-3 |
None known |
uimajUbuntu:22.04:LTS |
All versions, plus listed versions 2.10.2-4 |
None known |
uimajUbuntu:24.04:LTS |
All versions, plus listed versions 2.10.2-4 |
None known |
uimajUbuntu:25.10 |
All versions, plus listed versions 2.10.4-1 |
None known |
uimajUbuntu:26.10 |
All versions, plus listed versions 2.10.4-1build1 |
None known |
uimajUbuntu:26.04:LTS |
All versions, plus listed versions 2.10.4-12.10.4-1build1 |
None known |
History
| Recorded | Changed | Sources |
|---|---|---|
| aliases, products | EUVD | |
| first indexed | CVE List, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2018-8035 is a medium vulnerability (CVSS 6.1) in Apache Uima Ducc, published May 1, 2019. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 4.88%, the 92nd percentile. Fixed in org.apache.uima:uima-ducc-web 3.0.0.
References
uima.apache.org/security_report
securityfocus.com/bid/108195
lists.apache.org/thread.html/2f49681259b375d53431605f1c557ef8a3ed0af01a488d2e1b330053%40%3Cdev.uima.apache.org%3E
nvd.nist.gov/vuln/detail/CVE-2018-8035
lists.apache.org/thread.html/2f49681259b375d53431605f1c557ef8a3ed0af01a488d2e1b330053@%3Cdev.uima.apache.org%3E
github.com/advisories/GHSA-vm59-329q-p468
ubuntu.com/security/CVE-2018-8035
cve.org/CVERecord?id=CVE-2018-8035