CVE-2018-8074
Yii Framework Code Injection
Yii 2.x before 2.0.15 allows remote attackers to inject unintended search conditions via a variant of the CVE-2018-7269 attack in conjunction with the Elasticsearch extension.
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- High
- Privileges needed
- None
- User interaction
- None
What an attacker can affect
- Confidentiality
- High
- Integrity
- High
- Availability
- High
Exploit likelihood
What each source reports
NVD Score used
8.1
Yii 2.x before 2.0.15 allows remote attackers to inject unintended search conditions via a variant of the CVE-2018-7269 attack in conjunction with the Elasticsearch extension.
- Record
CVE-2018-8074- CVSS 3.0
- 8.1 High
CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H - CVSS 2.0
- 6.8 Medium
AV:N/AC:M/Au:N/C:P/I:P/A:P - Weakness
- CWE-94
- Updated
- 2026-11-02
CVE List No score
Yii 2.x before 2.0.15 allows remote attackers to inject unintended search conditions via a variant of the CVE-2018-7269 attack in conjunction with the Elasticsearch extension.
- Record
CVE-2018-8074- Updated
- 2026-11-02
EUVDEUVD-2022-4471 No score
Yii 2.x before 2.0.15 allows remote attackers to inject unintended search conditions via a variant of the CVE-2018-7269 attack in conjunction with the Elasticsearch extension.
- Record
EUVD-2022-4471- Updated
- 2026-11-03
GitHub AdvisoriesGHSA-m2p5-fwp2-qcw2
8.1
Yii Framework Code Injection
Yii 2.x before 2.0.15 allows remote attackers to inject unintended search conditions via a variant of the CVE-2018-7269 attack in conjunction with the Elasticsearch extension.
- Record
GHSA-m2p5-fwp2-qcw2- CVSS 3.0
- 8.1 High
CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H - Weakness
- CWE-94
- Updated
- 2026-11-02
OSV
8.1
Yii 2.x before 2.0.15 allows remote attackers to inject unintended search conditions via a variant of the CVE-2018-7269 attack in conjunction with the Elasticsearch extension.
- Record
CVE-2018-8074- CVSS 3.0
- 8.1 High
CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H - Updated
- 2026-11-02
OSVGHSA-m2p5-fwp2-qcw2
8.1
Yii Framework Code Injection
Yii 2.x before 2.0.15 allows remote attackers to inject unintended search conditions via a variant of the CVE-2018-7269 attack in conjunction with the Elasticsearch extension.
- Record
GHSA-m2p5-fwp2-qcw2- CVSS 3.0
- 8.1 High
CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H - Weakness
- CWE-94
- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
yiisoft/yii2-devPackagist |
2.0.0 up to 2.0.15 | 2.0.15 |
yiisoft/yii2-elasticsearchPackagist |
before 2.0.5 | 2.0.5 |
yiisoft/yii2-devPackagist |
2.0.0 up to 2.0.15, plus listed versions 2.0.12.0.102.0.112.0.11.12.0.11.2 Show 18 moreShow less2.0.122.0.12.12.0.12.22.0.132.0.13.12.0.13.22.0.13.32.0.142.0.14.12.0.14.22.0.22.0.32.0.42.0.52.0.62.0.72.0.82.0.9 |
2.0.15 |
yiisoft/yii2-elasticsearchPackagist |
before 2.0.5, plus listed versions 2.0.02.0.0-alpha2.0.0-beta2.0.0-rc2.0.12.0.22.0.32.0.4 |
2.0.5 |
History
| Recorded | Changed | Sources |
|---|---|---|
| aliases | EUVD | |
| first indexed | CVE List, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2018-8074 is a high vulnerability (CVSS 8.1) in Yiiframework Yii, published March 21, 2018. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 1.49%, the 74th percentile. Fixed in yiisoft/yii2-dev 2.0.15.