CVE-2018-8098
Integer overflow in the index.c:read_entry() function while decompressing a compressed prefix...
Integer overflow in the index.c:read_entry() function while decompressing a compressed prefix length in libgit2 before v0.26.2 allows an attacker to cause a denial of service (out-of-bounds read) via a crafted repository index file.
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- Low
- Privileges needed
- None
- User interaction
- Required
What an attacker can affect
- Confidentiality
- None
- Integrity
- None
- Availability
- High
Exploit likelihood
What each source reports
NVD Score used
6.5
Integer overflow in the index.c:read_entry() function while decompressing a compressed prefix length in libgit2 before v0.26.2 allows an attacker to cause a denial of service (out-of-bounds read) via a crafted repository index file.
- Record
CVE-2018-8098- CVSS 3.1
- 6.5 Medium
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H - CVSS 2.0
- 4.3 Medium
AV:N/AC:M/Au:N/C:N/I:N/A:P - Weakness
- CWE-190
- Updated
- 2026-11-02
CVE List No score
Integer overflow in the index.c:read_entry() function while decompressing a compressed prefix length in libgit2 before v0.26.2 allows an attacker to cause a denial of service (out-of-bounds read) via a crafted repository index file.
- Record
CVE-2018-8098- Updated
- 2026-11-02
EUVDEUVD-2018-19774 No score
Integer overflow in the index.c:read_entry() function while decompressing a compressed prefix length in libgit2 before v0.26.2 allows an attacker to cause a denial of service (out-of-bounds read) via a crafted repository index file.
- Record
EUVD-2018-19774- Updated
- 2026-11-03
GitHub AdvisoriesGHSA-m334-hpp6-wjh3
6.5
Integer overflow in the index.c:read_entry() function while decompressing a compressed prefix...
Integer overflow in the index.c:read_entry() function while decompressing a compressed prefix length in libgit2 before v0.26.2 allows an attacker to cause a denial of service (out-of-bounds read) via a crafted repository index file.
- Record
GHSA-m334-hpp6-wjh3- CVSS 3.1
- 6.5 Medium
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H - Weakness
- CWE-190
- Updated
- 2026-11-02
OSV
6.5
Integer overflow in the index.c:read_entry() function while decompressing a compressed prefix length in libgit2 before v0.26.2 allows an attacker to cause a denial of service (out-of-bounds read) via a crafted repository index file.
- Record
CVE-2018-8098- CVSS 3.1
- 6.5 Medium
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H - Updated
- 2026-11-02
OSVDEBIAN-CVE-2018-8098
6.5
Integer overflow in the index.c:read_entry() function while decompressing a compressed prefix length in libgit2 before v0.26.2 allows an attacker to cause a denial of service (out-of-bounds read) via a crafted repository index file.
- Record
DEBIAN-CVE-2018-8098- CVSS 3.1
- 6.5 Medium
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H - Updated
- 2026-11-02
OSVUBUNTU-CVE-2018-8098
6.5
Integer overflow in the index.c:read_entry() function while decompressing a compressed prefix length in libgit2 before v0.26.2 allows an attacker to cause a denial of service (out-of-bounds read) via a crafted repository index file.
- Record
UBUNTU-CVE-2018-8098- CVSS 3.1
- 6.5 Medium
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H - Updated
- 2026-11-02
OSVopenSUSE-SU-2024:10943-1 No score
libgit2-1_1-1.1.1-1.2 on GA media
These are all security issues fixed in the libgit2-1_1-1.1.1-1.2 package on the GA media of openSUSE Tumbleweed.
- Record
openSUSE-SU-2024:10943-1- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
libgit2Debian:12 |
before 0.27.0+dfsg.1-0.6 | 0.27.0+dfsg.1-0.6 |
libgit2Debian:13 |
before 0.27.0+dfsg.1-0.6 | 0.27.0+dfsg.1-0.6 |
libgit2Debian:14 |
before 0.27.0+dfsg.1-0.6 | 0.27.0+dfsg.1-0.6 |
libgit2Debian:9 |
before 0.25.1+really0.24.6-1+deb9u1, plus listed versions 0.25.1+really0.24.6-1 |
0.25.1+really0.24.6-1+deb9u1 |
libgit2Ubuntu:Pro:18.04:LTS |
before 0.26.0+dfsg.1-1.1ubuntu0.2+esm2, plus listed versions 0.25.1+really0.24.6-10.26.0+dfsg.1-1.10.26.0+dfsg.1-1.1build10.26.0+dfsg.1-1.1ubuntu0.20.26.0+dfsg.1-1.1ubuntu0.2+esm1 |
0.26.0+dfsg.1-1.1ubuntu0.2+esm2 |
libgit2openSUSE:Tumbleweed |
before 1.1.1-1.2 | 1.1.1-1.2 |
History
| Recorded | Changed | Sources |
|---|---|---|
| aliases | EUVD | |
| first indexed | CVE List, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2018-8098 is a medium vulnerability (CVSS 6.5) in Libgit2, published March 14, 2018. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 1.43%, the 73rd percentile. Fixed in libgit2 0.27.0+dfsg.1-0.6.
References
github.com/libgit2/libgit2/commit/3207ddb0103543da8ad2139ec6539f590f9900c1
libgit2.github.com/security
github.com/libgit2/libgit2/commit/3db1af1f370295ad5355b8f64b865a2a357bcac0
lists.debian.org/debian-lts-announce/2022/03/msg00031.html
nvd.nist.gov/vuln/detail/CVE-2018-8098
github.com/advisories/GHSA-m334-hpp6-wjh3
Show 19 moreShow less
security-tracker.debian.org/tracker/CVE-2018-8098
ubuntu.com/security/CVE-2018-8098
cve.org/CVERecord?id=CVE-2018-8098
ubuntu.com/security/notices/USN-8628-1
suse.com/security/cve/CVE-2005-4900
suse.com/security/cve/CVE-2016-10128
suse.com/security/cve/CVE-2016-10130
suse.com/security/cve/CVE-2018-10887
suse.com/security/cve/CVE-2018-11235
suse.com/security/cve/CVE-2018-17456
suse.com/security/cve/CVE-2018-8098
suse.com/security/cve/CVE-2019-1348
suse.com/security/cve/CVE-2019-1349
suse.com/security/cve/CVE-2019-1350
suse.com/security/cve/CVE-2019-1351
suse.com/security/cve/CVE-2019-1352
suse.com/security/cve/CVE-2019-1353
suse.com/security/cve/CVE-2019-1354
suse.com/security/cve/CVE-2019-1387