CVE-2018-8831
A Persistent XSS vulnerability exists in Kodi (formerly XBMC) through 17.6 that allows the...
A Persistent XSS vulnerability exists in Kodi (formerly XBMC) through 17.6 that allows the execution of arbitrary HTML/script code in the context of the victim user's browser via a playlist.
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- Low
- Privileges needed
- None
- User interaction
- Required
What an attacker can affect
- Confidentiality
- Low
- Integrity
- Low
- Availability
- None
Exploit likelihood
What each source reports
NVD Score used
6.1
A Persistent XSS vulnerability exists in Kodi (formerly XBMC) through 17.6 that allows the execution of arbitrary HTML/script code in the context of the victim user's browser via a playlist.
- Record
CVE-2018-8831- CVSS 3.0
- 6.1 Medium
CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N - CVSS 2.0
- 4.3 Medium
AV:N/AC:M/Au:N/C:N/I:P/A:N - Weakness
- CWE-79
- Updated
- 2026-11-02
CVE List No score
A Persistent XSS vulnerability exists in Kodi (formerly XBMC) through 17.6 that allows the execution of arbitrary HTML/script code in the context of the victim user's browser via a playlist.
- Record
CVE-2018-8831- Updated
- 2026-11-02
EUVDEUVD-2018-20439 No score
A Persistent XSS vulnerability exists in Kodi (formerly XBMC) through 17.6 that allows the execution of arbitrary HTML/script code in the context of the victim user's browser via a playlist.
- Record
EUVD-2018-20439- Updated
- 2026-11-03
GitHub AdvisoriesGHSA-h8r8-r3f3-wmh3
6.1
A Persistent XSS vulnerability exists in Kodi (formerly XBMC) through 17.6 that allows the...
A Persistent XSS vulnerability exists in Kodi (formerly XBMC) through 17.6 that allows the execution of arbitrary HTML/script code in the context of the victim user's browser via a playlist.
- Record
GHSA-h8r8-r3f3-wmh3- CVSS 3.0
- 6.1 Medium
CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N - Weakness
- CWE-79
- Updated
- 2026-11-02
OSVALPINE-CVE-2018-8831
6.1
A Persistent XSS vulnerability exists in Kodi (formerly XBMC) through 17.6 that allows the execution of arbitrary HTML/script code in the context of the victim user's browser via a playlist.
- Record
ALPINE-CVE-2018-8831- CVSS 3.0
- 6.1 Medium
CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N - Updated
- 2026-11-03
OSVUBUNTU-CVE-2018-8831
6.1
A Persistent XSS vulnerability exists in Kodi (formerly XBMC) through 17.6 that allows the execution of arbitrary HTML/script code in the context of the victim user's browser via a playlist.
- Record
UBUNTU-CVE-2018-8831- CVSS 3.0
- 6.1 Medium
CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N - Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
kodiAlpine:v3.11 |
before 18.2-r0 | 18.2-r0 |
kodiAlpine:v3.12 |
before 18.2-r0 | 18.2-r0 |
kodiAlpine:v3.13 |
before 18.2-r0 | 18.2-r0 |
kodiAlpine:v3.14 |
before 18.2-r0 | 18.2-r0 |
kodiAlpine:v3.15 |
before 18.2-r0 | 18.2-r0 |
kodiAlpine:v3.16 |
before 18.2-r0 | 18.2-r0 |
kodiAlpine:v3.17 |
before 18.2-r0 | 18.2-r0 |
kodiAlpine:v3.18 |
before 18.2-r0 | 18.2-r0 |
kodiAlpine:v3.19 |
before 18.2-r0 | 18.2-r0 |
kodiAlpine:v3.20 |
before 18.2-r0 | 18.2-r0 |
Show 12 moreShow less
| Package | Affected | Fixed |
|---|---|---|
kodiAlpine:v3.21 |
before 18.2-r0 | 18.2-r0 |
kodiAlpine:v3.22 |
before 18.2-r0 | 18.2-r0 |
kodiAlpine:v3.23 |
before 18.2-r0 | 18.2-r0 |
kodiAlpine:v3.24 |
before 18.2-r0 | 18.2-r0 |
kodiUbuntu:16.04:LTS |
All versions, plus listed versions 15.1+dfsg1-315.2+dfsg1-1build115.2+dfsg1-315.2+dfsg1-3ubuntu115.2+dfsg1-3ubuntu1.1 |
None known |
kodiUbuntu:18.04:LTS |
All versions, plus listed versions 2:17.3+dfsg1-32:17.3+dfsg1-3build12:17.3+dfsg1-52:17.3+dfsg1-5build12:17.3+dfsg1-5build22:17.6+dfsg1-12:17.6+dfsg1-1build12:17.6+dfsg1-1ubuntu1 |
None known |
kodiUbuntu:20.04:LTS |
All versions, plus listed versions 2:17.6+dfsg1-4ubuntu42:17.6+dfsg1-4ubuntu92:17.6+dfsg1-4ubuntu102:18.5+dfsg1-0ubuntu32:18.6+dfsg1-2ubuntu1 |
None known |
kodiUbuntu:22.04:LTS |
All versions, plus listed versions 2:19.1+dfsg2-22:19.3+dfsg1-12:19.3+dfsg1-1build22:19.3+dfsg1-1build32:19.3+dfsg1-1build42:19.3+dfsg1-1build52:19.4+dfsg1-2 |
None known |
kodiUbuntu:24.04:LTS |
All versions, plus listed versions 2:20.2+dfsg-42:20.2+dfsg-4build12:20.2+dfsg-4build22:20.2+dfsg-4ubuntu12:20.3+dfsg-12:20.4+dfsg-12:20.5+dfsg-1build22:20.5+dfsg-1ubuntu1 |
None known |
kodiUbuntu:25.10 |
All versions, plus listed versions 2:21.2+dfsg-1build22:21.2+dfsg-42:21.2+dfsg-4build12:21.2+dfsg-4build2 |
None known |
kodiUbuntu:26.10 |
All versions, plus listed versions 2:21.3+dfsg-1ubuntu12:21.3+dfsg-1.2 |
None known |
kodiUbuntu:26.04:LTS |
All versions, plus listed versions 2:21.2+dfsg-4build22:21.2+dfsg-4build32:21.2+dfsg-52:21.3+dfsg-12:21.3+dfsg-1build12:21.3+dfsg-1ubuntu1 |
None known |
Public exploits
Links only. Every CVE stores no exploit code.
| Source | Link | Date |
|---|---|---|
| Exploit-DB | Kodi 17.6 - Persistent Cross-Site Scripting | 2018-04-18 |
History
| Recorded | Changed | Sources |
|---|---|---|
| affected, aliases, facts, references | OSV | |
| aliases | EUVD | |
| first indexed | CVE List, Exploit-DB, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2018-8831 is a medium vulnerability (CVSS 6.1) in Kodi, published April 18, 2018. Public exploit code exists. EPSS puts the chance of exploitation in the next 30 days at 52.0%, the 98th percentile. Fixed in kodi 18.2-r0.