Every CVE Search/ Get API key

CVE-2018-8975

The pm_mallocarray2 function in lib/util/mallocvar.c in Netpbm through 10.81.03 allows remote...

5.5 MediumFix available

The pm_mallocarray2 function in lib/util/mallocvar.c in Netpbm through 10.81.03 allows remote attackers to cause a denial of service (heap-based buffer over-read) via a crafted image file, as demonstrated by pbmmask.

Attack profile

How easy it is to exploit

Attack vector
Local
Complexity
Low
Privileges needed
None
User interaction
Required

What an attacker can affect

Confidentiality
None
Integrity
None
Availability
High

Exploit likelihood

1.66%Unchanged since Apr 14, 2021
90%50%10%1%

What each source reports

NVD Score used 5.5

The pm_mallocarray2 function in lib/util/mallocvar.c in Netpbm through 10.81.03 allows remote attackers to cause a denial of service (heap-based buffer over-read) via a crafted image file, as demonstrated by pbmmask.

Record
CVE-2018-8975
CVSS 3.0
5.5 MediumCVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H
CVSS 2.0
4.3 MediumAV:N/AC:M/Au:N/C:N/I:N/A:P
Weakness
CWE-125
Updated
2026-11-02
CVE List No score

The pm_mallocarray2 function in lib/util/mallocvar.c in Netpbm through 10.81.03 allows remote attackers to cause a denial of service (heap-based buffer over-read) via a crafted image file, as demonstrated by pbmmask.

Record
CVE-2018-8975
Updated
2026-11-02
EUVDEUVD-2018-20582 No score

The pm_mallocarray2 function in lib/util/mallocvar.c in Netpbm through 10.81.03 allows remote attackers to cause a denial of service (heap-based buffer over-read) via a crafted image file, as demonstrated by pbmmask.

Record
EUVD-2018-20582
Updated
2026-11-03
GitHub AdvisoriesGHSA-vq9h-w3r5-w484 5.5

The pm_mallocarray2 function in lib/util/mallocvar.c in Netpbm through 10.81.03 allows remote...

The pm_mallocarray2 function in lib/util/mallocvar.c in Netpbm through 10.81.03 allows remote attackers to cause a denial of service (heap-based buffer over-read) via a crafted image file, as demonstrated by pbmmask.

Record
GHSA-vq9h-w3r5-w484
CVSS 3.0
5.5 MediumCVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H
Weakness
CWE-125
Updated
2026-11-02
OSVMGASA-2019-0183 No score

Updated netpbm packages fix security vulnerability

The pm_mallocarray2 function allowed remote attackers to cause a denial of service (heap-based buffer over-read) via a crafted image file (CVE-2018-8975).

Record
MGASA-2019-0183
Updated
2026-11-02
OSVopenSUSE-SU-2019:1200-1 No score

Security update for netpbm

This update for netpbm fixes the following issues:

  • CVE-2018-8975: The pm_mallocarray2 function allowed remote attackers to cause a denial of service (heap-based buffer over-read) via a crafted image file (bsc#1086777).

This update was imported from the SUSE:SLE-15:Update update project.

Record
openSUSE-SU-2019:1200-1
Updated
2026-11-02
OSVopenSUSE-SU-2024:11084-1 No score

libnetpbm-devel-10.93.0-1.6 on GA media

These are all security issues fixed in the libnetpbm-devel-10.93.0-1.6 package on the GA media of openSUSE Tumbleweed.

Record
openSUSE-SU-2024:11084-1
Updated
2026-11-02
OSVSUSE-SU-2019:0855-1 No score

Security update for netpbm

This update for netpbm fixes the following issues:

  • CVE-2018-8975: The pm_mallocarray2 function allowed remote attackers to cause a denial of service (heap-based buffer over-read) via a crafted image file (bsc#1086777).
Record
SUSE-SU-2019:0855-1
Updated
2026-11-02
OSVSUSE-SU-2019:1645-1 No score

Security update for netpbm

This update for netpbm fixes the following issues:

Security issues fixed:

  • CVE-2018-8975: The pm_mallocarray2 function allowed remote attackers to cause a denial of service (heap-based buffer over-read) via a crafted image file (bsc#1086777).

  • CVE-2017-2579: Fixed out-of-bounds read in expandCodeOntoStack() (bsc#1024288).

  • CVE-2017-2580: Fixed out-of-bounds write of heap data in addPixelToRaster() function (bsc#1024291).

  • create netpbm-vulnerable subpackage and move pstopnm there (bsc#1136936)

Record
SUSE-SU-2019:1645-1
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
netpbm
Mageia:6
before 10.73.07-1.1.mga6
10.73.07-1.1.mga6
netpbm
SUSE:Linux Enterprise Module for Basesystem 15
before 10.80.1-3.3.36
10.80.1-3.3.36
netpbm
SUSE:Linux Enterprise Module for Desktop Applications 15
before 10.80.1-3.3.36
10.80.1-3.3.36
netpbm
SUSE:Linux Enterprise Desktop 12 SP3
before 10.66.3-8.7.2
10.66.3-8.7.2
netpbm
SUSE:Linux Enterprise Desktop 12 SP4
before 10.66.3-8.7.2
10.66.3-8.7.2
netpbm
SUSE:Linux Enterprise Software Development Kit 12 SP3
before 10.66.3-8.7.2
10.66.3-8.7.2
netpbm
SUSE:Linux Enterprise Software Development Kit 12 SP4
before 10.66.3-8.7.2
10.66.3-8.7.2
netpbm
SUSE:Linux Enterprise Server 12 SP3
before 10.66.3-8.7.2
10.66.3-8.7.2
netpbm
SUSE:Linux Enterprise Server for SAP Applications 12 SP3
before 10.66.3-8.7.2
10.66.3-8.7.2
netpbm
SUSE:Linux Enterprise Server 12 SP4
before 10.66.3-8.7.2
10.66.3-8.7.2
netpbm
SUSE:Linux Enterprise Server for SAP Applications 12 SP4
before 10.66.3-8.7.2
10.66.3-8.7.2
netpbm
openSUSE:Leap 15.0
before 10.80.1-lp150.2.3.1
10.80.1-lp150.2.3.1
netpbm
openSUSE:Tumbleweed
before 10.93.0-1.6
10.93.0-1.6

History

History
RecordedChangedSources
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2018-8975 is a medium vulnerability (CVSS 5.5) in Netpbm Project Netpbm, published March 25, 2018. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 1.66%, the 76th percentile. Fixed in netpbm 10.73.07-1.1.mga6.

References

Show 15 moreShow less
MoveEnter Open