Every CVE Search/ Get API key

CVE-2018-9336

openvpnserv.exe (aka the interactive service helper) in OpenVPN 2.4.x before 2.4.6 allows a local...

7.8 HighFix available

openvpnserv.exe (aka the interactive service helper) in OpenVPN 2.4.x before 2.4.6 allows a local attacker to cause a double-free of memory by sending a malformed request to the interactive service. This could cause a denial-of-service through memory corruption or possibly have unspecified other impact including privilege escalation.

Attack profile

How easy it is to exploit

Attack vector
Local
Complexity
Low
Privileges needed
Low
User interaction
None

What an attacker can affect

Confidentiality
High
Integrity
High
Availability
High

Exploit likelihood

0.59%Unchanged since Apr 14, 2021
90%50%10%1%

What each source reports

NVD Score used 7.8

openvpnserv.exe (aka the interactive service helper) in OpenVPN 2.4.x before 2.4.6 allows a local attacker to cause a double-free of memory by sending a malformed request to the interactive service. This could cause a denial-of-service through memory corruption or possibly have unspecified other impact including privilege escalation.

Record
CVE-2018-9336
CVSS 3.0
7.8 HighCVSS:3.0/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
CVSS 2.0
4.6 MediumAV:L/AC:L/Au:N/C:P/I:P/A:P
Weakness
CWE-415
Updated
2026-11-02
CVE List No score

openvpnserv.exe (aka the interactive service helper) in OpenVPN 2.4.x before 2.4.6 allows a local attacker to cause a double-free of memory by sending a malformed request to the interactive service. This could cause a denial-of-service through memory corruption or possibly have unspecified other impact including privilege escalation.

Record
CVE-2018-9336
Updated
2026-11-02
EUVDEUVD-2018-20930 No score

openvpnserv.exe (aka the interactive service helper) in OpenVPN 2.4.x before 2.4.6 allows a local attacker to cause a double-free of memory by sending a malformed request to the interactive service. This could cause a denial-of-service through memory corruption or possibly have unspecified other impact including privilege escalation.

Record
EUVD-2018-20930
Updated
2026-11-03
GitHub AdvisoriesGHSA-9p34-3252-9gh9 7.8

openvpnserv.exe (aka the interactive service helper) in OpenVPN 2.4.x before 2.4.6 allows a local...

openvpnserv.exe (aka the interactive service helper) in OpenVPN 2.4.x before 2.4.6 allows a local attacker to cause a double-free of memory by sending a malformed request to the interactive service. This could cause a denial-of-service through memory corruption or possibly have unspecified other impact including privilege escalation.

Record
GHSA-9p34-3252-9gh9
CVSS 3.0
7.8 HighCVSS:3.0/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
Weakness
CWE-415
Updated
2026-11-02
OSVALPINE-CVE-2018-9336 7.8

openvpnserv.exe (aka the interactive service helper) in OpenVPN 2.4.x before 2.4.6 allows a local attacker to cause a double-free of memory by sending a malformed request to the interactive service. This could cause a denial-of-service through memory corruption or possibly have unspecified other impact including privilege escalation.

Record
ALPINE-CVE-2018-9336
CVSS 3.0
7.8 HighCVSS:3.0/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
Updated
2026-11-02
OSV 7.8

openvpnserv.exe (aka the interactive service helper) in OpenVPN 2.4.x before 2.4.6 allows a local attacker to cause a double-free of memory by sending a malformed request to the interactive service. This could cause a denial-of-service through memory corruption or possibly have unspecified other impact including privilege escalation.

Record
CVE-2018-9336
CVSS 3.0
7.8 HighCVSS:3.0/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
Updated
2026-11-02
OSVMGASA-2018-0329 No score

Updated openvpn packages fix security vulnerability

Updated openvpn packages fix security vulnerability:

Fix potential double-free() in Interactive Service could lead to denial of service (CVE-2018-9336).

Record
MGASA-2018-0329
Updated
2026-11-02
OSVopenSUSE-SU-2024:11128-1 No score

openvpn-2.5.3-1.2 on GA media

These are all security issues fixed in the openvpn-2.5.3-1.2 package on the GA media of openSUSE Tumbleweed.

Record
openSUSE-SU-2024:11128-1
Updated
2026-11-02
OSVSUSE-SU-2018:1888-1 No score

Security update for openvpn

This update for openvpn fixes the following issues:

  • CVE-2018-9336: Fix potential double-free() in Interactive Service could lead to denial of service (bsc#1090839).
Record
SUSE-SU-2018:1888-1
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
openvpn
Alpine:v3.10
2.4.0 up to 2.4.6-r0
2.4.6-r0
openvpn
Alpine:v3.11
2.4.0 up to 2.4.6-r0
2.4.6-r0
openvpn
Alpine:v3.12
2.4.0 up to 2.4.6-r0
2.4.6-r0
openvpn
Alpine:v3.13
2.4.0 up to 2.4.6-r0
2.4.6-r0
openvpn
Alpine:v3.14
2.4.0 up to 2.4.6-r0
2.4.6-r0
openvpn
Alpine:v3.15
2.4.0 up to 2.4.6-r0
2.4.6-r0
openvpn
Alpine:v3.16
2.4.0 up to 2.4.6-r0
2.4.6-r0
openvpn
Alpine:v3.17
2.4.0 up to 2.4.6-r0
2.4.6-r0
openvpn
Alpine:v3.18
2.4.0 up to 2.4.6-r0
2.4.6-r0
openvpn
Alpine:v3.19
2.4.0 up to 2.4.6-r0
2.4.6-r0
Show 8 moreShow less
Affected packages
PackageAffectedFixed
openvpn
Alpine:v3.20
2.4.0 up to 2.4.6-r0
2.4.6-r0
openvpn
Alpine:v3.21
2.4.0 up to 2.4.6-r0
2.4.6-r0
openvpn
Alpine:v3.22
2.4.0 up to 2.4.6-r0
2.4.6-r0
openvpn
Alpine:v3.23
2.4.0 up to 2.4.6-r0
2.4.6-r0
openvpn
Alpine:v3.24
2.4.0 up to 2.4.6-r0
2.4.6-r0
openvpn
Mageia:6
before 2.4.4-1.1.mga6
2.4.4-1.1.mga6
openvpn
SUSE:Linux Enterprise Module for Basesystem 15
before 2.4.3-5.3.19
2.4.3-5.3.19
openvpn
openSUSE:Tumbleweed
before 2.5.3-1.2
2.5.3-1.2

History

History
RecordedChangedSources
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2018-9336 is a high vulnerability (CVSS 7.8) in Openvpn, published May 1, 2018. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.59%, the 48th percentile. Fixed in openvpn 2.4.6-r0.

References

Show 17 moreShow less
MoveEnter Open