CVE-2018-9988
ARM mbed TLS before 2.1.11, before 2.7.2, and before 2.8.0 has a buffer over-read in...
ARM mbed TLS before 2.1.11, before 2.7.2, and before 2.8.0 has a buffer over-read in ssl_parse_server_key_exchange() that could cause a crash on invalid input.
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- Low
- Privileges needed
- None
- User interaction
- None
What an attacker can affect
- Confidentiality
- None
- Integrity
- None
- Availability
- High
Exploit likelihood
What each source reports
NVD Score used
7.5
ARM mbed TLS before 2.1.11, before 2.7.2, and before 2.8.0 has a buffer over-read in ssl_parse_server_key_exchange() that could cause a crash on invalid input.
- Record
CVE-2018-9988- CVSS 3.1
- 7.5 High
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H - CVSS 2.0
- 5.0 Medium
AV:N/AC:L/Au:N/C:N/I:N/A:P - Weakness
- CWE-125
- Updated
- 2026-11-02
CVE List No score
ARM mbed TLS before 2.1.11, before 2.7.2, and before 2.8.0 has a buffer over-read in ssl_parse_server_key_exchange() that could cause a crash on invalid input.
- Record
CVE-2018-9988- Updated
- 2026-11-02
EUVDEUVD-2018-21580 No score
ARM mbed TLS before 2.1.11, before 2.7.2, and before 2.8.0 has a buffer over-read in ssl_parse_server_key_exchange() that could cause a crash on invalid input.
- Record
EUVD-2018-21580- Updated
- 2026-11-03
GitHub AdvisoriesGHSA-h9j8-4v77-hmr3
7.5
ARM mbed TLS before 2.1.11, before 2.7.2, and before 2.8.0 has a buffer over-read in...
ARM mbed TLS before 2.1.11, before 2.7.2, and before 2.8.0 has a buffer over-read in ssl_parse_server_key_exchange() that could cause a crash on invalid input.
- Record
GHSA-h9j8-4v77-hmr3- CVSS 3.1
- 7.5 High
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H - Weakness
- CWE-125
- Updated
- 2026-11-02
OSV
7.5
ARM mbed TLS before 2.1.11, before 2.7.2, and before 2.8.0 has a buffer over-read in ssl_parse_server_key_exchange() that could cause a crash on invalid input.
- Record
CVE-2018-9988- CVSS 3.1
- 7.5 High
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H - Updated
- 2026-11-02
OSVDEBIAN-CVE-2018-9988
7.5
ARM mbed TLS before 2.1.11, before 2.7.2, and before 2.8.0 has a buffer over-read in ssl_parse_server_key_exchange() that could cause a crash on invalid input.
- Record
DEBIAN-CVE-2018-9988- CVSS 3.1
- 7.5 High
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H - Updated
- 2026-11-02
Show 4 moreShow less
OSVUBUNTU-CVE-2018-9988
7.5
ARM mbed TLS before 2.1.11, before 2.7.2, and before 2.8.0 has a buffer over-read in ssl_parse_server_key_exchange() that could cause a crash on invalid input.
- Record
UBUNTU-CVE-2018-9988- CVSS 3.1
- 7.5 High
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H - Updated
- 2026-11-02
OSVMGASA-2018-0253 No score
Updated mbedtls packages fix security issues
CVE-2018-9988: ARM mbed TLS before 2.1.11, before 2.7.2, and before 2.8.0 has a buffer over-read in ssl_parse_server_key_exchange() that could cause a crash on invalid input. CVE-2018-9989: ARM mbed TLS before 2.1.11, before 2.7.2, and before 2.8.0 has a buffer over-read in ssl_parse_server_psk_hint() that could cause a crash on invalid input.
- Record
MGASA-2018-0253- Updated
- 2026-11-02
OSVopenSUSE-SU-2018:1039-1 No score
Security update for mbedtls
This update for mbedtls fixes the following issues:
Security issues fixed:
- CVE-2018-9988: Fixed buffer over-read in ssl_parse_server_key_exchange() that could cause a crash on invalid input (boo#1089022).
- CVE-2018-9989: Fixed buffer over-read in ssl_parse_server_psk_hint() that could cause a crash on invalid input (boo#1089021).
- Record
openSUSE-SU-2018:1039-1- Updated
- 2026-11-02
OSVopenSUSE-SU-2018:1041-1 No score
Security update for mbedtls
This update for mbedtls fixes the following issues:
Security issues fixed:
- CVE-2018-9988: Fixed buffer over-read in ssl_parse_server_key_exchange() that could cause a crash on invalid input (boo#1089022).
- CVE-2018-9989: Fixed buffer over-read in ssl_parse_server_psk_hint() that could cause a crash on invalid input (boo#1089021).
- Record
openSUSE-SU-2018:1041-1- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
mbedtlsDebian:12 |
before 2.8.0-1 | 2.8.0-1 |
mbedtlsDebian:13 |
before 2.8.0-1 | 2.8.0-1 |
mbedtlsDebian:14 |
before 2.8.0-1 | 2.8.0-1 |
polarsslDebian:8 |
before 1.3.9-2.1+deb8u4, plus listed versions 1.3.9-2.11.3.9-2.1+deb8u11.3.9-2.1+deb8u21.3.9-2.1+deb8u3 |
1.3.9-2.1+deb8u4 |
mbedtlsDebian:9 |
before 2.4.2-1+deb9u4, plus listed versions 2.4.2-12.4.2-1+deb9u12.4.2-1+deb9u1~bpo8+12.4.2-1+deb9u22.4.2-1+deb9u3 |
2.4.2-1+deb9u4 |
bctoolboxMageia:6 |
before 0.2.0-4.2.mga6 | 0.2.0-4.2.mga6 |
hiawathaMageia:6 |
before 10.4-1.2.mga6 | 10.4-1.2.mga6 |
mbedtlsMageia:6 |
before 2.7.3-1.mga6 | 2.7.3-1.mga6 |
shadowsocks-libevMageia:6 |
before 3.1.0-1.2.mga6 | 3.1.0-1.2.mga6 |
dolphin-emuMageia:6 |
before 5.0-5.2.mga6.tainted | 5.0-5.2.mga6.tainted |
mbedtlsUbuntu:16.04:LTS |
All versions, plus listed versions 2.1.2-12.2.0-12.2.1-12.2.1-22.2.1-2ubuntu0.12.2.1-2ubuntu0.22.2.1-2ubuntu0.3 |
None known |
mbedtlsSUSE:Package Hub 12 |
before 1.3.19-14.1 | 1.3.19-14.1 |
History
| Recorded | Changed | Sources |
|---|---|---|
| aliases | EUVD | |
| first indexed | CVE List, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2018-9988 is a high vulnerability (CVSS 7.5) in Arm Mbed Tls, published April 10, 2018. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 2.16%, the 82nd percentile. Fixed in mbedtls 2.8.0-1.
References
lists.debian.org/debian-lts-announce/2018/09/msg00029.html
github.com/ARMmbed/mbedtls/commit/a1098f81c252b317ad34ea978aea2bc47760b215
tls.mbed.org/tech-updates/releases/mbedtls-2.8.0-2.7.2-and-2.1.11-released
github.com/ARMmbed/mbedtls/commit/027f84c69f4ef30c0693832a6c396ef19e563ca1
lists.debian.org/debian-lts-announce/2021/11/msg00021.html
nvd.nist.gov/vuln/detail/CVE-2018-9988
Show 11 moreShow less
github.com/advisories/GHSA-h9j8-4v77-hmr3
security-tracker.debian.org/tracker/CVE-2018-9988
advisories.mageia.org/MGASA-2018-0253.html
bugs.mageia.org/show_bug.cgi?id=22914
lists.opensuse.org/opensuse-updates/2018-04/msg00051.html
ubuntu.com/security/CVE-2018-9988
cve.org/CVERecord?id=CVE-2018-9988
bugzilla.suse.com/1089021
bugzilla.suse.com/1089022
suse.com/security/cve/CVE-2018-9988
suse.com/security/cve/CVE-2018-9989