Every CVE Search/ Get API key

CVE-2019-0188

XML External Entity injection in Apache Camel

7.5 HighFix available

Apache Camel prior to 2.24.0 contains an XML external entity injection (XXE) vulnerability (CWE-611) due to using an outdated vulnerable JSON-lib library. This affects only the camel-xmljson component, which was removed.

Attack profile

How easy it is to exploit

Attack vector
Network
Complexity
Low
Privileges needed
None
User interaction
None

What an attacker can affect

Confidentiality
High
Integrity
None
Availability
None

Exploit likelihood

9.78%Unchanged since Apr 14, 2021
90%50%10%1%

What each source reports

NVD Score used 7.5

Apache Camel prior to 2.24.0 contains an XML external entity injection (XXE) vulnerability (CWE-611) due to using an outdated vulnerable JSON-lib library. This affects only the camel-xmljson component, which was removed.

Record
CVE-2019-0188
CVSS 3.1
7.5 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N
CVSS 2.0
5.0 MediumAV:N/AC:L/Au:N/C:P/I:N/A:N
Weakness
CWE-611
Updated
2026-11-02
CVE List No score

Apache Camel prior to 2.24.0 contains an XML external entity injection (XXE) vulnerability (CWE-611) due to using an outdated vulnerable JSON-lib library. This affects only the camel-xmljson component, which was removed.

Record
CVE-2019-0188
Updated
2026-11-02
EUVDEUVD-2019-0466 No score

Apache Camel prior to 2.24.0 contains an XML external entity injection (XXE) vulnerability (CWE-611) due to using an outdated vulnerable JSON-lib library. This affects only the camel-xmljson component, which was removed.

Record
EUVD-2019-0466
Updated
2026-11-03
GitHub AdvisoriesGHSA-h896-mx9x-g32g 7.5

XML External Entity injection in Apache Camel

Apache Camel prior to 2.24.0 contains an XML external entity injection (XXE) vulnerability (CWE-611) due to using an outdated vulnerable JSON-lib library. This affects only the camel-xmljson component, which was removed.

Record
GHSA-h896-mx9x-g32g
CVSS 3.1
7.5 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N
Weakness
CWE-611
Updated
2026-11-02
OSV 7.5

Apache Camel prior to 2.24.0 contains an XML external entity injection (XXE) vulnerability (CWE-611) due to using an outdated vulnerable JSON-lib library. This affects only the camel-xmljson component, which was removed.

Record
CVE-2019-0188
CVSS 3.1
7.5 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N
Updated
2026-11-02
OSVGHSA-h896-mx9x-g32g 7.5

XML External Entity injection in Apache Camel

Apache Camel prior to 2.24.0 contains an XML external entity injection (XXE) vulnerability (CWE-611) due to using an outdated vulnerable JSON-lib library. This affects only the camel-xmljson component, which was removed.

Record
GHSA-h896-mx9x-g32g
CVSS 3.1
7.5 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N
Weakness
CWE-611
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
org.apache.camel:camel-core
Maven
before 2.24.0
2.24.0
org.apache.camel:camel-xmljson
Maven
through 2.23.4 None known
org.apache.camel:camel-core
Maven
before 2.24.0, plus listed versions
1.0.01.1.01.2.01.3.01.4.0
Show 45 moreShow less
1.5.01.6.01.6.11.6.21.6.31.6.42.0-M12.0-M22.0-M32.0.02.1.02.10.02.10.12.10.22.10.32.10.42.10.52.10.62.10.72.11.02.11.12.11.22.11.32.11.42.12.02.12.12.12.22.12.32.12.42.12.52.13.02.13.12.13.22.13.32.13.42.14.02.14.12.14.22.14.32.14.42.15.02.15.12.15.22.15.32.15.4
2.24.0
org.apache.camel:camel-xmljson
Maven
through 2.23.4, plus listed versions
2.10.02.10.12.10.22.10.32.10.4
Show 45 moreShow less
2.10.52.10.62.10.72.11.02.11.12.11.22.11.32.11.42.12.02.12.12.12.22.12.32.12.42.12.52.13.02.13.12.13.22.13.32.13.42.14.02.14.12.14.22.14.32.14.42.15.02.15.12.15.22.15.32.15.42.15.52.15.62.16.02.16.12.16.22.16.32.16.42.16.52.17.02.17.12.17.22.17.32.17.42.17.52.17.62.17.7
None known

History

History
RecordedChangedSources
aliases, productsEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2019-0188 is a high vulnerability (CVSS 7.5) in Apache Camel, published May 28, 2019. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 9.78%, the 95th percentile. Fixed in org.apache.camel:camel-core 2.24.0.

References

Show 22 moreShow less
This page doesn't list everything

Left out here: 111 versions. The JSON record has them.

MoveEnter Open