Every CVE Search/ Get API key

CVE-2019-0190

A bug exists in the way mod_ssl handled client renegotiations. A remote attacker could send a...

7.5 HighFix available

A bug exists in the way mod_ssl handled client renegotiations. A remote attacker could send a carefully crafted request that would cause mod_ssl to enter a loop leading to a denial of service. This bug can be only triggered with Apache HTTP Server version 2.4.37 when using OpenSSL version 1.1.1 or later, due to an interaction in changes to handling of renegotiation attempts.

Attack profile

How easy it is to exploit

Attack vector
Network
Complexity
Low
Privileges needed
None
User interaction
None

What an attacker can affect

Confidentiality
None
Integrity
None
Availability
High

Exploit likelihood

59.9%Up 44.7 points since Apr 14, 2021
90%50%10%1%

What each source reports

NVD Score used 7.5

A bug exists in the way mod_ssl handled client renegotiations. A remote attacker could send a carefully crafted request that would cause mod_ssl to enter a loop leading to a denial of service. This bug can be only triggered with Apache HTTP Server version 2.4.37 when using OpenSSL version 1.1.1 or later, due to an interaction in changes to handling of renegotiation attempts.

Record
CVE-2019-0190
CVSS 3.1
7.5 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
CVSS 2.0
5.0 MediumAV:N/AC:L/Au:N/C:N/I:N/A:P
Updated
2026-11-02
CVE List No score

A bug exists in the way mod_ssl handled client renegotiations. A remote attacker could send a carefully crafted request that would cause mod_ssl to enter a loop leading to a denial of service. This bug can be only triggered with Apache HTTP Server version 2.4.37 when using OpenSSL version 1.1.1 or later, due to an interaction in changes to handling of renegotiation attempts.

Record
CVE-2019-0190
Updated
2026-11-02
EUVDEUVD-2019-0994 No score

A bug exists in the way mod_ssl handled client renegotiations. A remote attacker could send a carefully crafted request that would cause mod_ssl to enter a loop leading to a denial of service. This bug can be only triggered with Apache HTTP Server version 2.4.37 when using OpenSSL version 1.1.1 or later, due to an interaction in changes to handling of renegotiation attempts.

Record
EUVD-2019-0994
Updated
2026-11-03
GitHub AdvisoriesGHSA-m3q7-x278-m229 7.5

A bug exists in the way mod_ssl handled client renegotiations. A remote attacker could send a...

A bug exists in the way mod_ssl handled client renegotiations. A remote attacker could send a carefully crafted request that would cause mod_ssl to enter a loop leading to a denial of service. This bug can be only triggered with Apache HTTP Server version 2.4.37 when using OpenSSL version 1.1.1 or later, due to an interaction in changes to handling of renegotiation attempts.

Record
GHSA-m3q7-x278-m229
CVSS 3.1
7.5 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Updated
2026-11-02
OSVALPINE-CVE-2019-0190 7.5

A bug exists in the way mod_ssl handled client renegotiations. A remote attacker could send a carefully crafted request that would cause mod_ssl to enter a loop leading to a denial of service. This bug can be only triggered with Apache HTTP Server version 2.4.37 when using OpenSSL version 1.1.1 or later, due to an interaction in changes to handling of renegotiation attempts.

Record
ALPINE-CVE-2019-0190
CVSS 3.1
7.5 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Updated
2026-11-02
OSVBELL-CVE-2019-0190 7.5

CVE-2019-0190 does not affect BellSoft software

Record
BELL-CVE-2019-0190
CVSS 3.1
7.5 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Updated
2026-11-02
OSV 7.5

A bug exists in the way mod_ssl handled client renegotiations. A remote attacker could send a carefully crafted request that would cause mod_ssl to enter a loop leading to a denial of service. This bug can be only triggered with Apache HTTP Server version 2.4.37 when using OpenSSL version 1.1.1 or later, due to an interaction in changes to handling of renegotiation attempts.

Record
CVE-2019-0190
CVSS 3.1
7.5 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Updated
2026-11-02
OSVDEBIAN-CVE-2019-0190 7.5

A bug exists in the way mod_ssl handled client renegotiations. A remote attacker could send a carefully crafted request that would cause mod_ssl to enter a loop leading to a denial of service. This bug can be only triggered with Apache HTTP Server version 2.4.37 when using OpenSSL version 1.1.1 or later, due to an interaction in changes to handling of renegotiation attempts.

Record
DEBIAN-CVE-2019-0190
CVSS 3.1
7.5 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
apache2
Alpine:v3.10
before 2.4.38-r0
2.4.38-r0
apache2
Alpine:v3.11
before 2.4.38-r0
2.4.38-r0
apache2
Alpine:v3.12
before 2.4.38-r0
2.4.38-r0
apache2
Alpine:v3.13
before 2.4.38-r0
2.4.38-r0
apache2
Alpine:v3.14
before 2.4.38-r0
2.4.38-r0
apache2
Alpine:v3.15
before 2.4.38-r0
2.4.38-r0
apache2
Alpine:v3.16
before 2.4.38-r0
2.4.38-r0
apache2
Alpine:v3.17
before 2.4.38-r0
2.4.38-r0
apache2
Alpine:v3.18
before 2.4.38-r0
2.4.38-r0
apache2
Alpine:v3.19
before 2.4.38-r0
2.4.38-r0
Show 12 moreShow less
Affected packages
PackageAffectedFixed
apache2
Alpine:v3.20
before 2.4.38-r0
2.4.38-r0
apache2
Alpine:v3.21
before 2.4.38-r0
2.4.38-r0
apache2
Alpine:v3.22
before 2.4.38-r0
2.4.38-r0
apache2
Alpine:v3.23
before 2.4.38-r0
2.4.38-r0
apache2
Alpine:v3.24
before 2.4.38-r0
2.4.38-r0
apache2
Alpine:v3.6
before 2.4.38-r0
2.4.38-r0
apache2
Alpine:v3.7
before 2.4.38-r0
2.4.38-r0
apache2
Alpine:v3.8
before 2.4.38-r0
2.4.38-r0
apache2
Alpine:v3.9
before 2.4.38-r0
2.4.38-r0
apache2
Debian:12
before 2.4.38-1
2.4.38-1
apache2
Debian:13
before 2.4.38-1
2.4.38-1
apache2
Debian:14
before 2.4.38-1
2.4.38-1

History

History
RecordedChangedSources
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2019-0190 is a high vulnerability (CVSS 7.5) in Apache Http Server, published January 30, 2019. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 59.9%, the 99th percentile. Fixed in apache2 2.4.38-r0.

References

Show 32 moreShow less
MoveEnter Open