Every CVE Search/ Get API key

CVE-2019-0192

Critical severity vulnerability that affects org.apache.solr:solr-core

9.8 CriticalPublic exploitFix available

In Apache Solr versions 5.0.0 to 5.5.5 and 6.0.0 to 6.6.5, the Config API allows to configure the JMX server via an HTTP POST request. By pointing it to a malicious RMI server, an attacker could take advantage of Solr's unsafe deserialization to trigger remote code execution on the Solr side.

Attack profile

How easy it is to exploit

Attack vector
Network
Complexity
Low
Privileges needed
None
User interaction
None

What an attacker can affect

Confidentiality
High
Integrity
High
Availability
High

Exploit likelihood

78.2%Up 29.5 points since Apr 14, 2021
90%50%10%1%

What each source reports

NVD Score used 9.8

In Apache Solr versions 5.0.0 to 5.5.5 and 6.0.0 to 6.6.5, the Config API allows to configure the JMX server via an HTTP POST request. By pointing it to a malicious RMI server, an attacker could take advantage of Solr's unsafe deserialization to trigger remote code execution on the Solr side.

Record
CVE-2019-0192
CVSS 3.0
9.8 CriticalCVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
CVSS 2.0
7.5 HighAV:N/AC:L/Au:N/C:P/I:P/A:P
Weakness
CWE-502
Updated
2026-11-02
CVE List No score

In Apache Solr versions 5.0.0 to 5.5.5 and 6.0.0 to 6.6.5, the Config API allows to configure the JMX server via an HTTP POST request. By pointing it to a malicious RMI server, an attacker could take advantage of Solr's unsafe deserialization to trigger remote code execution on the Solr side.

Record
CVE-2019-0192
Updated
2026-11-02
EUVDEUVD-2019-0397 No score

In Apache Solr versions 5.0.0 to 5.5.5 and 6.0.0 to 6.6.5, the Config API allows to configure the JMX server via an HTTP POST request. By pointing it to a malicious RMI server, an attacker could take advantage of Solr's unsafe deserialization to trigger remote code execution on the Solr side.

Record
EUVD-2019-0397
Updated
2026-11-03
GitHub AdvisoriesGHSA-xhcq-fv7x-grr2 9.8

Critical severity vulnerability that affects org.apache.solr:solr-core

In Apache Solr versions 5.0.0 to 5.5.5 and 6.0.0 to 6.6.5, the Config API allows to configure the JMX server via an HTTP POST request. By pointing it to a malicious RMI server, an attacker could take advantage of Solr's unsafe deserialization to trigger remote code execution on the Solr side.

Record
GHSA-xhcq-fv7x-grr2
CVSS 3.0
9.8 CriticalCVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Weakness
CWE-502
Updated
2026-11-02
OSV 9.8

In Apache Solr versions 5.0.0 to 5.5.5 and 6.0.0 to 6.6.5, the Config API allows to configure the JMX server via an HTTP POST request. By pointing it to a malicious RMI server, an attacker could take advantage of Solr's unsafe deserialization to trigger remote code execution on the Solr side.

Record
CVE-2019-0192
CVSS 3.0
9.8 CriticalCVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Updated
2026-11-02
OSVGHSA-xhcq-fv7x-grr2 9.8

Critical severity vulnerability that affects org.apache.solr:solr-core

In Apache Solr versions 5.0.0 to 5.5.5 and 6.0.0 to 6.6.5, the Config API allows to configure the JMX server via an HTTP POST request. By pointing it to a malicious RMI server, an attacker could take advantage of Solr's unsafe deserialization to trigger remote code execution on the Solr side.

Record
GHSA-xhcq-fv7x-grr2
CVSS 3.0
9.8 CriticalCVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Weakness
CWE-502
Updated
2026-11-02
OSVUBUNTU-CVE-2019-0192 9.8

In Apache Solr versions 5.0.0 to 5.5.5 and 6.0.0 to 6.6.5, the Config API allows to configure the JMX server via an HTTP POST request. By pointing it to a malicious RMI server, an attacker could take advantage of Solr's unsafe deserialization to trigger remote code execution on the Solr side.

Record
UBUNTU-CVE-2019-0192
CVSS 3.0
9.8 CriticalCVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Updated
2026-11-02
OSVCLSA-2026-1790616173 No score

TuxCare security update for org.apache.solr:solr-core (4 CVEs)

TuxCare rebuilt org.apache.solr:solr-core to address 4 CVEs. Fixed in 5.5.5-tuxcare.3.

Record
CLSA-2026-1790616173
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
org.apache.solr:solr-core
Maven
5.0.0 to 5.5.5
7.0.0
org.apache.solr:solr-core
Maven
6.0.0 to 6.6.5
7.0.0
org.apache.solr:solr-core
TuxCare:Maven
From an advisory covering 4 CVEs
5.5.5 up to 5.5.5-tuxcare.3, plus listed versions
5.5.5-tuxcare.15.5.5-tuxcare.2
5.5.5-tuxcare.3
org.apache.solr:solr-core
Maven
5.0.0 up to 7.0.0, plus listed versions
5.1.05.2.05.2.15.3.05.3.1
Show 27 moreShow less
5.3.25.4.05.4.15.5.05.5.15.5.25.5.35.5.45.5.56.0.06.0.16.1.06.2.06.2.16.3.06.4.06.4.16.4.26.5.06.5.16.6.06.6.16.6.26.6.36.6.46.6.56.6.6
7.0.0
org.apache.solr:solr-core
Maven
6.0.0 up to 7.0.0, plus listed versions
6.0.16.1.06.2.06.2.16.3.0
Show 12 moreShow less
6.4.06.4.16.4.26.5.06.5.16.6.06.6.16.6.26.6.36.6.46.6.56.6.6
7.0.0
lucene-solr
Ubuntu:Pro:14.04:LTS
All versions, plus listed versions
3.6.2+dfsg-13.6.2+dfsg-23.6.2+dfsg-2ubuntu0.1~esm13.6.2+dfsg-2ubuntu0.1~esm23.6.2+dfsg-2ubuntu0.1~esm4
None known
lucene-solr
Ubuntu:Pro:16.04:LTS
All versions, plus listed versions
3.6.2+dfsg-73.6.2+dfsg-83.6.2+dfsg-8ubuntu0.13.6.2+dfsg-8ubuntu0.1+esm1
None known
lucene-solr
Ubuntu:Pro:18.04:LTS
All versions, plus listed versions
3.6.2+dfsg-103.6.2+dfsg-113.6.2+dfsg-18~18.043.6.2+dfsg-18~18.04.1~esm2
None known
lucene-solr
Ubuntu:20.04:LTS
All versions, plus listed versions
3.6.2+dfsg-203.6.2+dfsg-22
None known
lucene-solr
Ubuntu:22.04:LTS
All versions, plus listed versions
3.6.2+dfsg-24
None known
Show 4 moreShow less
Affected packages
PackageAffectedFixed
lucene-solr
Ubuntu:24.04:LTS
All versions, plus listed versions
3.6.2+dfsg-26
None known
lucene-solr
Ubuntu:25.10
All versions, plus listed versions
3.6.2+dfsg-26
None known
lucene-solr
Ubuntu:26.10
All versions, plus listed versions
3.6.2+dfsg-27
None known
lucene-solr
Ubuntu:26.04:LTS
All versions, plus listed versions
3.6.2+dfsg-263.6.2+dfsg-27
None known

Public exploits

Links only. Every CVE stores no exploit code.

Public exploits
SourceLinkDate
PoC in GitHubmpgn/CVE-2019-01922019-03-10
PoC in GitHubRapidsafeguard/Solr-RCE-CVE-2019-01922019-11-01
NucleiApache Solr - Deserialization of Untrusted Data

History

History
RecordedChangedSources
affected, exploits, facts
aliasesEUVD
first indexedCVE List, GitHub Advisories, Nuclei, NVD, OSV, PoC in GitHub

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2019-0192 is a critical vulnerability (CVSS 9.8) in Apache Solr, published March 7, 2019. Public exploit code exists. EPSS puts the chance of exploitation in the next 30 days at 78.2%, the 99th percentile. Fixed in org.apache.solr:solr-core 7.0.0.

References

Show 20 moreShow less
MoveEnter Open