Every CVE Search/ Get API key

CVE-2019-0194

Path Traversal in Apache Camel

7.5 HighFix available

Apache Camel's File is vulnerable to directory traversal. Camel 2.21.0 to 2.21.3, 2.22.0 to 2.22.2, 2.23.0 and the unsupported Camel 2.x (2.19 and earlier) versions may be also affected.

Attack profile

How easy it is to exploit

Attack vector
Network
Complexity
Low
Privileges needed
None
User interaction
None

What an attacker can affect

Confidentiality
High
Integrity
None
Availability
None

Exploit likelihood

8.48%Up 2.5 points since Apr 14, 2021
90%50%10%1%

What each source reports

NVD Score used 7.5

Apache Camel's File is vulnerable to directory traversal. Camel 2.21.0 to 2.21.3, 2.22.0 to 2.22.2, 2.23.0 and the unsupported Camel 2.x (2.19 and earlier) versions may be also affected.

Record
CVE-2019-0194
CVSS 3.0
7.5 HighCVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N
CVSS 2.0
5.0 MediumAV:N/AC:L/Au:N/C:P/I:N/A:N
Weakness
CWE-22
Updated
2026-11-02
CVE List No score

Apache Camel's File is vulnerable to directory traversal. Camel 2.21.0 to 2.21.3, 2.22.0 to 2.22.2, 2.23.0 and the unsupported Camel 2.x (2.19 and earlier) versions may be also affected.

Record
CVE-2019-0194
Updated
2026-11-02
EUVDEUVD-2019-0449 No score

Apache Camel's File is vulnerable to directory traversal. Camel 2.21.0 to 2.21.3, 2.22.0 to 2.22.2, 2.23.0 and the unsupported Camel 2.x (2.19 and earlier) versions may be also affected.

Record
EUVD-2019-0449
Updated
2026-11-03
GitHub AdvisoriesGHSA-4wjq-69rc-8wcp 7.5

Path Traversal in Apache Camel

Apache Camel's File is vulnerable to directory traversal. Camel 2.21.0 to 2.21.3, 2.22.0 to 2.22.2, 2.23.0 and the unsupported Camel 2.x (2.19 and earlier) versions may be also affected.

Record
GHSA-4wjq-69rc-8wcp
CVSS 3.0
7.5 HighCVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N
Weakness
CWE-22
Updated
2026-11-02
OSV 7.5

Apache Camel's File is vulnerable to directory traversal. Camel 2.21.0 to 2.21.3, 2.22.0 to 2.22.2, 2.23.0 and the unsupported Camel 2.x (2.19 and earlier) versions may be also affected.

Record
CVE-2019-0194
CVSS 3.0
7.5 HighCVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N
Updated
2026-11-02
OSVGHSA-4wjq-69rc-8wcp 7.5

Path Traversal in Apache Camel

Apache Camel's File is vulnerable to directory traversal. Camel 2.21.0 to 2.21.3, 2.22.0 to 2.22.2, 2.23.0 and the unsupported Camel 2.x (2.19 and earlier) versions may be also affected.

Record
GHSA-4wjq-69rc-8wcp
CVSS 3.0
7.5 HighCVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N
Weakness
CWE-22
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
org.apache.camel:camel-core
Maven
2.21.0 to 2.21.3
2.21.5
org.apache.camel:camel-core
Maven
2.22.0 up to 2.22.3
2.22.3
org.apache.camel:camel-core
Maven
2.23.0 to 2.23.0
2.23.1
org.apache.camel:camel-core
Maven
2.21.0 up to 2.21.5, plus listed versions
2.21.12.21.22.21.32.21.4
2.21.5
org.apache.camel:camel-core
Maven
2.22.0 up to 2.22.3, plus listed versions
2.22.12.22.2
2.22.3
org.apache.camel:camel-core
Maven
2.23.0 up to 2.23.1
2.23.1

History

History
RecordedChangedSources
aliases, productsEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2019-0194 is a high vulnerability (CVSS 7.5) in Apache Camel, published April 30, 2019. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 8.48%, the 95th percentile. Fixed in org.apache.camel:camel-core 2.21.5.

References

Show 12 moreShow less
MoveEnter Open