Every CVE Search/ Get API key

CVE-2019-0226

Apache Karaf vulnerable to relative path traversal

4.9 MediumFix available

Apache Karaf Config service provides a install method (via service or MBean) that could be used to travel in any directory and overwrite existing file. The vulnerability is low if the Karaf process user has limited permission on the filesystem. Any Apache Karaf version before 4.2.5 is impacted. User should upgrade to Apache Karaf 4.2.5 or later.

Attack profile

How easy it is to exploit

Attack vector
Network
Complexity
Low
Privileges needed
High
User interaction
None

What an attacker can affect

Confidentiality
None
Integrity
High
Availability
None

Exploit likelihood

1.80%Down 0.1 points since Apr 14, 2021
90%50%10%1%

What each source reports

NVD Score used 4.9

Apache Karaf Config service provides a install method (via service or MBean) that could be used to travel in any directory and overwrite existing file. The vulnerability is low if the Karaf process user has limited permission on the filesystem. Any Apache Karaf version before 4.2.5 is impacted. User should upgrade to Apache Karaf 4.2.5 or later.

Record
CVE-2019-0226
CVSS 3.0
4.9 MediumCVSS:3.0/AV:N/AC:L/PR:H/UI:N/S:U/C:N/I:H/A:N
CVSS 2.0
5.5 MediumAV:N/AC:L/Au:S/C:N/I:P/A:P
Weakness
CWE-22
Updated
2026-11-02
CVE List No score

Apache Karaf Config service provides a install method (via service or MBean) that could be used to travel in any directory and overwrite existing file. The vulnerability is low if the Karaf process user has limited permission on the filesystem. Any Apache Karaf version before 4.2.5 is impacted. User should upgrade to Apache Karaf 4.2.5 or later.

Record
CVE-2019-0226
Updated
2026-11-02
EUVDEUVD-2022-3800 No score

Apache Karaf Config service provides a install method (via service or MBean) that could be used to travel in any directory and overwrite existing file. The vulnerability is low if the Karaf process user has limited permission on the filesystem. Any Apache Karaf version before 4.2.5 is impacted. User should upgrade to Apache Karaf 4.2.5 or later.

Record
EUVD-2022-3800
Updated
2026-11-03
GitHub AdvisoriesGHSA-fjw4-39pg-vf4f 4.9

Apache Karaf vulnerable to relative path traversal

Apache Karaf Config service provides a install method (via service or MBean) that could be used to travel in any directory and overwrite existing file. The vulnerability is low if the Karaf process user has limited permission on the filesystem. Any Apache Karaf version before 4.2.5 is impacted. User should upgrade to Apache Karaf 4.2.5 or later.

Record
GHSA-fjw4-39pg-vf4f
CVSS 3.0
4.9 MediumCVSS:3.0/AV:N/AC:L/PR:H/UI:N/S:U/C:N/I:H/A:N
Weakness
CWE-22
Updated
2026-11-02
OSV 4.9

Apache Karaf Config service provides a install method (via service or MBean) that could be used to travel in any directory and overwrite existing file. The vulnerability is low if the Karaf process user has limited permission on the filesystem. Any Apache Karaf version before 4.2.5 is impacted. User should upgrade to Apache Karaf 4.2.5 or later.

Record
CVE-2019-0226
CVSS 3.0
4.9 MediumCVSS:3.0/AV:N/AC:L/PR:H/UI:N/S:U/C:N/I:H/A:N
Updated
2026-11-02
OSVGHSA-fjw4-39pg-vf4f 4.9

Apache Karaf vulnerable to relative path traversal

Apache Karaf Config service provides a install method (via service or MBean) that could be used to travel in any directory and overwrite existing file. The vulnerability is low if the Karaf process user has limited permission on the filesystem. Any Apache Karaf version before 4.2.5 is impacted. User should upgrade to Apache Karaf 4.2.5 or later.

Record
GHSA-fjw4-39pg-vf4f
CVSS 3.0
4.9 MediumCVSS:3.0/AV:N/AC:L/PR:H/UI:N/S:U/C:N/I:H/A:N
Weakness
CWE-22
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
org.apache.karaf.config:org.apache.karaf.config.core
Maven
before 4.2.5
4.2.5
org.apache.karaf.config:org.apache.karaf.config.core
Maven
before 4.2.5, plus listed versions
3.0.03.0.0.RC13.0.13.0.103.0.2
Show 36 moreShow less
3.0.33.0.43.0.53.0.63.0.73.0.83.0.94.0.04.0.0.M14.0.0.M24.0.0.M34.0.14.0.104.0.24.0.34.0.44.0.54.0.64.0.74.0.84.0.94.1.04.1.14.1.24.1.34.1.44.1.54.1.64.1.74.2.04.2.0.M14.2.0.M24.2.14.2.24.2.34.2.4
4.2.5

History

History
RecordedChangedSources
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2019-0226 is a medium vulnerability (CVSS 4.9) in Apache Karaf, published May 9, 2019. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 1.80%, the 78th percentile. Fixed in org.apache.karaf.config:org.apache.karaf.config.core 4.2.5.

References

MoveEnter Open