Every CVE Search/ Get API key

CVE-2019-0233

Improper Preservation of Permissions in Apache Struts

7.5 HighFix available

An access permission override in Apache Struts 2.0.0 to 2.5.20 may cause a Denial of Service when performing a file upload.

Attack profile

How easy it is to exploit

Attack vector
Network
Complexity
Low
Privileges needed
None
User interaction
None

What an attacker can affect

Confidentiality
None
Integrity
None
Availability
High

Exploit likelihood

66.1%Up 63.1 points since Apr 14, 2021
90%50%10%1%

What each source reports

NVD Score used 7.5

An access permission override in Apache Struts 2.0.0 to 2.5.20 may cause a Denial of Service when performing a file upload.

Record
CVE-2019-0233
CVSS 3.1
7.5 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
CVSS 2.0
5.0 MediumAV:N/AC:L/Au:N/C:N/I:N/A:P
Weakness
CWE-281
Updated
2026-11-02
CVE List No score

An access permission override in Apache Struts 2.0.0 to 2.5.20 may cause a Denial of Service when performing a file upload.

Record
CVE-2019-0233
Updated
2026-11-02
EUVDEUVD-2022-3561 No score

An access permission override in Apache Struts 2.0.0 to 2.5.20 may cause a Denial of Service when performing a file upload.

Record
EUVD-2022-3561
Updated
2026-11-03
GitHub AdvisoriesGHSA-ccp5-gg58-pxfm 7.5

Improper Preservation of Permissions in Apache Struts

An access permission override in Apache Struts 2.0.0 to 2.5.20 may cause a Denial of Service when performing a file upload.

Record
GHSA-ccp5-gg58-pxfm
CVSS 3.1
7.5 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Weakness
CWE-281
Updated
2026-11-02
OSV 7.5

An access permission override in Apache Struts 2.0.0 to 2.5.20 may cause a Denial of Service when performing a file upload.

Record
CVE-2019-0233
CVSS 3.1
7.5 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Updated
2026-11-02
OSVGHSA-ccp5-gg58-pxfm 7.5

Improper Preservation of Permissions in Apache Struts

An access permission override in Apache Struts 2.0.0 to 2.5.20 may cause a Denial of Service when performing a file upload.

Record
GHSA-ccp5-gg58-pxfm
CVSS 3.1
7.5 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Weakness
CWE-281
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
org.apache.struts:struts2-core
Maven
2.0.0 up to 2.5.22
2.5.22
org.apache.struts:struts2-core
Maven
2.0.0 up to 2.5.22, plus listed versions
2.0.112.0.11.12.0.11.22.0.122.0.14
Show 45 moreShow less
2.0.52.0.62.0.82.0.92.1.22.1.62.1.82.1.8.12.2.12.2.1.12.2.32.2.3.12.3.12.3.1.12.3.1.22.3.122.3.142.3.14.12.3.14.22.3.14.32.3.152.3.15.12.3.15.22.3.15.32.3.162.3.16.12.3.16.22.3.16.32.3.202.3.20.12.3.20.32.3.242.3.24.12.3.24.32.3.282.3.28.12.3.292.3.32.3.302.3.312.3.322.3.332.3.342.3.352.3.36
2.5.22

History

History
RecordedChangedSources
aliases, productsEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2019-0233 is a high vulnerability (CVSS 7.5) in Apache Struts, published September 14, 2020. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 66.1%, the 99th percentile. Fixed in org.apache.struts:struts2-core 2.5.22.

References

This page doesn't list everything

Left out here: 23 versions. The JSON record has them.

MoveEnter Open