CVE-2019-0542
xterm vulnerable to remote code execution
A remote code execution vulnerability exists in Xterm.js when the component mishandles special characters, aka "Xterm Remote Code Execution Vulnerability." This affects xterm.js.
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- Low
- Privileges needed
- None
- User interaction
- Required
What an attacker can affect
- Confidentiality
- High
- Integrity
- High
- Availability
- High
Exploit likelihood
What each source reports
NVD Score used
8.8
A remote code execution vulnerability exists in Xterm.js when the component mishandles special characters, aka "Xterm Remote Code Execution Vulnerability." This affects xterm.js.
- Record
CVE-2019-0542- CVSS 3.1
- 8.8 High
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H - CVSS 2.0
- 6.8 Medium
AV:N/AC:M/Au:N/C:P/I:P/A:P - Weakness
- CWE-94
- Updated
- 2026-11-02
CVE List No score
A remote code execution vulnerability exists in Xterm.js when the component mishandles special characters, aka "Xterm Remote Code Execution Vulnerability." This affects xterm.js.
- Record
CVE-2019-0542- Updated
- 2026-11-02
EUVDEUVD-2019-0189 No score
A remote code execution vulnerability exists in Xterm.js when the component mishandles special characters, aka "Xterm Remote Code Execution Vulnerability." This affects xterm.js.
- Record
EUVD-2019-0189- Updated
- 2026-11-03
GitHub AdvisoriesGHSA-mc23-976p-j42x
8.8
xterm vulnerable to remote code execution
A remote code execution vulnerability exists in Xterm.js when the component mishandles special characters.
- Record
GHSA-mc23-976p-j42x- CVSS 3.1
- 8.8 High
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H - Weakness
- CWE-94
- Updated
- 2026-11-02
OSV
8.8
A remote code execution vulnerability exists in Xterm.js when the component mishandles special characters, aka "Xterm Remote Code Execution Vulnerability." This affects xterm.js.
- Record
CVE-2019-0542- CVSS 3.1
- 8.8 High
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H - Updated
- 2026-11-02
OSVDEBIAN-CVE-2019-0542
8.8
A remote code execution vulnerability exists in Xterm.js when the component mishandles special characters, aka "Xterm Remote Code Execution Vulnerability." This affects xterm.js.
- Record
DEBIAN-CVE-2019-0542- CVSS 3.1
- 8.8 High
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H - Updated
- 2026-11-02
Show 4 moreShow less
OSVGHSA-mc23-976p-j42x
8.8
xterm vulnerable to remote code execution
A remote code execution vulnerability exists in Xterm.js when the component mishandles special characters.
- Record
GHSA-mc23-976p-j42x- CVSS 3.1
- 8.8 High
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H - Weakness
- CWE-94
- Updated
- 2026-11-02
OSVRHSA-2019:1422
7.5
Red Hat Security Advisory: OpenShift Container Platform 3.11 atomic-openshift-web-console security update
- Record
RHSA-2019:1422- CVSS 3.0
- 7.5 High
CVSS:3.0/AV:N/AC:H/PR:N/UI:R/S:U/C:H/I:H/A:H - Updated
- 2026-11-02
OSVRHSA-2019:2551
7.5
Red Hat Security Advisory: OpenShift Container Platform 3.9 atomic-openshift-web-console security update
- Record
RHSA-2019:2551- CVSS 3.0
- 7.5 High
CVSS:3.0/AV:N/AC:H/PR:N/UI:R/S:U/C:H/I:H/A:H - Updated
- 2026-11-02
OSVRHSA-2019:2552
7.5
Red Hat Security Advisory: OpenShift Container Platform 3.10 atomic-openshift-web-console security update
- Record
RHSA-2019:2552- CVSS 3.0
- 7.5 High
CVSS:3.0/AV:N/AC:H/PR:N/UI:R/S:U/C:H/I:H/A:H - Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
xtermnpm |
before 3.8.1 | 3.8.1 |
xtermnpm |
3.9.0 up to 3.9.2 | 3.9.2 |
xtermnpm |
3.10.0 up to 3.10.1 | 3.10.1 |
node-xtermDebian:12 |
before 3.8.1-1 | 3.8.1-1 |
node-xtermDebian:13 |
before 3.8.1-1 | 3.8.1-1 |
node-xtermDebian:14 |
before 3.8.1-1 | 3.8.1-1 |
atomic-openshift-web-consoleRed Hat:openshift:3.11::el7 |
before 0:3.11.104-1.git.1.3c3a7f2.el7 | 0:3.11.104-1.git.1.3c3a7f2.el7 |
atomic-openshift-web-consoleRed Hat:openshift:3.9::el7 |
before 0:3.9.99-1.git.1.49cd7e9.el7 | 0:3.9.99-1.git.1.49cd7e9.el7 |
atomic-openshift-web-consoleRed Hat:openshift:3.10::el7 |
before 0:3.10.163-1.git.1.c3a2131.el7 | 0:3.10.163-1.git.1.c3a2131.el7 |
History
| Recorded | Changed | Sources |
|---|---|---|
| aliases | EUVD | |
| first indexed | CVE List, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2019-0542 is a high vulnerability (CVSS 8.8) in Https://xtermjs.org/ Xterm.js, published January 9, 2019. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 3.17%, the 88th percentile. Fixed in xterm 3.8.1.
References
securityfocus.com/bid/106434
access.redhat.com/errata/RHBA-2019:0959
access.redhat.com/errata/RHSA-2019:1422
access.redhat.com/errata/RHSA-2019:2552
access.redhat.com/errata/RHSA-2019:2551
github.com/xtermjs/xterm.js/releases
Show 13 moreShow less
nvd.nist.gov/vuln/detail/CVE-2019-0542
github.com/advisories/GHSA-mc23-976p-j42x
github.com/xtermjs/xterm.js/commit/3592c641cd0348e0b698e8a180aea2072c6bcd9a
github.com/xtermjs/xterm.js/releases/tag/3.8.1
security-tracker.debian.org/tracker/CVE-2019-0542
github.com/xtermjs/xterm.js
access.redhat.com/security/updates/classification
bugzilla.redhat.com/show_bug.cgi?id=1668531
security.access.redhat.com/data/csaf/v2/advisories/2019/rhsa-2019_1422.json
access.redhat.com/security/cve/CVE-2019-0542
cve.org/CVERecord?id=CVE-2019-0542
security.access.redhat.com/data/csaf/v2/advisories/2019/rhsa-2019_2551.json
security.access.redhat.com/data/csaf/v2/advisories/2019/rhsa-2019_2552.json