Every CVE Search/ Get API key

CVE-2019-1000018

rssh version 2.3.4 contains a CWE-77: Improper Neutralization of Special Elements used in a...

7.8 HighFix available

rssh version 2.3.4 contains a CWE-77: Improper Neutralization of Special Elements used in a Command ('Command Injection') vulnerability in allowscp permission that can result in Local command execution. This attack appear to be exploitable via An authorized SSH user with the allowscp permission.

Attack profile

How easy it is to exploit

Attack vector
Local
Complexity
Low
Privileges needed
Low
User interaction
None

What an attacker can affect

Confidentiality
High
Integrity
High
Availability
High

Exploit likelihood

1.88%Up 0.1 points since Apr 14, 2021
90%50%10%1%

What each source reports

NVD Score used 7.8

rssh version 2.3.4 contains a CWE-77: Improper Neutralization of Special Elements used in a Command ('Command Injection') vulnerability in allowscp permission that can result in Local command execution. This attack appear to be exploitable via An authorized SSH user with the allowscp permission.

Record
CVE-2019-1000018
CVSS 3.1
7.8 HighCVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
CVSS 2.0
4.6 MediumAV:L/AC:L/Au:N/C:P/I:P/A:P
Weakness
CWE-77
Updated
2026-11-02
CVE List No score

rssh version 2.3.4 contains a CWE-77: Improper Neutralization of Special Elements used in a Command ('Command Injection') vulnerability in allowscp permission that can result in Local command execution. This attack appear to be exploitable via An authorized SSH user with the allowscp permission.

Record
CVE-2019-1000018
Updated
2026-11-02
EUVDEUVD-2019-1737 0.0

rssh version 2.3.4 contains a CWE-77: Improper Neutralization of Special Elements used in a Command ('Command Injection') vulnerability in allowscp permission that can result in Local command execution. This attack appear to be exploitable via An authorized SSH user with the allowscp permission.

Record
EUVD-2019-1737
CVSS
0.0 NoneCVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
Updated
2026-11-02
GitHub AdvisoriesGHSA-w832-4843-q4m8 7.8

rssh version 2.3.4 contains a CWE-77: Improper Neutralization of Special Elements used in a...

rssh version 2.3.4 contains a CWE-77: Improper Neutralization of Special Elements used in a Command ('Command Injection') vulnerability in allowscp permission that can result in Local command execution. This attack appear to be exploitable via An authorized SSH user with the allowscp permission.

Record
GHSA-w832-4843-q4m8
CVSS 3.1
7.8 HighCVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
Weakness
CWE-77
Updated
2026-11-02
OSVALPINE-CVE-2019-1000018 7.8

rssh version 2.3.4 contains a CWE-77: Improper Neutralization of Special Elements used in a Command ('Command Injection') vulnerability in allowscp permission that can result in Local command execution. This attack appear to be exploitable via An authorized SSH user with the allowscp permission.

Record
ALPINE-CVE-2019-1000018
CVSS 3.1
7.8 HighCVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
Updated
2026-11-02
OSV 7.8

rssh version 2.3.4 contains a CWE-77: Improper Neutralization of Special Elements used in a Command ('Command Injection') vulnerability in allowscp permission that can result in Local command execution. This attack appear to be exploitable via An authorized SSH user with the allowscp permission.

Record
CVE-2019-1000018
CVSS 3.1
7.8 HighCVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
Updated
2026-11-02
OSVUBUNTU-CVE-2019-1000018 7.8

rssh version 2.3.4 contains a CWE-77: Improper Neutralization of Special Elements used in a Command ('Command Injection') vulnerability in allowscp permission that can result in Local command execution. This attack appear to be exploitable via An authorized SSH user with the allowscp permission.

Record
UBUNTU-CVE-2019-1000018
CVSS 3.1
7.8 HighCVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
CVSS 3.0
7.8 HighCVSS:3.0/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
Updated
2026-11-02
OSVUSN-3946-1 No score

rssh vulnerabilities

It was discovered that rssh incorrectly handled certain command-line arguments and environment variables. An authenticated user could bypass rssh's command restrictions, allowing an attacker to run arbitrary commands.

Record
USN-3946-1
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
rssh
Alpine:v3.13
before 2.3.4-r2
2.3.4-r2
rssh
Alpine:v3.14
before 2.3.4-r2
2.3.4-r2
rssh
Alpine:v3.15
before 2.3.4-r2
2.3.4-r2
rssh
Alpine:v3.16
before 2.3.4-r2
2.3.4-r2
rssh
Alpine:v3.17
before 2.3.4-r2
2.3.4-r2
rssh
Alpine:v3.18
before 2.3.4-r2
2.3.4-r2
rssh
Alpine:v3.19
before 2.3.4-r2
2.3.4-r2
rssh
Alpine:v3.20
before 2.3.4-r2
2.3.4-r2
rssh
Alpine:v3.21
before 2.3.4-r2
2.3.4-r2
rssh
Alpine:v3.22
before 2.3.4-r2
2.3.4-r2
Show 8 moreShow less
Affected packages
PackageAffectedFixed
rssh
Debian:8
before 2.3.4-4+deb8u1, plus listed versions
2.3.4-4
2.3.4-4+deb8u1
rssh
Debian:9
before 2.3.4-5+deb9u1, plus listed versions
2.3.4-5
2.3.4-5+deb9u1
rssh
Ubuntu:14.04:LTS
before 2.3.4-4+deb8u2ubuntu0.14.04.2, plus listed versions
2.3.4-32.3.4-42.3.4-4+deb8u1build0.14.04.12.3.4-4+deb8u2build0.14.04.12.3.4-4+deb8u2ubuntu0.14.04.1
2.3.4-4+deb8u2ubuntu0.14.04.2
rssh
Ubuntu:16.04:LTS
before 2.3.4-4+deb8u2ubuntu0.16.04.2, plus listed versions
2.3.4-42.3.4-4+deb8u1build0.16.04.12.3.4-4+deb8u2build0.16.04.12.3.4-4+deb8u2ubuntu0.16.04.1
2.3.4-4+deb8u2ubuntu0.16.04.2
rssh
Ubuntu:18.04:LTS
before 2.3.4-7ubuntu0.1, plus listed versions
2.3.4-52.3.4-62.3.4-7
2.3.4-7ubuntu0.1
rssh
Ubuntu:14.04:LTS
From an advisory covering 3 CVEs
before 2.3.4-4+deb8u2ubuntu0.14.04.2, plus listed versions
2.3.4-32.3.4-42.3.4-4+deb8u1build0.14.04.12.3.4-4+deb8u2build0.14.04.12.3.4-4+deb8u2ubuntu0.14.04.1
2.3.4-4+deb8u2ubuntu0.14.04.2
rssh
Ubuntu:16.04:LTS
From an advisory covering 3 CVEs
before 2.3.4-4+deb8u2ubuntu0.16.04.2, plus listed versions
2.3.4-42.3.4-4+deb8u1build0.16.04.12.3.4-4+deb8u2build0.16.04.12.3.4-4+deb8u2ubuntu0.16.04.1
2.3.4-4+deb8u2ubuntu0.16.04.2
rssh
Ubuntu:18.04:LTS
From an advisory covering 3 CVEs
before 2.3.4-7ubuntu0.1, plus listed versions
2.3.4-52.3.4-62.3.4-7
2.3.4-7ubuntu0.1

History

History
RecordedChangedSources
affected, facts
first indexedCVE List, EUVD, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2019-1000018 is a high vulnerability (CVSS 7.8) in Pizzashack Rssh, published January 30, 2019. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 1.88%, the 79th percentile. Fixed in rssh 2.3.4-r2.

References

Show 17 moreShow less
MoveEnter Open