CVE-2019-10019
An issue was discovered in Xpdf 4.01.01. There is an FPE in the function PSOutputDev:...
An issue was discovered in Xpdf 4.01.01. There is an FPE in the function PSOutputDev::checkPageSlice at PSOutputDev.cc for nStripes.
Attack profile
How easy it is to exploit
- Attack vector
- Local
- Complexity
- Low
- Privileges needed
- None
- User interaction
- Required
What an attacker can affect
- Confidentiality
- None
- Integrity
- None
- Availability
- High
Exploit likelihood
What each source reports
NVD Score used
5.5
An issue was discovered in Xpdf 4.01.01. There is an FPE in the function PSOutputDev::checkPageSlice at PSOutputDev.cc for nStripes.
- Record
CVE-2019-10019- CVSS 3.0
- 5.5 Medium
CVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H - CVSS 2.0
- 4.3 Medium
AV:N/AC:M/Au:N/C:N/I:N/A:P - Weakness
- CWE-369
- Updated
- 2026-11-02
CVE List No score
An issue was discovered in Xpdf 4.01.01. There is an FPE in the function PSOutputDev::checkPageSlice at PSOutputDev.cc for nStripes.
- Record
CVE-2019-10019- Updated
- 2026-11-02
EUVDEUVD-2019-2083 No score
An issue was discovered in Xpdf 4.01.01. There is an FPE in the function PSOutputDev::checkPageSlice at PSOutputDev.cc for nStripes.
- Record
EUVD-2019-2083- Updated
- 2026-11-03
GitHub AdvisoriesGHSA-jqhh-g8q4-pp8j
5.5
An issue was discovered in Xpdf 4.01.01. There is an FPE in the function PSOutputDev:...
An issue was discovered in Xpdf 4.01.01. There is an FPE in the function PSOutputDev::checkPageSlice at PSOutputDev.cc for nStripes.
- Record
GHSA-jqhh-g8q4-pp8j- CVSS 3.0
- 5.5 Medium
CVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H - Weakness
- CWE-369
- Updated
- 2026-11-02
OSVUBUNTU-CVE-2019-10019
5.5
An issue was discovered in Xpdf 4.01.01. There is an FPE in the function PSOutputDev::checkPageSlice at PSOutputDev.cc for nStripes.
- Record
UBUNTU-CVE-2019-10019- CVSS 3.0
- 5.5 Medium
CVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H - Updated
- 2026-11-02
OSVMGASA-2019-0293 No score
Updated xpdf packages fix security vulnerabilities
The updated xpdf packages fix security vulnerabilities:
An issue was discovered in Xpdf 4.01.01. There is an FPE in the function PostScriptFunction::exec at Function.cc for the psOpIdiv case. (CVE-2019-10018)
An issue was discovered in Xpdf 4.01.01. There is an FPE in the function PSOutputDev::checkPageSlice at PSOutputDev.cc for nStripes. (CVE-2019-10019)
An issue was discovered in Xpdf 4.01.01. There is an FPE in the function ImageStream::ImageStream at Stream.cc for nComps. (CVE-2019-10021)
An issue was discovered in Xpdf 4.01.01. There is an FPE in the function PostScriptFunction::exec at Function.cc for the psOpMod case. (CVE-2019-10023)
Xpdf 4.01.01 has an out-of-bounds write in the vertProfile part of the TextPage::findGaps function in TextOutputDev.cc, a different vulnerability than CVE-2019-9877. (CVE-2019-16927)
- Record
MGASA-2019-0293- Updated
- 2026-11-02
OSVUSN-4042-1 No score
poppler vulnerabilities
It was discovered that poppler incorrectly handled certain files. If a user or automated system were tricked into opening a crafted PDF file, an attacker could cause a denial of service, or possibly execute arbitrary code
- Record
USN-4042-1- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
xpdfMageia:7 From an advisory covering 5 CVEs |
before 4.02-1.mga7 | 4.02-1.mga7 |
popplerUbuntu:16.04:LTS |
before 0.41.0-0ubuntu1.14, plus listed versions 0.33.0-0ubuntu30.37.0-0ubuntu10.38.0-0ubuntu10.41.0-0ubuntu10.41.0-0ubuntu1.1 Show 12 moreShow less0.41.0-0ubuntu1.20.41.0-0ubuntu1.30.41.0-0ubuntu1.40.41.0-0ubuntu1.50.41.0-0ubuntu1.60.41.0-0ubuntu1.70.41.0-0ubuntu1.80.41.0-0ubuntu1.90.41.0-0ubuntu1.100.41.0-0ubuntu1.110.41.0-0ubuntu1.120.41.0-0ubuntu1.13 |
0.41.0-0ubuntu1.14 |
popplerUbuntu:16.04:LTS From an advisory covering 12 CVEs |
before 0.41.0-0ubuntu1.14, plus listed versions 0.33.0-0ubuntu30.37.0-0ubuntu10.38.0-0ubuntu10.41.0-0ubuntu10.41.0-0ubuntu1.1 Show 12 moreShow less0.41.0-0ubuntu1.20.41.0-0ubuntu1.30.41.0-0ubuntu1.40.41.0-0ubuntu1.50.41.0-0ubuntu1.60.41.0-0ubuntu1.70.41.0-0ubuntu1.80.41.0-0ubuntu1.90.41.0-0ubuntu1.100.41.0-0ubuntu1.110.41.0-0ubuntu1.120.41.0-0ubuntu1.13 |
0.41.0-0ubuntu1.14 |
popplerUbuntu:18.04:LTS From an advisory covering 12 CVEs |
before 0.62.0-2ubuntu2.9, plus listed versions 0.57.0-2ubuntu40.57.0-2ubuntu50.62.0-1ubuntu10.62.0-2ubuntu10.62.0-2ubuntu2 Show 7 moreShow less0.62.0-2ubuntu2.10.62.0-2ubuntu2.20.62.0-2ubuntu2.40.62.0-2ubuntu2.50.62.0-2ubuntu2.60.62.0-2ubuntu2.70.62.0-2ubuntu2.8 |
0.62.0-2ubuntu2.9 |
History
| Recorded | Changed | Sources |
|---|---|---|
| affected, facts | ||
| aliases | EUVD | |
| first indexed | CVE List, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2019-10019 is a medium vulnerability (CVSS 5.5) in Xpdfreader Xpdf, published March 24, 2019. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.90%, the 59th percentile. Fixed in poppler 0.41.0-0ubuntu1.14.
References
forum.xpdfreader.com/viewtopic.php?f=3&t=41275
usn.ubuntu.com/4042-1
nvd.nist.gov/vuln/detail/CVE-2019-10019
github.com/advisories/GHSA-jqhh-g8q4-pp8j
advisories.mageia.org/MGASA-2019-0293.html
bugs.mageia.org/show_bug.cgi?id=25364
Show 15 moreShow less
ubuntu.com/security/CVE-2019-10019
ubuntu.com/security/notices/USN-4042-1
cve.org/CVERecord?id=CVE-2019-10019
ubuntu.com/security/CVE-2017-9865
ubuntu.com/security/CVE-2018-18897
ubuntu.com/security/CVE-2018-20662
ubuntu.com/security/CVE-2019-9200
ubuntu.com/security/CVE-2019-9631
ubuntu.com/security/CVE-2019-9903
ubuntu.com/security/CVE-2019-10018
ubuntu.com/security/CVE-2019-10021
ubuntu.com/security/CVE-2019-10023
ubuntu.com/security/CVE-2019-10872
ubuntu.com/security/CVE-2019-10873
ubuntu.com/security/CVE-2019-12293