Every CVE Search/ Get API key

CVE-2019-10061

OS Command Injection in node-opencv

9.8 CriticalFix available

utils/find-opencv.js in node-opencv (aka OpenCV bindings for Node.js) prior to 6.1.0 is vulnerable to Command Injection. It does not validate user input allowing attackers to execute arbitrary commands.

Attack profile

How easy it is to exploit

Attack vector
Network
Complexity
Low
Privileges needed
None
User interaction
None

What an attacker can affect

Confidentiality
High
Integrity
High
Availability
High

Exploit likelihood

4.24%Down 2.0 points since Apr 14, 2021
90%50%10%1%

What each source reports

NVD Score used 9.8

utils/find-opencv.js in node-opencv (aka OpenCV bindings for Node.js) prior to 6.1.0 is vulnerable to Command Injection. It does not validate user input allowing attackers to execute arbitrary commands.

Record
CVE-2019-10061
CVSS 3.0
9.8 CriticalCVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
CVSS 2.0
7.5 HighAV:N/AC:L/Au:N/C:P/I:P/A:P
Weakness
CWE-78
Updated
2026-11-02
CVE List No score

utils/find-opencv.js in node-opencv (aka OpenCV bindings for Node.js) prior to 6.1.0 is vulnerable to Command Injection. It does not validate user input allowing attackers to execute arbitrary commands.

Record
CVE-2019-10061
Updated
2026-11-02
EUVDEUVD-2021-2230 No score

utils/find-opencv.js in node-opencv (aka OpenCV bindings for Node.js) prior to 6.1.0 is vulnerable to Command Injection. It does not validate user input allowing attackers to execute arbitrary commands.

Record
EUVD-2021-2230
Updated
2026-11-03
GitHub AdvisoriesGHSA-mc7w-4cjf-c973 9.8

OS Command Injection in node-opencv

utils/find-opencv.js in node-opencv (aka OpenCV bindings for Node.js) prior to 6.1.0 is vulnerable to Command Injection. It does not validate user input allowing attackers to execute arbitrary commands.

Record
GHSA-mc7w-4cjf-c973
CVSS 3.0
9.8 CriticalCVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Weakness
CWE-78
Updated
2026-11-02
OSV 9.8

utils/find-opencv.js in node-opencv (aka OpenCV bindings for Node.js) prior to 6.1.0 is vulnerable to Command Injection. It does not validate user input allowing attackers to execute arbitrary commands.

Record
CVE-2019-10061
CVSS 3.0
9.8 CriticalCVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Updated
2026-11-02
OSVDEBIAN-CVE-2019-10061 9.8

utils/find-opencv.js in node-opencv (aka OpenCV bindings for Node.js) prior to 6.1.0 is vulnerable to Command Injection. It does not validate user input allowing attackers to execute arbitrary commands.

Record
DEBIAN-CVE-2019-10061
CVSS 3.0
9.8 CriticalCVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Updated
2026-11-02
OSVGHSA-mc7w-4cjf-c973 9.8

OS Command Injection in node-opencv

utils/find-opencv.js in node-opencv (aka OpenCV bindings for Node.js) prior to 6.1.0 is vulnerable to Command Injection. It does not validate user input allowing attackers to execute arbitrary commands.

Record
GHSA-mc7w-4cjf-c973
CVSS 3.0
9.8 CriticalCVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Weakness
CWE-78
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
opencv
npm
before 6.1.0
6.1.0
node-opencv
Debian:12
before 6.0.0+git20180416.cfc96ba0-3
6.0.0+git20180416.cfc96ba0-3
node-opencv
Debian:13
before 6.0.0+git20180416.cfc96ba0-3
6.0.0+git20180416.cfc96ba0-3
node-opencv
Debian:14
before 6.0.0+git20180416.cfc96ba0-3
6.0.0+git20180416.cfc96ba0-3

History

History
RecordedChangedSources
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2019-10061 is a critical vulnerability (CVSS 9.8) in Node-opencv Project Node-opencv, published March 26, 2019. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 4.24%, the 91st percentile. Fixed in opencv 6.1.0.

References

MoveEnter Open