Every CVE Search/ Get API key

CVE-2019-10078

Cross-site Scriptin in JSPWiki

6.1 MediumPublic exploitFix available

A carefully crafted plugin link invocation could trigger an XSS vulnerability on Apache JSPWiki 2.9.0 to 2.11.0.M3, which could lead to session hijacking. Initial reporting indicated ReferredPagesPlugin, but further analysis showed that multiple plugins were vulnerable.

Attack profile

How easy it is to exploit

Attack vector
Network
Complexity
Low
Privileges needed
None
User interaction
Required

What an attacker can affect

Confidentiality
Low
Integrity
Low
Availability
None

Exploit likelihood

4.94%Up 0.7 points since Apr 14, 2021
90%50%10%1%

What each source reports

NVD Score used 6.1

A carefully crafted plugin link invocation could trigger an XSS vulnerability on Apache JSPWiki 2.9.0 to 2.11.0.M3, which could lead to session hijacking. Initial reporting indicated ReferredPagesPlugin, but further analysis showed that multiple plugins were vulnerable.

Record
CVE-2019-10078
CVSS 3.0
6.1 MediumCVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
CVSS 2.0
4.3 MediumAV:N/AC:M/Au:N/C:N/I:P/A:N
Weakness
CWE-79
Updated
2026-11-02
CVE List No score

A carefully crafted plugin link invocation could trigger an XSS vulnerability on Apache JSPWiki 2.9.0 to 2.11.0.M3, which could lead to session hijacking. Initial reporting indicated ReferredPagesPlugin, but further analysis showed that multiple plugins were vulnerable.

Record
CVE-2019-10078
Updated
2026-11-02
EUVDEUVD-2019-0541 No score

A carefully crafted plugin link invocation could trigger an XSS vulnerability on Apache JSPWiki 2.9.0 to 2.11.0.M3, which could lead to session hijacking. Initial reporting indicated ReferredPagesPlugin, but further analysis showed that multiple plugins were vulnerable.

Record
EUVD-2019-0541
Updated
2026-11-03
GitHub AdvisoriesGHSA-hp5r-mhgp-56c9 6.1

Cross-site Scriptin in JSPWiki

A carefully crafted plugin link invocation could trigger an XSS vulnerability on Apache JSPWiki 2.9.0 to 2.11.0.M3, which could lead to session hijacking. Initial reporting indicated ReferredPagesPlugin, but further analysis showed that multiple plugins were vulnerable.

Record
GHSA-hp5r-mhgp-56c9
CVSS 3.0
6.1 MediumCVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
Weakness
CWE-79
Updated
2026-11-02
OSV 6.1

A carefully crafted plugin link invocation could trigger an XSS vulnerability on Apache JSPWiki 2.9.0 to 2.11.0.M3, which could lead to session hijacking. Initial reporting indicated ReferredPagesPlugin, but further analysis showed that multiple plugins were vulnerable.

Record
CVE-2019-10078
CVSS 3.0
6.1 MediumCVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
Updated
2026-11-02
OSVGHSA-hp5r-mhgp-56c9 6.1

Cross-site Scriptin in JSPWiki

A carefully crafted plugin link invocation could trigger an XSS vulnerability on Apache JSPWiki 2.9.0 to 2.11.0.M3, which could lead to session hijacking. Initial reporting indicated ReferredPagesPlugin, but further analysis showed that multiple plugins were vulnerable.

Record
GHSA-hp5r-mhgp-56c9
CVSS 3.0
6.1 MediumCVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
Weakness
CWE-79
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
org.apache.jspwiki:jspwiki-war
Maven
2.9.0 to 2.11.0.M3
2.11.0.M4
org.apache.jspwiki:jspwiki-main
Maven
2.9.0 to 2.11.0.M3
2.11.0.M4
org.apache.jspwiki:jspwiki-war
Maven
2.9.0 up to 2.11.0.M4, plus listed versions
2.10.02.10.12.10.22.10.32.10.4
Show 4 moreShow less
2.10.52.11.0.M12.11.0.M22.11.0.M3
2.11.0.M4
org.apache.jspwiki:jspwiki-main
Maven
2.9.0 up to 2.11.0.M4, plus listed versions
2.11.0.M12.11.0.M22.11.0.M3
2.11.0.M4

Public exploits

Links only. Every CVE stores no exploit code.

Public exploits
SourceLinkDate
PoC in GitHubshoucheng3/apache__jspwiki_CVE-2019-10078_2-11-0-M32025-08-19
PoC in GitHubshoucheng3/apache__jspwiki_CVE-2019-10078_2_11_0_M4_fixed2025-09-06

History

History
RecordedChangedSources
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV, PoC in GitHub

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2019-10078 is a medium vulnerability (CVSS 6.1) in Apache Jspwiki, published May 20, 2019. Public exploit code exists. EPSS puts the chance of exploitation in the next 30 days at 4.94%, the 92nd percentile. Fixed in org.apache.jspwiki:jspwiki-war 2.11.0.M4.

References

MoveEnter Open