Every CVE Search/ Get API key

CVE-2019-10095

bash command injection in spark interpreter

9.8 CriticalFix available

CVE-2019-10095 is a critical vulnerability (CVSS 9.8) in Apache Zeppelin, published September 2, 2021. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 5.75%, the 93rd percentile. Fixed in org.apache.zeppelin:zeppelin 0.10.0.

bash command injection vulnerability in Apache Zeppelin allows an attacker to inject system commands into Spark interpreter settings. This issue affects Apache Zeppelin Apache Zeppelin version 0.9.0 and prior versions.

Attack profile

How easy it is to exploit

Attack vector
Network
Complexity
Low
Privileges needed
None
User interaction
None

What an attacker can affect

Confidentiality
High
Integrity
High
Availability
High

Exploit likelihood

5.75%Up 4.7 points since Sep 3, 2021
90%50%10%1%

What each source reports

NVD Score used 9.8

bash command injection vulnerability in Apache Zeppelin allows an attacker to inject system commands into Spark interpreter settings. This issue affects Apache Zeppelin Apache Zeppelin version 0.9.0 and prior versions.

Record
CVE-2019-10095
CVSS 3.1
9.8 CriticalCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
CVSS 2.0
10.0 HighAV:N/AC:L/Au:N/C:C/I:C/A:C
Weakness
CWE-77
Updated
2026-11-02
CVE List No score

bash command injection in spark interpreter

bash command injection vulnerability in Apache Zeppelin allows an attacker to inject system commands into Spark interpreter settings. This issue affects Apache Zeppelin Apache Zeppelin version 0.9.0 and prior versions.

Record
CVE-2019-10095
Updated
2026-11-02
EUVDEUVD-2021-1977 No score

bash command injection vulnerability in Apache Zeppelin allows an attacker to inject system commands into Spark interpreter settings. This issue affects Apache Zeppelin Apache Zeppelin version 0.9.0 and prior versions.

Record
EUVD-2021-1977
Updated
2026-11-03
GitHub AdvisoriesGHSA-4qw8-pgpr-p9mq 9.8

Bash command injection in Apache Zeppelin

bash command injection vulnerability in Apache Zeppelin allows an attacker to inject system commands into Spark interpreter settings. This issue affects Apache Zeppelin Apache Zeppelin version 0.9.0 and prior versions.

Record
GHSA-4qw8-pgpr-p9mq
CVSS 3.1
9.8 CriticalCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Weakness
CWE-77, CWE-78
Updated
2026-11-02
OSV 9.8

bash command injection vulnerability in Apache Zeppelin allows an attacker to inject system commands into Spark interpreter settings. This issue affects Apache Zeppelin Apache Zeppelin version 0.9.0 and prior versions.

Record
CVE-2019-10095
CVSS 3.1
9.8 CriticalCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Updated
2026-11-02
OSVGHSA-4qw8-pgpr-p9mq 9.8

Bash command injection in Apache Zeppelin

bash command injection vulnerability in Apache Zeppelin allows an attacker to inject system commands into Spark interpreter settings. This issue affects Apache Zeppelin Apache Zeppelin version 0.9.0 and prior versions.

Record
GHSA-4qw8-pgpr-p9mq
CVSS 3.1
9.8 CriticalCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Weakness
CWE-77, CWE-78
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
org.apache.zeppelin:zeppelin
Maven
before 0.10.0
0.10.0
org.apache.zeppelin:zeppelin
Maven
before 0.10.0, plus listed versions
0.5.0-incubating0.6.00.6.10.6.20.7.0
Show 9 moreShow less
0.7.10.7.20.7.30.8.00.8.10.8.20.9.00.9.0-preview10.9.0-preview2
0.10.0

History

History
WhenChangedSources
2026-11-03aliasesEUVD
2026-11-02createdCVE List, GitHub Advisories, NVD, OSV

References

Show 5 moreShow less
MoveEnter Open