CVE-2019-1010174
CImg The CImg Library v.2.3.3 and earlier is affected by: command injection. The impact is: RCE....
CImg The CImg Library v.2.3.3 and earlier is affected by: command injection. The impact is: RCE. The component is: load_network() function. The attack vector is: Loading an image from a user-controllable url can lead to command injection, because no string sanitization is done on the url. The fixed version is: v.2.3.4.
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- Low
- Privileges needed
- None
- User interaction
- None
What an attacker can affect
- Confidentiality
- High
- Integrity
- High
- Availability
- High
Exploit likelihood
What each source reports
NVD Score used
9.8
CImg The CImg Library v.2.3.3 and earlier is affected by: command injection. The impact is: RCE. The component is: load_network() function. The attack vector is: Loading an image from a user-controllable url can lead to command injection, because no string sanitization is done on the url. The fixed version is: v.2.3.4.
- Record
CVE-2019-1010174- CVSS 3.1
- 9.8 Critical
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - CVSS 2.0
- 7.5 High
AV:N/AC:L/Au:N/C:P/I:P/A:P - Weakness
- CWE-77
- Updated
- 2026-11-02
CVE List No score
CImg The CImg Library v.2.3.3 and earlier is affected by: command injection. The impact is: RCE. The component is: load_network() function. The attack vector is: Loading an image from a user-controllable url can lead to command injection, because no string sanitization is done on the url. The fixed version is: v.2.3.4.
- Record
CVE-2019-1010174- Updated
- 2026-11-02
EUVDEUVD-2019-1919 No score
CImg The CImg Library v.2.3.3 and earlier is affected by: command injection. The impact is: RCE. The component is: load_network() function. The attack vector is: Loading an image from a user-controllable url can lead to command injection, because no string sanitization is done on the url. The fixed version is: v.2.3.4.
- Record
EUVD-2019-1919- Updated
- 2026-11-03
GitHub AdvisoriesGHSA-rp8q-pmmm-p726
9.8
CImg The CImg Library v.2.3.3 and earlier is affected by: command injection. The impact is: RCE....
CImg The CImg Library v.2.3.3 and earlier is affected by: command injection. The impact is: RCE. The component is: load_network() function. The attack vector is: Loading an image from a user-controllable url can lead to command injection, because no string sanitization is done on the url. The fixed version is: v.2.3.4.
- Record
GHSA-rp8q-pmmm-p726- CVSS 3.1
- 9.8 Critical
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - Weakness
- CWE-77
- Updated
- 2026-11-02
OSV
9.8
CImg The CImg Library v.2.3.3 and earlier is affected by: command injection. The impact is: RCE. The component is: load_network() function. The attack vector is: Loading an image from a user-controllable url can lead to command injection, because no string sanitization is done on the url. The fixed version is: v.2.3.4.
- Record
CVE-2019-1010174- CVSS 3.1
- 9.8 Critical
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - Updated
- 2026-11-02
OSVDEBIAN-CVE-2019-1010174
9.8
CImg The CImg Library v.2.3.3 and earlier is affected by: command injection. The impact is: RCE. The component is: load_network() function. The attack vector is: Loading an image from a user-controllable url can lead to command injection, because no string sanitization is done on the url. The fixed version is: v.2.3.4.
- Record
DEBIAN-CVE-2019-1010174- CVSS 3.1
- 9.8 Critical
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - Updated
- 2026-11-02
OSVUBUNTU-CVE-2019-1010174
9.8
CImg The CImg Library v.2.3.3 and earlier is affected by: command injection. The impact is: RCE. The component is: load_network() function. The attack vector is: Loading an image from a user-controllable url can lead to command injection, because no string sanitization is done on the url. The fixed version is: v.2.3.4.
- Record
UBUNTU-CVE-2019-1010174- CVSS 3.1
- 9.8 Critical
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
cimgDebian:12 |
before 2.3.6+dfsg-1 | 2.3.6+dfsg-1 |
cimgDebian:13 |
before 2.3.6+dfsg-1 | 2.3.6+dfsg-1 |
cimgDebian:14 |
before 2.3.6+dfsg-1 | 2.3.6+dfsg-1 |
cimgDebian:8 From an advisory covering 8 CVEs |
before 1.5.9+dfsg-1+deb8u1, plus listed versions 1.5.9+dfsg-1 |
1.5.9+dfsg-1+deb8u1 |
cimgDebian:9 From an advisory covering 8 CVEs |
before 1.7.9+dfsg-1+deb9u1, plus listed versions 1.7.9+dfsg-1 |
1.7.9+dfsg-1+deb9u1 |
cimgUbuntu:16.04:LTS |
All versions, plus listed versions 1.6.4+dfsg-1build11.6.5+dfsg-1 |
None known |
gmicUbuntu:16.04:LTS |
All versions, plus listed versions 1.6.2.0-1build21.6.8-3 |
None known |
cimgUbuntu:Pro:18.04:LTS |
All versions, plus listed versions 1.7.9+dfsg-21.7.9+dfsg-2build11.7.9+dfsg-2ubuntu0.18.04.11.7.9+dfsg-2ubuntu0.18.04.21.7.9+dfsg-2ubuntu0.18.04.2+esm1 |
None known |
gmicUbuntu:18.04:LTS |
All versions, plus listed versions 1.7.9+zart-4build11.7.9+zart-4build21.7.9+zart-4build3 |
None known |
gmicUbuntu:20.04:LTS |
All versions, plus listed versions 2.4.5-12.4.5-1.1 |
None known |
gmicUbuntu:22.04:LTS |
All versions, plus listed versions 2.9.4-42.9.4-4build1 |
None known |
Public exploits
Links only. Every CVE stores no exploit code.
| Source | Link | Date |
|---|---|---|
| PoC in GitHub | NketiahGodfred/CVE-2019-1010174 | 2024-12-01 |
History
| Recorded | Changed | Sources |
|---|---|---|
| affected, facts | ||
| aliases | EUVD | |
| first indexed | CVE List, GitHub Advisories, NVD, OSV, PoC in GitHub |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2019-1010174 is a critical vulnerability (CVSS 9.8) in Cimg Library, published July 25, 2019. Public exploit code exists. EPSS puts the chance of exploitation in the next 30 days at 4.97%, the 92nd percentile. Fixed in cimg 2.3.6+dfsg-1.
References
framagit.org/dtschump/CImg/commit/5ce7a426b77f814973e56182a0e76a2b04904146
lists.debian.org/debian-lts-announce/2019/09/msg00030.html
lists.debian.org/debian-lts-announce/2020/10/msg00033.html
nvd.nist.gov/vuln/detail/CVE-2019-1010174
github.com/advisories/GHSA-rp8q-pmmm-p726
security-tracker.debian.org/tracker/CVE-2019-1010174
ubuntu.com/security/CVE-2019-1010174
cve.org/CVERecord?id=CVE-2019-1010174