CVE-2019-1010266
Regular Expression Denial of Service (ReDoS) in lodash
lodash prior to 4.17.11 is affected by: CWE-400: Uncontrolled Resource Consumption. The impact is: Denial of service. The component is: Date handler. The attack vector is: Attacker provides very long strings, which the library attempts to match using a regular expression. The fixed version is: 4.17.11.
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- Low
- Privileges needed
- Low
- User interaction
- None
What an attacker can affect
- Confidentiality
- None
- Integrity
- None
- Availability
- High
Exploit likelihood
What each source reports
NVD Score used
6.5
lodash prior to 4.17.11 is affected by: CWE-400: Uncontrolled Resource Consumption. The impact is: Denial of service. The component is: Date handler. The attack vector is: Attacker provides very long strings, which the library attempts to match using a regular expression. The fixed version is: 4.17.11.
- Record
CVE-2019-1010266- CVSS 3.1
- 6.5 Medium
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H - CVSS 2.0
- 4.0 Medium
AV:N/AC:L/Au:S/C:N/I:N/A:P - Weakness
- CWE-400, CWE-770
- Updated
- 2026-11-02
CVE List No score
lodash prior to 4.17.11 is affected by: CWE-400: Uncontrolled Resource Consumption. The impact is: Denial of service. The component is: Date handler. The attack vector is: Attacker provides very long strings, which the library attempts to match using a regular expression. The fixed version is: 4.17.11.
- Record
CVE-2019-1010266- Weakness
- CWE-400
- Updated
- 2026-11-02
EUVDEUVD-2019-0610 No score
lodash prior to 4.17.11 is affected by: CWE-400: Uncontrolled Resource Consumption. The impact is: Denial of service. The component is: Date handler. The attack vector is: Attacker provides very long strings, which the library attempts to match using a regular expression. The fixed version is: 4.17.11.
- Record
EUVD-2019-0610- Updated
- 2026-11-03
GitHub AdvisoriesGHSA-x5rq-j2xg-h7qm
6.5
Regular Expression Denial of Service (ReDoS) in lodash
lodash prior to 4.7.11 is affected by: CWE-400: Uncontrolled Resource Consumption. The impact is: Denial of service. The component is: Date handler. The attack vector is: Attacker provides very long strings, which the library attempts to match using a regular expression. The fixed version is: 4.7.11.
- Record
GHSA-x5rq-j2xg-h7qm- CVSS 3.1
- 6.5 Medium
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H - Weakness
- CWE-400
- Updated
- 2026-11-02
OSVAZL-45159
6.5
CVE-2019-1010266 affecting package js-jquery 3.5.0-4
lodash prior to 4.17.11 is affected by: CWE-400: Uncontrolled Resource Consumption. The impact is: Denial of service. The component is: Date handler. The attack vector is: Attacker provides very long strings, which the library attempts to match using a regular expression. The fixed version is: 4.17.11.
- Record
AZL-45159- CVSS 3.1
- 6.5 Medium
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H - Updated
- 2026-11-05
OSV
6.5
lodash prior to 4.17.11 is affected by: CWE-400: Uncontrolled Resource Consumption. The impact is: Denial of service. The component is: Date handler. The attack vector is: Attacker provides very long strings, which the library attempts to match using a regular expression. The fixed version is: 4.17.11.
- Record
CVE-2019-1010266- CVSS 3.1
- 6.5 Medium
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H - Updated
- 2026-11-02
Show 5 moreShow less
OSVDEBIAN-CVE-2019-1010266
6.5
lodash prior to 4.17.11 is affected by: CWE-400: Uncontrolled Resource Consumption. The impact is: Denial of service. The component is: Date handler. The attack vector is: Attacker provides very long strings, which the library attempts to match using a regular expression. The fixed version is: 4.17.11.
- Record
DEBIAN-CVE-2019-1010266- CVSS 3.1
- 6.5 Medium
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H - Updated
- 2026-11-02
OSVGHSA-x5rq-j2xg-h7qm
6.5
Regular Expression Denial of Service (ReDoS) in lodash
lodash prior to 4.7.11 is affected by: CWE-400: Uncontrolled Resource Consumption. The impact is: Denial of service. The component is: Date handler. The attack vector is: Attacker provides very long strings, which the library attempts to match using a regular expression. The fixed version is: 4.7.11.
- Record
GHSA-x5rq-j2xg-h7qm- CVSS 3.1
- 6.5 Medium
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H - Weakness
- CWE-400
- Updated
- 2026-11-02
OSVUBUNTU-CVE-2019-1010266
6.5
lodash prior to 4.17.11 is affected by: CWE-400: Uncontrolled Resource Consumption. The impact is: Denial of service. The component is: Date handler. The attack vector is: Attacker provides very long strings, which the library attempts to match using a regular expression. The fixed version is: 4.17.11.
- Record
UBUNTU-CVE-2019-1010266- CVSS 3.1
- 6.5 Medium
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H - Updated
- 2026-11-02
OSVCLSA-2026-1784509823 No score
TuxCare security update for lodash (3 CVEs)
TuxCare rebuilt lodash to address 3 CVEs. Fixed in 4.17.4-tuxcare.2.
- Record
CLSA-2026-1784509823- Updated
- 2026-11-02
OSVCLSA-2026-1785291646 No score
TuxCare security update for lodash (4 CVEs)
TuxCare rebuilt lodash to address 4 CVEs. Fixed in 4.17.5-tuxcare.3.
- Record
CLSA-2026-1785291646- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
lodashnpm |
4.7.0 up to 4.17.11 | 4.17.11 |
lodash-esnpm |
4.7.0 up to 4.17.11 | 4.17.11 |
lodash-amdnpm |
4.7.0 up to 4.17.11 | 4.17.11 |
lodash-railsRubyGems |
4.7.0 up to 4.17.11 | 4.17.11 |
js-jqueryAzure Linux:3 |
through 3.5.0-4 | None known |
lodashTuxCare:npm |
4.17.4-tuxcare.0 up to 4.17.4-tuxcare.2, plus listed versions 4.17.44.17.4-tuxcare.1 |
4.17.4-tuxcare.2 |
lodashTuxCare:npm |
4.17.5-tuxcare.0 up to 4.17.5-tuxcare.3, plus listed versions 4.17.54.17.5-tuxcare.14.17.5-tuxcare.2 |
4.17.5-tuxcare.3 |
node-lodashDebian:12 |
before 4.17.11+dfsg-1 | 4.17.11+dfsg-1 |
node-lodashDebian:13 |
before 4.17.11+dfsg-1 | 4.17.11+dfsg-1 |
node-lodashDebian:14 |
before 4.17.11+dfsg-1 | 4.17.11+dfsg-1 |
lodash-railsRubyGems |
4.7.0 up to 4.17.11, plus listed versions 4.11.24.12.04.13.14.14.14.15.0 Show 8 moreShow less4.16.14.16.34.16.44.16.64.17.104.17.24.17.44.17.5 |
4.17.11 |
node-lodashUbuntu:Pro:18.04:LTS |
All versions, plus listed versions 4.17.4+dfsg-14.17.4+dfsg-1ubuntu0.1~esm1 |
None known |
History
| Recorded | Changed | Sources |
|---|---|---|
| facts | OSV | |
| aliases | EUVD | |
| first indexed | CVE List, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2019-1010266 is a medium vulnerability (CVSS 6.5) in Lodash, published July 17, 2019. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 3.04%, the 87th percentile. Fixed in lodash 4.17.11.
References
snyk.io/vuln/SNYK-JS-LODASH-73639
github.com/lodash/lodash/issues/3359
github.com/lodash/lodash/wiki/Changelog
security.netapp.com/advisory/ntap-20190919-0004
nvd.nist.gov/vuln/detail/CVE-2019-1010266
github.com/lodash/lodash/commit/5c08f18d365b64063bfbfa686cbb97cdd6267347
Show 7 moreShow less
github.com/rubysec/ruby-advisory-db/blob/master/gems/lodash-rails/CVE-2019-1010266.yml
github.com/github/advisory-database/pull/6138
github.com/advisories/GHSA-x5rq-j2xg-h7qm
security-tracker.debian.org/tracker/CVE-2019-1010266
github.com/lodash/lodash
ubuntu.com/security/CVE-2019-1010266
cve.org/CVERecord?id=CVE-2019-1010266