Every CVE Search/ Get API key

CVE-2019-1010275

Helm Improper Certificate Validation

9.8 CriticalFix available

helm Before 2.7.2 is affected by: CWE-295: Improper Certificate Validation. The impact is: Unauthorized clients could connect to the server because self-signed client certs were aloowed. The component is: helm (many files updated, see https://github.com/helm/helm/pull/3152/files/1096813bf9a425e2aa4ac755b6c991b626dfab50). The attack vector is: A malicious client could connect to the server over the network. The fixed version is: 2.7.2.

Attack profile

How easy it is to exploit

Attack vector
Network
Complexity
Low
Privileges needed
None
User interaction
None

What an attacker can affect

Confidentiality
High
Integrity
High
Availability
High

Exploit likelihood

1.36%Up 0.5 points since Apr 14, 2021
90%50%10%1%

What each source reports

NVD Score used 9.8

helm Before 2.7.2 is affected by: CWE-295: Improper Certificate Validation. The impact is: Unauthorized clients could connect to the server because self-signed client certs were aloowed. The component is: helm (many files updated, see https://github.com/helm/helm/pull/3152/files/1096813bf9a425e2aa4ac755b6c991b626dfab50). The attack vector is: A malicious client could connect to the server over the network. The fixed version is: 2.7.2.

Record
CVE-2019-1010275
CVSS 3.0
9.8 CriticalCVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
CVSS 2.0
7.5 HighAV:N/AC:L/Au:N/C:P/I:P/A:P
Weakness
CWE-295
Updated
2026-11-02
CVE List No score

helm Before 2.7.2 is affected by: CWE-295: Improper Certificate Validation. The impact is: Unauthorized clients could connect to the server because self-signed client certs were aloowed. The component is: helm (many files updated, see https://github.com/helm/helm/pull/3152/files/1096813bf9a425e2aa4ac755b6c991b626dfab50). The attack vector is: A malicious client could connect to the server over the network. The fixed version is: 2.7.2.

Record
CVE-2019-1010275
Weakness
CWE-295
Updated
2026-11-02
EUVDEUVD-2022-5730 No score

helm Before 2.7.2 is affected by: CWE-295: Improper Certificate Validation. The impact is: Unauthorized clients could connect to the server because self-signed client certs were aloowed. The component is: helm (many files updated, see https://github.com/helm/helm/pull/3152/files/1096813bf9a425e2aa4ac755b6c991b626dfab50). The attack vector is: A malicious client could connect to the server over the network. The fixed version is: 2.7.2.

Record
EUVD-2022-5730
Updated
2026-11-03
GitHub AdvisoriesGHSA-x6r5-vxfg-gq3v 9.8

Helm Improper Certificate Validation

helm Before 2.7.2 is affected by: CWE-295: Improper Certificate Validation. The impact is: Unauthorized clients could connect to the server because self-signed client certs were aloowed. The component is: helm (many files updated, see https://github.com/helm/helm/pull/3152/files/1096813bf9a425e2aa4ac755b6c991b626dfab50). The attack vector is: A malicious client could connect to the server over the network. The fixed version is: 2.7.2.

Record
GHSA-x6r5-vxfg-gq3v
CVSS 3.0
9.8 CriticalCVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Weakness
CWE-295
Updated
2026-11-02
OSV 9.8

helm Before 2.7.2 is affected by: CWE-295: Improper Certificate Validation. The impact is: Unauthorized clients could connect to the server because self-signed client certs were aloowed. The component is: helm (many files updated, see https://github.com/helm/helm/pull/3152/files/1096813bf9a425e2aa4ac755b6c991b626dfab50). The attack vector is: A malicious client could connect to the server over the network. The fixed version is: 2.7.2.

Record
CVE-2019-1010275
CVSS 3.0
9.8 CriticalCVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Updated
2026-11-02
OSVGHSA-x6r5-vxfg-gq3v 9.8

Helm Improper Certificate Validation

helm Before 2.7.2 is affected by: CWE-295: Improper Certificate Validation. The impact is: Unauthorized clients could connect to the server because self-signed client certs were aloowed. The component is: helm (many files updated, see https://github.com/helm/helm/pull/3152/files/1096813bf9a425e2aa4ac755b6c991b626dfab50). The attack vector is: A malicious client could connect to the server over the network. The fixed version is: 2.7.2.

Record
GHSA-x6r5-vxfg-gq3v
CVSS 3.0
9.8 CriticalCVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Weakness
CWE-295
Updated
2026-11-02
OSVUBUNTU-CVE-2019-1010275 9.8

helm Before 2.7.2 is affected by: CWE-295: Improper Certificate Validation. The impact is: Unauthorized clients could connect to the server because self-signed client certs were aloowed. The component is: helm (many files updated, see https://github.com/helm/helm/pull/3152/files/1096813bf9a425e2aa4ac755b6c991b626dfab50). The attack vector is: A malicious client could connect to the server over the network. The fixed version is: 2.7.2.

Record
UBUNTU-CVE-2019-1010275
CVSS 3.0
9.8 CriticalCVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Updated
2026-11-02
OSVGO-2023-1993 No score

Helm Improper Certificate Validation in helm.sh/helm

Helm Improper Certificate Validation in helm.sh/helm

Record
GO-2023-1993
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
helm.sh/helm
Go
before 2.7.2
2.7.2
helm.sh/helm
Go
before 2.7.2+incompatible
2.7.2+incompatible
helm
Ubuntu:16.04:LTS
All versions, plus listed versions
1.9.1-11.9.2-1
None known
helm
Ubuntu:18.04:LTS
All versions, plus listed versions
2.8.2-12.8.5-12.8.6-12.8.7-12.8.8-1
None known
helm
Ubuntu:20.04:LTS
All versions, plus listed versions
3.2-13.5.0-33.6.0-1
None known
helm
Ubuntu:22.04:LTS
All versions, plus listed versions
3.7.0-23.8.0-1
None known
helm
Ubuntu:24.04:LTS
All versions, plus listed versions
3.8.4-1
None known
helm
Ubuntu:25.10
All versions, plus listed versions
3.8.4-24.0.3-1
None known
helm
Ubuntu:26.10
All versions, plus listed versions
4.0.6-34.0.7-1
None known
helm
Ubuntu:26.04:LTS
All versions, plus listed versions
4.0.3-14.0.6-14.0.6-24.0.6-3
None known

History

History
RecordedChangedSources
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2019-1010275 is a critical vulnerability (CVSS 9.8) in Helm, published July 17, 2019. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 1.36%, the 71st percentile. Fixed in helm.sh/helm 2.7.2.

References

MoveEnter Open