CVE-2019-10187
Moodle Ability to delete glossary entries that belong to another glossary
A flaw was found in moodle before versions 3.7.1, 3.6.5, 3.5.7. Users with permission to delete entries from a glossary were able to delete entries from other glossaries they did not have direct access to.
Attack profile
How easy it is to exploit
- Attack vector
- Local
- Complexity
- Low
- Privileges needed
- None
- User interaction
- None
What an attacker can affect
- Confidentiality
- None
- Integrity
- Low
- Availability
- None
Exploit likelihood
What each source reports
CVE List Score used
4.0
A flaw was found in moodle before versions 3.7.1, 3.6.5, 3.5.7. Users with permission to delete entries from a glossary were able to delete entries from other glossaries they did not have direct access to.
- Record
CVE-2019-10187- CVSS 3.0
- 4.0 Medium
CVSS:3.0/AV:L/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:N - Weakness
- CWE-284
- Updated
- 2026-11-02
EUVDEUVD-2022-2013
4.0
A flaw was found in moodle before versions 3.7.1, 3.6.5, 3.5.7. Users with permission to delete entries from a glossary were able to delete entries from other glossaries they did not have direct access to.
- Record
EUVD-2022-2013- CVSS 3.0
- 4.0 Medium
CVSS:3.0/AV:L/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:N - Updated
- 2026-11-03
GitHub AdvisoriesGHSA-2mg9-hv69-897x
4.3
Moodle Ability to delete glossary entries that belong to another glossary
A flaw was found in moodle before versions 3.7.1, 3.6.5, 3.5.7. Users with permission to delete entries from a glossary were able to delete entries from other glossaries they did not have direct access to.
- Record
GHSA-2mg9-hv69-897x- CVSS 3.1
- 4.3 Medium
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:L/A:N - Weakness
- CWE-284, CWE-862
- Updated
- 2026-11-02
NVD
4.3
A flaw was found in moodle before versions 3.7.1, 3.6.5, 3.5.7. Users with permission to delete entries from a glossary were able to delete entries from other glossaries they did not have direct access to.
- Record
CVE-2019-10187- CVSS 3.1
- 4.3 Medium
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:L/A:N - CVSS 3.0
- 4.0 Medium
CVSS:3.0/AV:L/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:N - CVSS 2.0
- 4.0 Medium
AV:N/AC:L/Au:S/C:N/I:P/A:N - Weakness
- CWE-284, CWE-862
- Updated
- 2026-11-02
OSV
4.3
A flaw was found in moodle before versions 3.7.1, 3.6.5, 3.5.7. Users with permission to delete entries from a glossary were able to delete entries from other glossaries they did not have direct access to.
- Record
CVE-2019-10187- CVSS 3.1
- 4.3 Medium
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:L/A:N - Updated
- 2026-11-02
OSVGHSA-2mg9-hv69-897x
4.3
Moodle Ability to delete glossary entries that belong to another glossary
A flaw was found in moodle before versions 3.7.1, 3.6.5, 3.5.7. Users with permission to delete entries from a glossary were able to delete entries from other glossaries they did not have direct access to.
- Record
GHSA-2mg9-hv69-897x- CVSS 3.1
- 4.3 Medium
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:L/A:N - Weakness
- CWE-284, CWE-862
- Updated
- 2026-11-02
OSVUBUNTU-CVE-2019-10187
4.3
A flaw was found in moodle before versions 3.7.1, 3.6.5, 3.5.7. Users with permission to delete entries from a glossary were able to delete entries from other glossaries they did not have direct access to.
- Record
UBUNTU-CVE-2019-10187- CVSS 3.1
- 4.3 Medium
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:L/A:N - CVSS 3.0
- 4.0 Medium
CVSS:3.0/AV:L/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:N - Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
moodle/moodlePackagist |
3.7 up to 3.7.1 | 3.7.1 |
moodle/moodlePackagist |
3.6 up to 3.6.5 | 3.6.5 |
moodle/moodlePackagist |
3.5 up to 3.5.7 | 3.5.7 |
moodle/moodlePackagist |
3.7 up to 3.7.1, plus listed versions v3.7.0v3.7.0-betav3.7.0-rc1v3.7.0-rc2 |
3.7.1 |
moodle/moodlePackagist |
3.6 up to 3.6.5, plus listed versions v3.6.0v3.6.0-betav3.6.0-rc1v3.6.0-rc2v3.6.0-rc3 Show 4 moreShow lessv3.6.1v3.6.2v3.6.3v3.6.4 |
3.6.5 |
moodle/moodlePackagist |
3.5 up to 3.5.7, plus listed versions v3.5.0v3.5.0-betav3.5.0-rc1v3.5.1v3.5.2 Show 4 moreShow lessv3.5.3v3.5.4v3.5.5v3.5.6 |
3.5.7 |
moodleUbuntu:Pro:16.04:LTS |
All versions, plus listed versions 2.7.9+dfsg-12.7.10+dfsg-12.7.11+dfsg-12.7.11+dfsg-22.7.12+dfsg-13.0.3+dfsg-0ubuntu13.0.3+dfsg-0ubuntu1+esm1 |
None known |
moodleUbuntu:Pro:18.04:LTS |
All versions, plus listed versions 3.0.3+dfsg-0ubuntu13.0.3+dfsg-0ubuntu1+esm1 |
None known |
History
| Recorded | Changed | Sources |
|---|---|---|
| aliases | EUVD | |
| first indexed | CVE List, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2019-10187 is a medium vulnerability (CVSS 4.0) in Moodle, published July 31, 2019. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.86%, the 58th percentile. Fixed in moodle/moodle 3.7.1.