CVE-2019-1020012
Parse Server before v3.4.1 vulnerable to Denial of Service
parse-server before 3.4.1 allows DoS after any POST to a volatile class.
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- Low
- Privileges needed
- None
- User interaction
- None
What an attacker can affect
- Confidentiality
- None
- Integrity
- None
- Availability
- High
Exploit likelihood
What each source reports
NVD Score used
7.5
parse-server before 3.4.1 allows DoS after any POST to a volatile class.
- Record
CVE-2019-1020012- CVSS 3.0
- 7.5 High
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H - CVSS 2.0
- 5.0 Medium
AV:N/AC:L/Au:N/C:N/I:N/A:P - Weakness
- CWE-444
- Updated
- 2026-11-02
CVE List No score
parse-server before 3.4.1 allows DoS after any POST to a volatile class.
- Record
CVE-2019-1020012- Updated
- 2026-11-02
EUVDEUVD-2019-0487 No score
parse-server before 3.4.1 allows DoS after any POST to a volatile class.
- Record
EUVD-2019-0487- Updated
- 2026-11-03
GitHub AdvisoriesGHSA-2479-qvv7-47qq
7.5
Parse Server before v3.4.1 vulnerable to Denial of Service
Impact
If a POST request is made to /parse/classes/_Audience (or other volatile class), any subsuquent POST requests result in an internal server error (500).
Patches
Afflicted installations will also have to remove the offending collection from their database.
Yes, patched in 3.4.1
Workarounds
Yes, user can apply: https://github.com/parse-community/parse-server/commit/8709daf698ea69b59268cb66f0f7cee75b52daa5
References
Nothing other than this advisory at this time
For more information
If you have any questions or comments about this advisory:
- Open an issue in parse-server
- Email us at [email protected]
- Record
GHSA-2479-qvv7-47qq- CVSS 3.0
- 7.5 High
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H - Weakness
- CWE-444
- Updated
- 2026-11-02
OSV
7.5
parse-server before 3.4.1 allows DoS after any POST to a volatile class.
- Record
CVE-2019-1020012- CVSS 3.0
- 7.5 High
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H - Updated
- 2026-11-02
OSVGHSA-2479-qvv7-47qq
7.5
Parse Server before v3.4.1 vulnerable to Denial of Service
Impact
If a POST request is made to /parse/classes/_Audience (or other volatile class), any subsuquent POST requests result in an internal server error (500).
Patches
Afflicted installations will also have to remove the offending collection from their database.
Yes, patched in 3.4.1
Workarounds
Yes, user can apply: https://github.com/parse-community/parse-server/commit/8709daf698ea69b59268cb66f0f7cee75b52daa5
References
Nothing other than this advisory at this time
For more information
If you have any questions or comments about this advisory:
- Open an issue in parse-server
- Email us at [email protected]
- Record
GHSA-2479-qvv7-47qq- CVSS 3.0
- 7.5 High
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H - Weakness
- CWE-444
- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
parse-servernpm |
before 3.4.1 | 3.4.1 |
History
| Recorded | Changed | Sources |
|---|---|---|
| aliases, products | EUVD | |
| first indexed | CVE List, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2019-1020012 is a high vulnerability (CVSS 7.5) in Parse Parse-server, published June 13, 2019. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 1.40%, the 72nd percentile. Fixed in parse-server 3.4.1.