CVE-2019-1020013
Sensitive Data Exposure in parse-server
parse-server before 3.6.0 allows account enumeration.
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- Low
- Privileges needed
- None
- User interaction
- None
What an attacker can affect
- Confidentiality
- Low
- Integrity
- None
- Availability
- None
Exploit likelihood
What each source reports
NVD Score used
5.3
parse-server before 3.6.0 allows account enumeration.
- Record
CVE-2019-1020013- CVSS 3.0
- 5.3 Medium
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N - CVSS 2.0
- 5.0 Medium
AV:N/AC:L/Au:N/C:P/I:N/A:N - Weakness
- CWE-209
- Updated
- 2026-11-02
CVE List No score
parse-server before 3.6.0 allows account enumeration.
- Record
CVE-2019-1020013- Updated
- 2026-11-02
EUVDEUVD-2019-0584 No score
parse-server before 3.6.0 allows account enumeration.
- Record
EUVD-2019-0584- Updated
- 2026-11-03
GitHub AdvisoriesGHSA-8w3j-g983-8jh5
5.3
Sensitive Data Exposure in parse-server
Versions of parse-server prior to 3.6.0 could allow an account enumeration attack via account linking.
ParseError.ACCOUNT_ALREADY_LINKED(208) was thrown BEFORE the AuthController checks the password and throws a ParseError.SESSION_MISSING(206) for Insufficient auth. An attacker can guess ids and get information about linked accounts/email addresses.
For more information
If you have any questions or comments about this advisory, Open an issue in the parse-server Parse Community Vulnerability Disclosure Program
- Record
GHSA-8w3j-g983-8jh5- CVSS 3.0
- 5.3 Medium
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N - Weakness
- CWE-209
- Updated
- 2026-11-02
OSV
5.3
parse-server before 3.6.0 allows account enumeration.
- Record
CVE-2019-1020013- CVSS 3.0
- 5.3 Medium
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N - Updated
- 2026-11-02
OSVGHSA-8w3j-g983-8jh5
5.3
Sensitive Data Exposure in parse-server
Versions of parse-server prior to 3.6.0 could allow an account enumeration attack via account linking.
ParseError.ACCOUNT_ALREADY_LINKED(208) was thrown BEFORE the AuthController checks the password and throws a ParseError.SESSION_MISSING(206) for Insufficient auth. An attacker can guess ids and get information about linked accounts/email addresses.
For more information
If you have any questions or comments about this advisory, Open an issue in the parse-server Parse Community Vulnerability Disclosure Program
- Record
GHSA-8w3j-g983-8jh5- CVSS 3.0
- 5.3 Medium
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N - Weakness
- CWE-209
- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
parse-servernpm |
before 3.6.0 | 3.6.0 |
History
| Recorded | Changed | Sources |
|---|---|---|
| aliases, products | EUVD | |
| first indexed | CVE List, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2019-1020013 is a medium vulnerability (CVSS 5.3) in Parse Parse-server, published July 11, 2019. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 1.16%, the 67th percentile. Fixed in parse-server 3.6.0.
References
github.com/parse-community/parse-server/security/advisories/GHSA-8w3j-g983-8jh5
nvd.nist.gov/vuln/detail/CVE-2019-1020013
github.com/advisories/GHSA-8w3j-g983-8jh5
snyk.io/vuln/SNYK-JS-PARSESERVER-455637
npmjs.com/advisories/1114
github.com/parse-community/parse-server/commit/73b0f9a339b81f5d757725dc557955a7b670a3ec
owasp.org/index.php/Testing_for_User_Enumeration_and_Guessable_User_Account_(OWASP-AT-002)