CVE-2019-10643
Contao Does Not Expire Tokens Correctly
Contao 4.7 allows Use of a Key Past its Expiration Date.
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- Low
- Privileges needed
- None
- User interaction
- None
What an attacker can affect
- Confidentiality
- High
- Integrity
- High
- Availability
- High
Exploit likelihood
What each source reports
NVD Score used
9.8
Contao 4.7 allows Use of a Key Past its Expiration Date.
- Record
CVE-2019-10643- CVSS 3.0
- 9.8 Critical
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - CVSS 2.0
- 7.5 High
AV:N/AC:L/Au:N/C:P/I:P/A:P - Weakness
- CWE-287
- Updated
- 2026-11-02
CVE List No score
Contao 4.7 allows Use of a Key Past its Expiration Date.
- Record
CVE-2019-10643- Updated
- 2026-11-02
EUVDEUVD-2022-4322 No score
Contao 4.7 allows Use of a Key Past its Expiration Date.
- Record
EUVD-2022-4322- Updated
- 2026-11-03
GitHub AdvisoriesGHSA-j99g-qjvx-995g
9.8
Contao Does Not Expire Tokens Correctly
Security researcher Ali Razzaq has discovered that confirming an opt-in token does not invalidate previous opt-in tokens in Contao 4.7.
- Record
GHSA-j99g-qjvx-995g- CVSS 3.0
- 9.8 Critical
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - Weakness
- CWE-287, CWE-324
- Updated
- 2026-11-02
OSV
9.8
Contao 4.7 allows Use of a Key Past its Expiration Date.
- Record
CVE-2019-10643- CVSS 3.0
- 9.8 Critical
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - Updated
- 2026-11-02
OSVGHSA-j99g-qjvx-995g
9.8
Contao Does Not Expire Tokens Correctly
Security researcher Ali Razzaq has discovered that confirming an opt-in token does not invalidate previous opt-in tokens in Contao 4.7.
- Record
GHSA-j99g-qjvx-995g- CVSS 3.0
- 9.8 Critical
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - Weakness
- CWE-287, CWE-324
- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
contao/contaoPackagist |
4.7.0 up to 4.7.3 | 4.7.3 |
contao/core-bundlePackagist |
4.7.0 up to 4.7.3 | 4.7.3 |
contao/contaoPackagist |
4.7.0 up to 4.7.3, plus listed versions 4.7.14.7.2 |
4.7.3 |
contao/core-bundlePackagist |
4.7.0 up to 4.7.3, plus listed versions 4.7.14.7.2 |
4.7.3 |
History
| Recorded | Changed | Sources |
|---|---|---|
| aliases | EUVD | |
| first indexed | CVE List, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2019-10643 is a critical vulnerability (CVSS 9.8) in Contao Cms, published April 17, 2019. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 1.25%, the 69th percentile. Fixed in contao/contao 4.7.3.
References
contao.org/en/news.html
contao.org/en/news/security-vulnerability-cve-2019-10643.html
nvd.nist.gov/vuln/detail/CVE-2019-10643
github.com/contao/contao/commit/70348cc812b110831ad66a4f9857883f75649b88
github.com/FriendsOfPHP/security-advisories/blob/master/contao/contao/CVE-2019-10643.yaml
github.com/FriendsOfPHP/security-advisories/blob/master/contao/core-bundle/CVE-2019-10643.yaml
github.com/advisories/GHSA-j99g-qjvx-995g