Every CVE Search/ Get API key

CVE-2019-10742

Denial of Service in axios

7.5 HighPublic exploitFix available

Axios up to and including 0.18.0 allows attackers to cause a denial of service (application crash) by continuing to accepting content after maxContentLength is exceeded.

Attack profile

How easy it is to exploit

Attack vector
Network
Complexity
Low
Privileges needed
None
User interaction
None

What an attacker can affect

Confidentiality
None
Integrity
None
Availability
High

Exploit likelihood

6.14%Up 5.1 points since Apr 14, 2021
90%50%10%1%

What each source reports

NVD Score used 7.5

Axios up to and including 0.18.0 allows attackers to cause a denial of service (application crash) by continuing to accepting content after maxContentLength is exceeded.

Record
CVE-2019-10742
CVSS 3.0
7.5 HighCVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
CVSS 2.0
5.0 MediumAV:N/AC:L/Au:N/C:N/I:N/A:P
Weakness
CWE-755
Updated
2026-11-02
CVE List No score

Axios up to and including 0.18.0 allows attackers to cause a denial of service (application crash) by continuing to accepting content after maxContentLength is exceeded.

Record
CVE-2019-10742
Updated
2026-11-02
EUVDEUVD-2019-0448 No score

Axios up to and including 0.18.0 allows attackers to cause a denial of service (application crash) by continuing to accepting content after maxContentLength is exceeded.

Record
EUVD-2019-0448
Updated
2026-11-03
GitHub AdvisoriesGHSA-42xw-2xvc-qx8m 7.5

Denial of Service in axios

Versions of axios prior to 0.18.1 are vulnerable to Denial of Service. If a request exceeds the maxContentLength property, the package prints an error but does not stop the request. This may cause high CPU usage and lead to Denial of Service.

Recommendation

Upgrade to 0.18.1 or later.

Record
GHSA-42xw-2xvc-qx8m
CVSS 3.0
7.5 HighCVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Weakness
CWE-20, CWE-755
Updated
2026-11-02
OSV 7.5

Axios up to and including 0.18.0 allows attackers to cause a denial of service (application crash) by continuing to accepting content after maxContentLength is exceeded.

Record
CVE-2019-10742
CVSS 3.0
7.5 HighCVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Updated
2026-11-02
OSVDEBIAN-CVE-2019-10742 7.5

Axios up to and including 0.18.0 allows attackers to cause a denial of service (application crash) by continuing to accepting content after maxContentLength is exceeded.

Record
DEBIAN-CVE-2019-10742
CVSS 3.0
7.5 HighCVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Updated
2026-11-02
Show 4 moreShow less
OSVGHSA-42xw-2xvc-qx8m 7.5

Denial of Service in axios

Versions of axios prior to 0.18.1 are vulnerable to Denial of Service. If a request exceeds the maxContentLength property, the package prints an error but does not stop the request. This may cause high CPU usage and lead to Denial of Service.

Recommendation

Upgrade to 0.18.1 or later.

Record
GHSA-42xw-2xvc-qx8m
CVSS 3.0
7.5 HighCVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Weakness
CWE-20, CWE-755
Updated
2026-11-02
OSVUBUNTU-CVE-2019-10742 7.5

Axios up to and including 0.18.0 allows attackers to cause a denial of service (application crash) by continuing to accepting content after maxContentLength is exceeded.

Record
UBUNTU-CVE-2019-10742
CVSS 3.0
7.5 HighCVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Updated
2026-11-02
OSVCLSA-2026-1776991067 No score

TuxCare security update for axios (6 CVEs)

TuxCare rebuilt axios to address 6 CVEs. Fixed in 0.15.3-tuxcare.1.

Record
CLSA-2026-1776991067
Updated
2026-11-02
OSVCLSA-2026-1793101806 No score

TuxCare security update for axios (6 CVEs)

TuxCare rebuilt axios to address 6 CVEs. Fixed in 0.18.0-tuxcare.2.

Record
CLSA-2026-1793101806
Updated
2026-11-06

Affected products

Affected packages

Affected packages
PackageAffectedFixed
axios
npm
through 0.18.0
0.18.1
axios
TuxCare:npm
From an advisory covering 6 CVEs
0.15.3-tuxcare.0 up to 0.15.3-tuxcare.1, plus listed versions
0.15.3
0.15.3-tuxcare.1
axios
TuxCare:npm
From an advisory covering 6 CVEs
0.18.0-tuxcare.0 up to 0.18.0-tuxcare.2, plus listed versions
0.18.00.18.0-tuxcare.1
0.18.0-tuxcare.2
node-axios
Debian:12
before 0.17.1+dfsg-2
0.17.1+dfsg-2
node-axios
Debian:13
before 0.17.1+dfsg-2
0.17.1+dfsg-2
node-axios
Debian:14
before 0.17.1+dfsg-2
0.17.1+dfsg-2
axios
npm
before 0.18.1
0.18.1

Public exploits

Links only. Every CVE stores no exploit code.

Public exploits
SourceLinkDate
PoC in GitHubViniciuspxf/CVE-2019-107422022-06-26

History

History
RecordedChangedSources
affectedOSV
affected, facts
affected
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV, PoC in GitHub

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2019-10742 is a high vulnerability (CVSS 7.5) in Axios, published May 7, 2019. Public exploit code exists. EPSS puts the chance of exploitation in the next 30 days at 6.14%, the 93rd percentile. Fixed in axios 0.18.1.

References

Show 5 moreShow less
MoveEnter Open