CVE-2019-10748
SQL Injection in sequelize
Sequelize all versions prior to 3.35.1, 4.44.3, and 5.8.11 are vulnerable to SQL Injection due to JSON path keys not being properly escaped for the MySQL/MariaDB dialects.
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- Low
- Privileges needed
- None
- User interaction
- None
What an attacker can affect
- Confidentiality
- High
- Integrity
- High
- Availability
- High
Exploit likelihood
What each source reports
NVD Score used
9.8
Sequelize all versions prior to 3.35.1, 4.44.3, and 5.8.11 are vulnerable to SQL Injection due to JSON path keys not being properly escaped for the MySQL/MariaDB dialects.
- Record
CVE-2019-10748- CVSS 3.1
- 9.8 Critical
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - CVSS 2.0
- 7.5 High
AV:N/AC:L/Au:N/C:P/I:P/A:P - Weakness
- CWE-89
- Updated
- 2026-11-02
CVE List No score
Sequelize all versions prior to 3.35.1, 4.44.3, and 5.8.11 are vulnerable to SQL Injection due to JSON path keys not being properly escaped for the MySQL/MariaDB dialects.
- Record
CVE-2019-10748- Updated
- 2026-11-02
EUVDEUVD-2019-0753 No score
Sequelize all versions prior to 3.35.1, 4.44.3, and 5.8.11 are vulnerable to SQL Injection due to JSON path keys not being properly escaped for the MySQL/MariaDB dialects.
- Record
EUVD-2019-0753- Updated
- 2026-11-03
GitHub AdvisoriesGHSA-j9xp-92vc-559j
9.8
SQL Injection in sequelize
Affected versions of sequelize are vulnerable to SQL Injection. The package fails to sanitize JSON path keys in the MariaDB and MySQL dialects, which may allow attackers to inject SQL statements and execute arbitrary SQL queries.
Recommendation
If you are using sequelize 5.x, upgrade to version 5.8.11 or later.
If you are using sequelize 4.x, upgrade to version 4.44.3 or later.
If you are using sequelize 3.x, upgrade to version 3.35.1 or later.
- Record
GHSA-j9xp-92vc-559j- CVSS 3.1
- 9.8 Critical
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - Weakness
- CWE-89
- Updated
- 2026-11-02
OSV
9.8
Sequelize all versions prior to 3.35.1, 4.44.3, and 5.8.11 are vulnerable to SQL Injection due to JSON path keys not being properly escaped for the MySQL/MariaDB dialects.
- Record
CVE-2019-10748- CVSS 3.1
- 9.8 Critical
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - Updated
- 2026-11-02
OSVGHSA-j9xp-92vc-559j
9.8
SQL Injection in sequelize
Affected versions of sequelize are vulnerable to SQL Injection. The package fails to sanitize JSON path keys in the MariaDB and MySQL dialects, which may allow attackers to inject SQL statements and execute arbitrary SQL queries.
Recommendation
If you are using sequelize 5.x, upgrade to version 5.8.11 or later.
If you are using sequelize 4.x, upgrade to version 4.44.3 or later.
If you are using sequelize 3.x, upgrade to version 3.35.1 or later.
- Record
GHSA-j9xp-92vc-559j- CVSS 3.1
- 9.8 Critical
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - Weakness
- CWE-89
- Updated
- 2026-11-02
OSVROOT-APP-NPM-CVE-2019-10748
9.8
CVE-2019-10748 in sequelize - Patched by Root
Root has patched CVE-2019-10748 in the sequelize package for Root:npm. Multiple fixed versions available.
- Record
ROOT-APP-NPM-CVE-2019-10748- CVSS 3.1
- 9.8 Critical
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - Updated
- 2026-11-06
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
sequelizenpm |
before 3.35.1 | 3.35.1 |
sequelizenpm |
4.0.0 up to 4.44.3 | 4.44.3 |
sequelizenpm |
5.0.0 up to 5.8.11 | 5.8.11 |
sequelizeRoot:npm |
before 4.28.1-aikido.1 | 4.28.1-aikido.14.44.3-aikido.1 |
@rootio/sequelizeRoot:npm |
before 4.28.1-root.io.1 | 4.28.1-root.io.14.44.3-root.io.1 |
History
| Recorded | Changed | Sources |
|---|---|---|
| affected | OSV | |
| affected, aliases, facts | OSV | |
| aliases, products | EUVD | |
| first indexed | CVE List, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2019-10748 is a critical vulnerability (CVSS 9.8) in Sequelize, published October 28, 2019. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 1.31%, the 70th percentile. Fixed in sequelize 3.35.1.
References
snyk.io/vuln/SNYK-JS-SEQUELIZE-450221
github.com/sequelize/sequelize/commit/a72a3f5%2C
github.com/sequelize/sequelize/pull/11089%2C
nvd.nist.gov/vuln/detail/CVE-2019-10748
github.com/sequelize/sequelize/commit/a72a3f5,
github.com/sequelize/sequelize/pull/11089,
npmjs.com/advisories/1018
github.com/advisories/GHSA-j9xp-92vc-559j