CVE-2019-10762
SQL Injection in medoo
columnQuote in medoo before 1.7.5 allows remote attackers to perform a SQL Injection due to improper escaping.
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- Low
- Privileges needed
- None
- User interaction
- None
What an attacker can affect
- Confidentiality
- High
- Integrity
- High
- Availability
- High
Exploit likelihood
What each source reports
NVD Score used
9.8
columnQuote in medoo before 1.7.5 allows remote attackers to perform a SQL Injection due to improper escaping.
- Record
CVE-2019-10762- CVSS 3.1
- 9.8 Critical
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - CVSS 2.0
- 7.5 High
AV:N/AC:L/Au:N/C:P/I:P/A:P - Weakness
- CWE-89
- Updated
- 2026-11-02
CVE List No score
columnQuote in medoo before 1.7.5 allows remote attackers to perform a SQL Injection due to improper escaping.
- Record
CVE-2019-10762- Updated
- 2026-11-02
EUVDEUVD-2021-2247 No score
columnQuote in medoo before 1.7.5 allows remote attackers to perform a SQL Injection due to improper escaping.
- Record
EUVD-2021-2247- Updated
- 2026-11-03
GitHub AdvisoriesGHSA-q9p4-qfc8-fvpp
9.8
SQL Injection in medoo
columnQuote in medoo before 1.7.5 allows remote attackers to perform a SQL Injection due to improper escaping.
- Record
GHSA-q9p4-qfc8-fvpp- CVSS 3.1
- 9.8 Critical
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - Weakness
- CWE-89
- Updated
- 2026-11-02
OSV
9.8
columnQuote in medoo before 1.7.5 allows remote attackers to perform a SQL Injection due to improper escaping.
- Record
CVE-2019-10762- CVSS 3.1
- 9.8 Critical
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - Updated
- 2026-11-02
OSVGHSA-q9p4-qfc8-fvpp
9.8
SQL Injection in medoo
columnQuote in medoo before 1.7.5 allows remote attackers to perform a SQL Injection due to improper escaping.
- Record
GHSA-q9p4-qfc8-fvpp- CVSS 3.1
- 9.8 Critical
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - Weakness
- CWE-89
- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
catfan/medooPackagist |
before 1.7.5 | 1.7.5 |
catfan/medooPackagist |
before 1.7.5, plus listed versions v0.9.5.3v0.9.6v0.9.6.2v0.9.7v0.9.8 Show 29 moreShow lessv1.0v1.0.2v1.1v1.1.1v1.1.2v1.2v1.2.1v1.4v1.4.1v1.4.2v1.4.3v1.4.4v1.4.5v1.5v1.5.1v1.5.2v1.5.3v1.5.4v1.5.5v1.5.6v1.5.7v1.5av1.6v1.6.1v1.7.0v1.7.1v1.7.2v1.7.3v1.7.4 |
1.7.5 |
History
| Recorded | Changed | Sources |
|---|---|---|
| aliases | EUVD | |
| first indexed | CVE List, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2019-10762 is a critical vulnerability (CVSS 9.8) in Medoo, published October 30, 2019. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 1.42%, the 72nd percentile. Fixed in catfan/medoo 1.7.5.