Every CVE Search/ Get API key

CVE-2019-10782

XML external entity (XXE) processing ('external-parameter-entities' feature was not fully disabled))

5.3 MediumFix available

All versions of com.puppycrawl.tools:checkstyle before 8.29 are vulnerable to XML External Entity (XXE) Injection due to an incomplete fix for CVE-2019-9658.

Attack profile

How easy it is to exploit

Attack vector
Network
Complexity
Low
Privileges needed
None
User interaction
None

What an attacker can affect

Confidentiality
Low
Integrity
None
Availability
None

Exploit likelihood

1.53%Up 0.7 points since Apr 14, 2021
90%50%10%1%

What each source reports

NVD Score used 5.3

All versions of com.puppycrawl.tools:checkstyle before 8.29 are vulnerable to XML External Entity (XXE) Injection due to an incomplete fix for CVE-2019-9658.

Record
CVE-2019-10782
CVSS 3.1
5.3 MediumCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N
CVSS 2.0
5.0 MediumAV:N/AC:L/Au:N/C:P/I:N/A:N
Weakness
CWE-611
Updated
2026-11-02
CVE List No score

All versions of com.puppycrawl.tools:checkstyle before 8.29 are vulnerable to XML External Entity (XXE) Injection due to an incomplete fix for CVE-2019-9658.

Record
CVE-2019-10782
Updated
2026-11-02
EUVDEUVD-2020-0251 No score

All versions of com.puppycrawl.tools:checkstyle before 8.29 are vulnerable to XML External Entity (XXE) Injection due to an incomplete fix for CVE-2019-9658.

Record
EUVD-2020-0251
Updated
2026-11-03
GitHub AdvisoriesGHSA-763g-fqq7-48wg 5.3

XML external entity (XXE) processing ('external-parameter-entities' feature was not fully disabled))

Due to an incomplete fix for CVE-2019-9658, checkstyle was still vulnerable to XML External Entity (XXE) Processing.

Impact

User: Build Maintainers

This vulnerability probably doesn't impact Maven/Gradle users as, in most cases, these builds are processing files that are trusted, or pre-vetted by a pull request reviewer before being run on internal CI infrastructure.

User: Static Analysis as a Service

If you operate a site/service that parses "untrusted" Checkstyle XML configuration files, you are vulnerable to this and should patch.

Note from the discoverer of the original CVE-2019-9658:

While looking at a few companies that run Checkstyle/PMD/ect... as a service I notice that it's a common pattern to run the static code analysis tool inside of a Docker container with the following flags:

--net=none \
--privileged=false \
--cap-drop=ALL

Running the analysis in Docker has the advantage that there should be no sensitive local file information that XXE can exfiltrate from the container. Additionally, these flags prevent vulnerabilities in static analysis tools like Checkstyle from being used to exfiltrate data via XXE or to perform SSRF. - Jonathan Leitschuh

Patches

Has the problem been patched? What versions should users upgrade to?

Patched, will be released with version 8.29 at 26 Jan 2020.

Workarounds

Is there a way for users to fix or remediate the vulnerability without upgrading?

No workaround are available

References

For more information

If you have any questions or comments about this advisory:

Record
GHSA-763g-fqq7-48wg
CVSS 3.1
5.3 MediumCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N
Weakness
CWE-611
Updated
2026-11-02
OSV 5.3

All versions of com.puppycrawl.tools:checkstyle before 8.29 are vulnerable to XML External Entity (XXE) Injection due to an incomplete fix for CVE-2019-9658.

Record
CVE-2019-10782
CVSS 3.1
5.3 MediumCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N
Updated
2026-11-02
OSVDEBIAN-CVE-2019-10782 5.3

All versions of com.puppycrawl.tools:checkstyle before 8.29 are vulnerable to XML External Entity (XXE) Injection due to an incomplete fix for CVE-2019-9658.

Record
DEBIAN-CVE-2019-10782
CVSS 3.1
5.3 MediumCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N
Updated
2026-11-02
OSVGHSA-763g-fqq7-48wg 5.3

XML external entity (XXE) processing ('external-parameter-entities' feature was not fully disabled))

Due to an incomplete fix for CVE-2019-9658, checkstyle was still vulnerable to XML External Entity (XXE) Processing.

Impact

User: Build Maintainers

This vulnerability probably doesn't impact Maven/Gradle users as, in most cases, these builds are processing files that are trusted, or pre-vetted by a pull request reviewer before being run on internal CI infrastructure.

User: Static Analysis as a Service

If you operate a site/service that parses "untrusted" Checkstyle XML configuration files, you are vulnerable to this and should patch.

Note from the discoverer of the original CVE-2019-9658:

While looking at a few companies that run Checkstyle/PMD/ect... as a service I notice that it's a common pattern to run the static code analysis tool inside of a Docker container with the following flags:

--net=none \
--privileged=false \
--cap-drop=ALL

Running the analysis in Docker has the advantage that there should be no sensitive local file information that XXE can exfiltrate from the container. Additionally, these flags prevent vulnerabilities in static analysis tools like Checkstyle from being used to exfiltrate data via XXE or to perform SSRF. - Jonathan Leitschuh

Patches

Has the problem been patched? What versions should users upgrade to?

Patched, will be released with version 8.29 at 26 Jan 2020.

Workarounds

Is there a way for users to fix or remediate the vulnerability without upgrading?

No workaround are available

References

For more information

If you have any questions or comments about this advisory:

Record
GHSA-763g-fqq7-48wg
CVSS 3.1
5.3 MediumCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N
Weakness
CWE-611
Updated
2026-11-02
OSVUBUNTU-CVE-2019-10782 5.3

All versions of com.puppycrawl.tools:checkstyle before 8.29 are vulnerable to XML External Entity (XXE) Injection due to an incomplete fix for CVE-2019-9658.

Record
UBUNTU-CVE-2019-10782
CVSS 3.1
5.3 MediumCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
com.puppycrawl.tools:checkstyle
Maven
before 8.29
8.29
checkstyle
Debian:12
before 8.29-1
8.29-1
checkstyle
Debian:13
before 8.29-1
8.29-1
checkstyle
Debian:14
before 8.29-1
8.29-1
checkstyle
Debian:8
before 5.9-1+deb8u2, plus listed versions
5.9-15.9-1+deb8u1
5.9-1+deb8u2
com.puppycrawl.tools:checkstyle
Maven
before 8.29, plus listed versions
5.25.35.45.55.6
Show 45 moreShow less
5.75.85.96.06.16.1.16.106.10.16.116.11.16.11.26.126.12.16.136.146.14.16.156.166.16.16.176.186.196.26.36.46.4.16.56.66.76.86.8.16.8.26.97.07.17.1.17.1.27.27.37.47.57.5.17.67.6.17.7
8.29
checkstyle
Ubuntu:16.04:LTS
All versions, plus listed versions
5.9-16.12.1-16.13-16.14.1-16.15-1
None known
checkstyle
Ubuntu:18.04:LTS
All versions, plus listed versions
6.15-17.5.1-28.8-1
None known

History

History
RecordedChangedSources
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2019-10782 is a medium vulnerability (CVSS 5.3) in Checkstyle, published January 30, 2020. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 1.53%, the 74th percentile. Fixed in com.puppycrawl.tools:checkstyle 8.29.

References

Show 6 moreShow less
This page doesn't list everything

Left out here: 33 versions. The JSON record has them.

MoveEnter Open