Every CVE Search/ Get API key

CVE-2019-10784

phppgadmin through 7.12.1 allows sensitive actions to be performed without validating that the...

9.6 CriticalFix available

CVE-2019-10784 is a critical vulnerability (CVSS 9.6) in Phppgadmin, published February 4, 2020. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 3.64%, the 89th percentile. Fixed in phppgadmin 7.14.7+dfsg-1.

phppgadmin through 7.12.1 allows sensitive actions to be performed without validating that the request originated from the application. One such area, "database.php" does not verify the source of an HTTP request. This can be leveraged by a remote attacker to trick a logged-in administrator to visit a malicious page with a CSRF exploit and execute arbitrary system commands on the server.

Attack profile

How easy it is to exploit

Attack vector
Network
Complexity
Low
Privileges needed
None
User interaction
Required

What an attacker can affect

Confidentiality
High
Integrity
High
Availability
High

Exploit likelihood

3.64%Up 3.1 points since Apr 14, 2021
90%50%10%1%

What each source reports

NVD Score used 9.6

phppgadmin through 7.12.1 allows sensitive actions to be performed without validating that the request originated from the application. One such area, "database.php" does not verify the source of an HTTP request. This can be leveraged by a remote attacker to trick a logged-in administrator to visit a malicious page with a CSRF exploit and execute arbitrary system commands on the server.

Record
CVE-2019-10784
CVSS 3.1
9.6 CriticalCVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:H/I:H/A:H
CVSS 2.0
9.3 HighAV:N/AC:M/Au:N/C:C/I:C/A:C
Weakness
CWE-352
Updated
2026-11-02
CVE List No score

phppgadmin through 7.12.1 allows sensitive actions to be performed without validating that the request originated from the application. One such area, "database.php" does not verify the source of an HTTP request. This can be leveraged by a remote attacker to trick a logged-in administrator to visit a malicious page with a CSRF exploit and execute arbitrary system commands on the server.

Record
CVE-2019-10784
Updated
2026-11-02
EUVDEUVD-2019-2537 No score

phppgadmin through 7.12.1 allows sensitive actions to be performed without validating that the request originated from the application. One such area, "database.php" does not verify the source of an HTTP request. This can be leveraged by a remote attacker to trick a logged-in administrator to visit a malicious page with a CSRF exploit and execute arbitrary system commands on the server.

Record
EUVD-2019-2537
Updated
2026-11-03
GitHub AdvisoriesGHSA-84mp-rmf8-wc24 No score

phppgadmin through 7.12.1 allows sensitive actions to be performed without validating that the...

phppgadmin through 7.12.1 allows sensitive actions to be performed without validating that the request originated from the application. One such area, "database.php" does not verify the source of an HTTP request. This can be leveraged by a remote attacker to trick a logged-in administrator to visit a malicious page with a CSRF exploit and execute arbitrary system commands on the server.

Record
GHSA-84mp-rmf8-wc24
Updated
2026-11-02
OSV 9.6

phppgadmin through 7.12.1 allows sensitive actions to be performed without validating that the request originated from the application. One such area, "database.php" does not verify the source of an HTTP request. This can be leveraged by a remote attacker to trick a logged-in administrator to visit a malicious page with a CSRF exploit and execute arbitrary system commands on the server.

Record
CVE-2019-10784
CVSS 3.1
9.6 CriticalCVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:H/I:H/A:H
Updated
2026-11-02
OSVDEBIAN-CVE-2019-10784 9.6

phppgadmin through 7.12.1 allows sensitive actions to be performed without validating that the request originated from the application. One such area, "database.php" does not verify the source of an HTTP request. This can be leveraged by a remote attacker to trick a logged-in administrator to visit a malicious page with a CSRF exploit and execute arbitrary system commands on the server.

Record
DEBIAN-CVE-2019-10784
CVSS 3.1
9.6 CriticalCVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:H/I:H/A:H
Updated
2026-11-02
Show 4 moreShow less
OSVUBUNTU-CVE-2019-10784 9.6

phppgadmin through 7.12.1 allows sensitive actions to be performed without validating that the request originated from the application. One such area, "database.php" does not verify the source of an HTTP request. This can be leveraged by a remote attacker to trick a logged-in administrator to visit a malicious page with a CSRF exploit and execute arbitrary system commands on the server.

Record
UBUNTU-CVE-2019-10784
CVSS 3.1
9.6 CriticalCVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:H/I:H/A:H
Updated
2026-11-02
OSVMGASA-2021-0074 No score

Updated phppgadmin package fixes a security vulnerability

phppgadmin through 7.12.1 allows sensitive actions to be performed without validating that the request originated from the application. One such area, database.php does not verify the source of an HTTP request. This can be leveraged by a remote attacker to trick a logged-in administrator to visit a malicious page with a CSRF exploit and execute arbitrary system commands on the server (CVE-2019-10784).

Record
MGASA-2021-0074
Updated
2026-11-02
OSVopenSUSE-SU-2022:10065-1 No score

Security update for phpPgAdmin

This update for phpPgAdmin fixes the following issues:

  • CVE-2019-10784: Fixed improper source validation that could lead to CSRF (boo#1162794)
Record
openSUSE-SU-2022:10065-1
Updated
2026-11-02
OSVopenSUSE-SU-2024:12194-1 No score

phpPgAdmin-7.13.0-2.1 on GA media

These are all security issues fixed in the phpPgAdmin-7.13.0-2.1 package on the GA media of openSUSE Tumbleweed.

Record
openSUSE-SU-2024:12194-1
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
phppgadmin
Debian:13
before 7.14.7+dfsg-1
7.14.7+dfsg-1
phppgadmin
Debian:14
before 7.14.7+dfsg-1
7.14.7+dfsg-1
phppgadmin
Mageia:7
before 7.13.0-1.mga7
7.13.0-1.mga7
phppgadmin
Ubuntu:16.04:LTS
All versions, plus listed versions
5.1+ds-15.1+ds-1ubuntu1
None known
phppgadmin
Ubuntu:18.04:LTS
All versions, plus listed versions
5.1+ds-25.1+ds-3
None known
phppgadmin
Ubuntu:20.04:LTS
All versions, plus listed versions
5.1+ds-47.12.0+ds-27.12.0+ds-37.12.1+dfsg-1
None known
phppgadmin
Ubuntu:22.04:LTS
All versions, plus listed versions
7.13.0+dfsg-2
None known
phppgadmin
Ubuntu:24.04:LTS
All versions, plus listed versions
7.13.0+dfsg-27.13.0+dfsg-37.14.7+dfsg-1
None known
phppgadmin
Ubuntu:25.10
All versions, plus listed versions
7.14.7+dfsg-1
None known
phppgadmin
Ubuntu:26.10
All versions, plus listed versions
7.14.7+dfsg-1build17.14.8+dfsg-1
None known
Show 5 moreShow less
Affected packages
PackageAffectedFixed
phppgadmin
Ubuntu:26.04:LTS
All versions, plus listed versions
7.14.7+dfsg-17.14.7+dfsg-1build1
None known
phpPgAdmin
SUSE:Package Hub 15 SP3
before 7.13.0-bp154.2.3.1
7.13.0-bp154.2.3.1
phpPgAdmin
SUSE:Package Hub 15 SP4
before 7.13.0-bp154.2.3.1
7.13.0-bp154.2.3.1
phpPgAdmin
openSUSE:Leap 15.3
before 7.13.0-bp154.2.3.1
7.13.0-bp154.2.3.1
phpPgAdmin
openSUSE:Leap 15.4
before 7.13.0-bp154.2.3.1
7.13.0-bp154.2.3.1

History

History
WhenChangedSources
2026-11-03aliases, productsEUVD
2026-11-02createdCVE List, GitHub Advisories, NVD, OSV

References

Show 5 moreShow less
MoveEnter Open