CVE-2019-11002
Materialize-css vulnerable to Cross-site Scripting in tooltip component
In Materialize through 1.0.0, XSS is possible via the Tooltip feature.
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- Low
- Privileges needed
- None
- User interaction
- Required
What an attacker can affect
- Confidentiality
- Low
- Integrity
- Low
- Availability
- None
Exploit likelihood
What each source reports
NVD Score used
6.1
In Materialize through 1.0.0, XSS is possible via the Tooltip feature.
- Record
CVE-2019-11002- CVSS 3.0
- 6.1 Medium
CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N - CVSS 2.0
- 4.3 Medium
AV:N/AC:M/Au:N/C:N/I:P/A:N - Weakness
- CWE-79
- Updated
- 2026-11-02
CVE List No score
In Materialize through 1.0.0, XSS is possible via the Tooltip feature.
- Record
CVE-2019-11002- Updated
- 2026-11-02
EUVDEUVD-2019-0413 No score
In Materialize through 1.0.0, XSS is possible via the Tooltip feature.
- Record
EUVD-2019-0413- Updated
- 2026-11-03
GitHub AdvisoriesGHSA-98f7-p5rc-jx67
6.1
Materialize-css vulnerable to Cross-site Scripting in tooltip component
All versions of materialize-css are vulnerable to Cross-Site Scripting. The tooltip component does not sufficiently sanitize user input, allowing an attacker to execute arbitrary JavaScript code if the malicious input is rendered by a user.
Recommendation
No fix is currently available. Consider using an alternative module until a fix is made available.
- Record
GHSA-98f7-p5rc-jx67- CVSS 3.0
- 6.1 Medium
CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N - Weakness
- CWE-79
- Updated
- 2026-11-02
OSV
6.1
In Materialize through 1.0.0, XSS is possible via the Tooltip feature.
- Record
CVE-2019-11002- CVSS 3.0
- 6.1 Medium
CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N - Updated
- 2026-11-02
OSVGHSA-98f7-p5rc-jx67
6.1
Materialize-css vulnerable to Cross-site Scripting in tooltip component
All versions of materialize-css are vulnerable to Cross-Site Scripting. The tooltip component does not sufficiently sanitize user input, allowing an attacker to execute arbitrary JavaScript code if the malicious input is rendered by a user.
Recommendation
No fix is currently available. Consider using an alternative module until a fix is made available.
- Record
GHSA-98f7-p5rc-jx67- CVSS 3.0
- 6.1 Medium
CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N - Weakness
- CWE-79
- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
materialize-cssnpm |
through 1.0.0 | None known |
@materializecss/materializenpm |
before 1.1.0-alpha | 1.1.0-alpha |
History
| Recorded | Changed | Sources |
|---|---|---|
| aliases | EUVD | |
| first indexed | CVE List, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2019-11002 is a medium vulnerability (CVSS 6.1) in Materializecss Materialize, published April 8, 2019. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.80%, the 56th percentile. Fixed in @materializecss/materialize 1.1.0-alpha.