CVE-2019-11027
ruby-openid SSRF via claimed_id request
Ruby OpenID (aka ruby-openid) through 2.8.0 has a remotely exploitable flaw. This library is used by Rails web applications to integrate with OpenID Providers. Severity can range from medium to critical, depending on how a web application developer chose to employ the ruby-openid library. Developers who based their OpenID integration heavily on the "example app" provided by the project are at highest risk.
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- Low
- Privileges needed
- None
- User interaction
- None
What an attacker can affect
- Confidentiality
- High
- Integrity
- High
- Availability
- High
Exploit likelihood
What each source reports
NVD Score used
9.8
Ruby OpenID (aka ruby-openid) through 2.8.0 has a remotely exploitable flaw. This library is used by Rails web applications to integrate with OpenID Providers. Severity can range from medium to critical, depending on how a web application developer chose to employ the ruby-openid library. Developers who based their OpenID integration heavily on the "example app" provided by the project are at highest risk.
- Record
CVE-2019-11027- CVSS 3.0
- 9.8 Critical
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - CVSS 2.0
- 10.0 High
AV:N/AC:L/Au:N/C:C/I:C/A:C - Updated
- 2026-11-02
CVE List No score
Ruby OpenID (aka ruby-openid) through 2.8.0 has a remotely exploitable flaw. This library is used by Rails web applications to integrate with OpenID Providers. Severity can range from medium to critical, depending on how a web application developer chose to employ the ruby-openid library. Developers who based their OpenID integration heavily on the "example app" provided by the project are at highest risk.
- Record
CVE-2019-11027- Updated
- 2026-11-02
EUVDEUVD-2019-0532 No score
Ruby OpenID (aka ruby-openid) through 2.8.0 has a remotely exploitable flaw. This library is used by Rails web applications to integrate with OpenID Providers. Severity can range from medium to critical, depending on how a web application developer chose to employ the ruby-openid library. Developers who based their OpenID integration heavily on the "example app" provided by the project are at highest risk.
- Record
EUVD-2019-0532- Updated
- 2026-11-03
GitHub AdvisoriesGHSA-fqfj-cmh6-hj49
9.8
ruby-openid SSRF via claimed_id request
Ruby OpenID (aka ruby-openid) through 2.8.0 is vulnerable to SSRF. Ruby-openid performs discovery first, and then verification. This allows an attacker to change the URL used for discovery and trick the server into connecting to the URL, which might be a private server not publicly accessible. Severity can range from medium to critical, depending on how a web application developer chose to employ the ruby-openid library. Developers who based their OpenID integration heavily on the "example app" provided by the project are at highest risk.
- Record
GHSA-fqfj-cmh6-hj49- CVSS 3.0
- 9.8 Critical
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - Weakness
- CWE-918
- Updated
- 2026-11-02
OSV
9.8
Ruby OpenID (aka ruby-openid) through 2.8.0 has a remotely exploitable flaw. This library is used by Rails web applications to integrate with OpenID Providers. Severity can range from medium to critical, depending on how a web application developer chose to employ the ruby-openid library. Developers who based their OpenID integration heavily on the "example app" provided by the project are at highest risk.
- Record
CVE-2019-11027- CVSS 3.0
- 9.8 Critical
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - Updated
- 2026-11-02
OSVDEBIAN-CVE-2019-11027
9.8
Ruby OpenID (aka ruby-openid) through 2.8.0 has a remotely exploitable flaw. This library is used by Rails web applications to integrate with OpenID Providers. Severity can range from medium to critical, depending on how a web application developer chose to employ the ruby-openid library. Developers who based their OpenID integration heavily on the "example app" provided by the project are at highest risk.
- Record
DEBIAN-CVE-2019-11027- CVSS 3.0
- 9.8 Critical
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - Updated
- 2026-11-02
OSVGHSA-fqfj-cmh6-hj49
9.8
ruby-openid SSRF via claimed_id request
Ruby OpenID (aka ruby-openid) through 2.8.0 is vulnerable to SSRF. Ruby-openid performs discovery first, and then verification. This allows an attacker to change the URL used for discovery and trick the server into connecting to the URL, which might be a private server not publicly accessible. Severity can range from medium to critical, depending on how a web application developer chose to employ the ruby-openid library. Developers who based their OpenID integration heavily on the "example app" provided by the project are at highest risk.
- Record
GHSA-fqfj-cmh6-hj49- CVSS 3.0
- 9.8 Critical
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - Weakness
- CWE-918
- Updated
- 2026-11-02
OSVUBUNTU-CVE-2019-11027
9.8
Ruby OpenID (aka ruby-openid) through 2.8.0 has a remotely exploitable flaw. This library is used by Rails web applications to integrate with OpenID Providers. Severity can range from medium to critical, depending on how a web application developer chose to employ the ruby-openid library. Developers who based their OpenID integration heavily on the "example app" provided by the project are at highest risk.
- Record
UBUNTU-CVE-2019-11027- CVSS 3.0
- 9.8 Critical
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
ruby-openidRubyGems |
before 2.9.0 | 2.9.0 |
ruby-openidDebian:12 |
before 2.9.2debian-1 | 2.9.2debian-1 |
ruby-openidDebian:13 |
before 2.9.2debian-1 | 2.9.2debian-1 |
ruby-openidDebian:14 |
before 2.9.2debian-1 | 2.9.2debian-1 |
ruby-openidDebian:8 |
before 2.5.0debian-1+deb8u1, plus listed versions 2.5.0debian-1 |
2.5.0debian-1+deb8u1 |
ruby-openidRubyGems |
before 2.9.0, plus listed versions 1.01.0.11.0.21.1.11.1.2 Show 22 moreShow less1.1.31.1.42.0.12.0.22.0.32.0.42.1.22.1.42.1.52.1.62.1.72.1.82.2.02.2.12.2.22.2.32.3.02.4.02.5.02.6.02.7.02.8.0 |
2.9.0 |
ruby-openidUbuntu:16.04:LTS |
All versions, plus listed versions 2.7.0debian-1 |
None known |
ruby-openidUbuntu:18.04:LTS |
All versions, plus listed versions 2.7.0debian-1 |
None known |
History
| Recorded | Changed | Sources |
|---|---|---|
| aliases | EUVD | |
| first indexed | CVE List, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2019-11027 is a critical vulnerability (CVSS 9.8) in Openid Ruby-openid, published June 10, 2019. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 2.97%, the 87th percentile. Fixed in ruby-openid 2.9.0.
References
marc.info?l=openid-security&m=155154717027534&w=2
github.com/openid/ruby-openid/issues/122
lists.debian.org/debian-lts-announce/2019/10/msg00014.html
security.gentoo.org/glsa/202003-09
nvd.nist.gov/vuln/detail/CVE-2019-11027
github.com/openid/ruby-openid/commit/d181a8a2099c64365a1d24b29f6b6b646673a131
Show 7 moreShow less
github.com/openid/ruby-openid/releases/tag/v2.9.0
github.com/rubysec/ruby-advisory-db/blob/master/gems/ruby-openid/CVE-2019-11027.yml
github.com/advisories/GHSA-fqfj-cmh6-hj49
security-tracker.debian.org/tracker/CVE-2019-11027
github.com/openid/ruby-openid
ubuntu.com/security/CVE-2019-11027
cve.org/CVERecord?id=CVE-2019-11027