Every CVE Search/ Get API key

CVE-2019-11065

Insecure transport protocol in Gradle

5.9 MediumFix available

Gradle versions from 1.4 to 5.3.1 use an insecure HTTP URL to download dependencies when the built-in JavaScript or CoffeeScript Gradle plugins are used. Dependency artifacts could have been maliciously compromised by a MITM attack against the ajax.googleapis.com web site.

Attack profile

How easy it is to exploit

Attack vector
Network
Complexity
High
Privileges needed
None
User interaction
None

What an attacker can affect

Confidentiality
High
Integrity
None
Availability
None

Exploit likelihood

1.36%Up 0.3 points since Apr 14, 2021
90%50%10%1%

What each source reports

NVD Score used 5.9

Gradle versions from 1.4 to 5.3.1 use an insecure HTTP URL to download dependencies when the built-in JavaScript or CoffeeScript Gradle plugins are used. Dependency artifacts could have been maliciously compromised by a MITM attack against the ajax.googleapis.com web site.

Record
CVE-2019-11065
CVSS 3.1
5.9 MediumCVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:N/A:N
CVSS 2.0
4.3 MediumAV:N/AC:M/Au:N/C:P/I:N/A:N
Updated
2026-11-02
CVE List No score

Gradle versions from 1.4 to 5.3.1 use an insecure HTTP URL to download dependencies when the built-in JavaScript or CoffeeScript Gradle plugins are used. Dependency artifacts could have been maliciously compromised by a MITM attack against the ajax.googleapis.com web site.

Record
CVE-2019-11065
Updated
2026-11-02
EUVDEUVD-2022-4803 No score

Gradle versions from 1.4 to 5.3.1 use an insecure HTTP URL to download dependencies when the built-in JavaScript or CoffeeScript Gradle plugins are used. Dependency artifacts could have been maliciously compromised by a MITM attack against the ajax.googleapis.com web site.

Record
EUVD-2022-4803
Updated
2026-11-03
GitHub AdvisoriesGHSA-pprq-4488-wgqx 5.9

Insecure transport protocol in Gradle

Gradle versions from 1.4 to 5.3.1 use an insecure HTTP URL to download dependencies when the built-in JavaScript or CoffeeScript Gradle plugins are used. Dependency artifacts could have been maliciously compromised by a MITM attack against the ajax.googleapis.com web site.

Record
GHSA-pprq-4488-wgqx
CVSS 3.0
5.9 MediumCVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:N/A:N
Weakness
CWE-319
Updated
2026-11-02
OSVBELL-CVE-2019-11065 5.9

CVE-2019-11065 does not affect BellSoft software

Record
BELL-CVE-2019-11065
CVSS 3.1
5.9 MediumCVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:N/A:N
Updated
2026-11-02
OSV 5.9

Gradle versions from 1.4 to 5.3.1 use an insecure HTTP URL to download dependencies when the built-in JavaScript or CoffeeScript Gradle plugins are used. Dependency artifacts could have been maliciously compromised by a MITM attack against the ajax.googleapis.com web site.

Record
CVE-2019-11065
CVSS 3.1
5.9 MediumCVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:N/A:N
Updated
2026-11-02
Show 4 moreShow less
OSVDEBIAN-CVE-2019-11065 5.9

Gradle versions from 1.4 to 5.3.1 use an insecure HTTP URL to download dependencies when the built-in JavaScript or CoffeeScript Gradle plugins are used. Dependency artifacts could have been maliciously compromised by a MITM attack against the ajax.googleapis.com web site.

Record
DEBIAN-CVE-2019-11065
CVSS 3.1
5.9 MediumCVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:N/A:N
Updated
2026-11-02
OSVGHSA-pprq-4488-wgqx 5.9

Insecure transport protocol in Gradle

Gradle versions from 1.4 to 5.3.1 use an insecure HTTP URL to download dependencies when the built-in JavaScript or CoffeeScript Gradle plugins are used. Dependency artifacts could have been maliciously compromised by a MITM attack against the ajax.googleapis.com web site.

Record
GHSA-pprq-4488-wgqx
CVSS 3.0
5.9 MediumCVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:N/A:N
Weakness
CWE-319
Updated
2026-11-02
OSVUBUNTU-CVE-2019-11065 5.9

Gradle versions from 1.4 to 5.3.1 use an insecure HTTP URL to download dependencies when the built-in JavaScript or CoffeeScript Gradle plugins are used. Dependency artifacts could have been maliciously compromised by a MITM attack against the ajax.googleapis.com web site.

Record
UBUNTU-CVE-2019-11065
CVSS 3.1
5.9 MediumCVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:N/A:N
Updated
2026-11-02
OSVUSN-4858-1 No score

gradle vulnerabilities

It was discovered that Gradle used an insecure HTTP URL to download dependencies when the built-in JavaScript or CoffeeScript Gradle plugins were used. A remote unauthenticated attacker could possibly use this issue to perform a machine-in-the-middle attack. (CVE-2019-11065)

It was discovered that the PGP signing plugin in Gradle relied on the insecure SHA-1 algorithm. An attacker could possibly use this issue to conduct spoofing attacks. (CVE-2019-16370)

Record
USN-4858-1
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
org.gradle:gradle-core
Maven
1.4 up to 5.4.0
5.4.0
gradle
Debian:12
before 4.4.1-10
4.4.1-10
gradle
Debian:13
before 4.4.1-10
4.4.1-10
gradle
Debian:14
before 4.4.1-10
4.4.1-10
gradle
Ubuntu:16.04:LTS
All versions, plus listed versions
2.5-32.7-12.7-22.7-32.10-1
None known
gradle
Ubuntu:Pro:18.04:LTS
before 4.4.1-5ubuntu2~18.04+esm1, plus listed versions
3.2.1-3build23.2.1-43.2.1-53.4.1-43.4.1-63.4.1-7ubuntu14.4.1-5ubuntu2~18.04
4.4.1-5ubuntu2~18.04+esm1
gradle
Ubuntu:Pro:18.04:LTS
From an advisory covering 2 CVEs
before 4.4.1-5ubuntu2~18.04+esm1, plus listed versions
3.2.1-3build23.2.1-43.2.1-53.4.1-43.4.1-63.4.1-7ubuntu14.4.1-5ubuntu2~18.04
4.4.1-5ubuntu2~18.04+esm1

History

History
RecordedChangedSources
affected, facts
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2019-11065 is a medium vulnerability (CVSS 5.9) in Gradle, published April 9, 2019. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 1.36%, the 71st percentile. Fixed in org.gradle:gradle-core 5.4.0.

References

Show 10 moreShow less
MoveEnter Open