CVE-2019-11069
SQL Injection in sequelize
CVE-2019-11069 is a high vulnerability (CVSS 7.5) in Sequelizejs Sequelize, published April 10, 2019. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 1.82%, the 78th percentile. Fixed in sequelize 5.3.0.
Sequelize version 5 before 5.3.0 does not properly ensure that standard conforming strings are used.
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- Low
- Privileges needed
- None
- User interaction
- None
What an attacker can affect
- Confidentiality
- None
- Integrity
- High
- Availability
- None
Exploit likelihood
What each source reports
NVD Score used
7.5
Sequelize version 5 before 5.3.0 does not properly ensure that standard conforming strings are used.
- Record
CVE-2019-11069- CVSS 3.0
- 7.5 High
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N - CVSS 2.0
- 5.0 Medium
AV:N/AC:L/Au:N/C:N/I:P/A:N - Weakness
- CWE-20
- Updated
- 2026-11-02
CVE List No score
Sequelize version 5 before 5.3.0 does not properly ensure that standard conforming strings are used.
- Record
CVE-2019-11069- Updated
- 2026-11-02
EUVDEUVD-2019-0399 No score
Sequelize version 5 before 5.3.0 does not properly ensure that standard conforming strings are used.
- Record
EUVD-2019-0399- Updated
- 2026-11-03
GitHub AdvisoriesGHSA-2777-2vq8-c4v4
7.5
SQL Injection in sequelize
Versions of sequelize prior to 5.3.0 (excluding v3 and v4) are vulnerable to SQL Injection. PostgreSQL optionstandard_conforming_strings is not set to on by default, which may allow attackers to inject SQL statements due to poor handling of backslashes in string literals.
Recommendation
Upgrade to version 5.3.0 or later.
- Record
GHSA-2777-2vq8-c4v4- CVSS 3.0
- 7.5 High
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N - Weakness
- CWE-20
- Updated
- 2026-11-02
OSV
7.5
Sequelize version 5 before 5.3.0 does not properly ensure that standard conforming strings are used.
- Record
CVE-2019-11069- CVSS 3.0
- 7.5 High
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N - Updated
- 2026-11-02
OSVGHSA-2777-2vq8-c4v4
7.5
SQL Injection in sequelize
Versions of sequelize prior to 5.3.0 (excluding v3 and v4) are vulnerable to SQL Injection. PostgreSQL optionstandard_conforming_strings is not set to on by default, which may allow attackers to inject SQL statements due to poor handling of backslashes in string literals.
Recommendation
Upgrade to version 5.3.0 or later.
- Record
GHSA-2777-2vq8-c4v4- CVSS 3.0
- 7.5 High
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N - Weakness
- CWE-20
- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
sequelizenpm |
5.0.0 up to 5.3.0 | 5.3.0 |
History
| When | Changed | Sources |
|---|---|---|
| 2026-11-03 | aliases | EUVD |
| 2026-11-02 | created | CVE List, GitHub Advisories, NVD, OSV |
References
github.com/sequelize/sequelize/pull/10746/files
github.com/sequelize/sequelize/releases/tag/v5.3.0
github.com/sequelize/sequelize/blob/98cb17c17f73e2aa1792aa5a1d31216ba984b456/lib/dialects/postgres/connection-manager.js
github.com/sequelize/sequelize/commit/850c7fd04669e0fef9238b6dc4f8d6ee93ed71e9
nvd.nist.gov/vuln/detail/CVE-2019-11069
github.com/sequelize/sequelize/pull/10746
snyk.io/vuln/SNYK-JS-SEQUELIZE-174167
github.com/advisories/GHSA-2777-2vq8-c4v4
github.com/sequelize/sequelize