Every CVE Search/ Get API key

CVE-2019-11484

Integer overflow in bson_ensure_space

6.3 MediumFix available

Kevin Backhouse discovered an integer overflow in bson_ensure_space, as used in whoopsie.

Attack profile

How easy it is to exploit

Attack vector
Local
Complexity
Low
Privileges needed
Low
User interaction
None

What an attacker can affect

Confidentiality
Low
Integrity
Low
Availability
Low

Exploit likelihood

0.44%Down 0.2 points since Apr 14, 2021
90%50%10%1%

What each source reports

CVE List Score used 6.3

Integer overflow in bson_ensure_space

Kevin Backhouse discovered an integer overflow in bson_ensure_space, as used in whoopsie.

Record
CVE-2019-11484
CVSS 3.1
6.3 MediumCVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:L
Weakness
CWE-190
Updated
2026-11-02
EUVDEUVD-2019-3157 6.3

Kevin Backhouse discovered an integer overflow in bson_ensure_space, as used in whoopsie.

Record
EUVD-2019-3157
CVSS 3.1
6.3 MediumCVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:L
Updated
2026-11-03
GitHub AdvisoriesGHSA-rwvc-6fhr-c2q7 7.8

Kevin Backhouse discovered an integer overflow in bson_ensure_space, as used in whoopsie.

Kevin Backhouse discovered an integer overflow in bson_ensure_space, as used in whoopsie.

Record
GHSA-rwvc-6fhr-c2q7
CVSS 3.1
7.8 HighCVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
Weakness
CWE-190
Updated
2026-11-02
NVD 6.3

Kevin Backhouse discovered an integer overflow in bson_ensure_space, as used in whoopsie.

Record
CVE-2019-11484
CVSS 3.1
6.3 MediumCVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:L
CVSS 3.1
7.8 HighCVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
CVSS 2.0
4.6 MediumAV:L/AC:L/Au:N/C:P/I:P/A:P
Weakness
CWE-190
Updated
2026-11-02
OSVUBUNTU-CVE-2019-11484 6.3

Kevin Backhouse discovered an integer overflow in bson_ensure_space, as used in whoopsie.

Record
UBUNTU-CVE-2019-11484
CVSS 3.1
6.3 MediumCVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:L
CVSS 3.1
7.8 HighCVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
Updated
2026-11-02
OSVUSN-4170-1 No score

whoopsie vulnerability

Kevin Backhouse discovered Whoopsie incorrectly handled very large crash reports. A local attacker could possibly use this issue to cause a denial of service, expose sensitive information or execute code as the whoopsie user.

Record
USN-4170-1
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
whoopsie
Ubuntu:16.04:LTS
before 0.2.52.5ubuntu0.2, plus listed versions
0.2.490.2.500.2.510.2.520.2.52.1
Show 5 moreShow less
0.2.52.20.2.52.30.2.52.40.2.52.50.2.52.5ubuntu0.1
0.2.52.5ubuntu0.2
duo-unix
Ubuntu:16.04:LTS
All versions, plus listed versions
1.9.11-1
None known
whoopsie
Ubuntu:18.04:LTS
before 0.2.62ubuntu0.2, plus listed versions
0.2.580.2.590.2.59build10.2.600.2.620.2.62ubuntu0.1
0.2.62ubuntu0.2
duo-unix
Ubuntu:18.04:LTS
All versions, plus listed versions
1.9.21-11.9.21-1build1
None known
whoopsie
Ubuntu:20.04:LTS
before 0.2.68, plus listed versions
0.2.660.2.67
0.2.68
duo-unix
Ubuntu:20.04:LTS
All versions, plus listed versions
1.9.21-1.11.11.3-1
None known
duo-unix
Ubuntu:22.04:LTS
All versions, plus listed versions
1.11.3-11.11.3-1build1
None known
duo-unix
Ubuntu:24.04:LTS
All versions, plus listed versions
1.11.3-1build11.11.3-1.11.11.3-1.1build11.11.3-1.1build2
None known
duo-unix
Ubuntu:25.10
All versions, plus listed versions
1.11.3-1.2
None known
duo-unix
Ubuntu:26.10
All versions, plus listed versions
1.11.3-1.2build11.11.3-1.2ubuntu1
None known
duo-unix
Ubuntu:26.04:LTS
All versions, plus listed versions
1.11.3-1.21.11.3-1.2build1
None known

History

History
RecordedChangedSources
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2019-11484 is a medium vulnerability (CVSS 6.3) in Canonical Whoopsie, published October 29, 2019. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.44%, the 38th percentile. Fixed in whoopsie 0.2.52.5ubuntu0.2.

References

MoveEnter Open