CVE-2019-11514
Flarum mishandles invalidation of user email tokens
User/Command/ConfirmEmailHandler.php in Flarum before 0.1.0-beta.8 mishandles invalidation of user email tokens.
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- Low
- Privileges needed
- None
- User interaction
- None
What an attacker can affect
- Confidentiality
- None
- Integrity
- High
- Availability
- None
Exploit likelihood
What each source reports
NVD Score used
7.5
User/Command/ConfirmEmailHandler.php in Flarum before 0.1.0-beta.8 mishandles invalidation of user email tokens.
- Record
CVE-2019-11514- CVSS 3.0
- 7.5 High
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N - CVSS 2.0
- 5.0 Medium
AV:N/AC:L/Au:N/C:N/I:P/A:N - Weakness
- CWE-459
- Updated
- 2026-11-02
CVE List No score
User/Command/ConfirmEmailHandler.php in Flarum before 0.1.0-beta.8 mishandles invalidation of user email tokens.
- Record
CVE-2019-11514- Updated
- 2026-11-02
EUVDEUVD-2022-3907 No score
User/Command/ConfirmEmailHandler.php in Flarum before 0.1.0-beta.8 mishandles invalidation of user email tokens.
- Record
EUVD-2022-3907- Updated
- 2026-11-03
GitHub AdvisoriesGHSA-g6w5-439m-jhwv
7.5
Flarum mishandles invalidation of user email tokens
User/Command/ConfirmEmailHandler.php in Flarum before 0.1.0-beta.8 mishandles invalidation of user email tokens.
- Record
GHSA-g6w5-439m-jhwv- CVSS 3.0
- 7.5 High
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N - Weakness
- CWE-459
- Updated
- 2026-11-02
OSV
7.5
User/Command/ConfirmEmailHandler.php in Flarum before 0.1.0-beta.8 mishandles invalidation of user email tokens.
- Record
CVE-2019-11514- CVSS 3.0
- 7.5 High
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N - Updated
- 2026-11-02
OSVGHSA-g6w5-439m-jhwv
7.5
Flarum mishandles invalidation of user email tokens
User/Command/ConfirmEmailHandler.php in Flarum before 0.1.0-beta.8 mishandles invalidation of user email tokens.
- Record
GHSA-g6w5-439m-jhwv- CVSS 3.0
- 7.5 High
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N - Weakness
- CWE-459
- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
flarum/flarumPackagist |
before 0.1.0-beta.8 | 0.1.0-beta.8 |
flarum/flarumPackagist |
before 0.1.0-beta.8, plus listed versions v0.1.0-beta.3v0.1.0-beta.4v0.1.0-beta.5v0.1.0-beta.6v0.1.0-beta.7 |
0.1.0-beta.8 |
History
| Recorded | Changed | Sources |
|---|---|---|
| aliases | EUVD | |
| first indexed | CVE List, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2019-11514 is a high vulnerability (CVSS 7.5) in Flarum, published April 25, 2019. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 1.34%, the 71st percentile. Fixed in flarum/flarum 0.1.0-beta.8.