CVE-2019-11834
cJSON before 1.7.11 allows out-of-bounds access, related to \x00 in a string literal.
cJSON before 1.7.11 allows out-of-bounds access, related to \x00 in a string literal.
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- Low
- Privileges needed
- None
- User interaction
- None
What an attacker can affect
- Confidentiality
- High
- Integrity
- High
- Availability
- High
Exploit likelihood
What each source reports
NVD Score used
9.8
cJSON before 1.7.11 allows out-of-bounds access, related to \x00 in a string literal.
- Record
CVE-2019-11834- CVSS 3.1
- 9.8 Critical
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - CVSS 2.0
- 7.5 High
AV:N/AC:L/Au:N/C:P/I:P/A:P - Weakness
- CWE-125, CWE-787
- Updated
- 2026-11-02
CVE List No score
cJSON before 1.7.11 allows out-of-bounds access, related to \x00 in a string literal.
- Record
CVE-2019-11834- Updated
- 2026-11-02
EUVDEUVD-2019-3497 No score
cJSON before 1.7.11 allows out-of-bounds access, related to \x00 in a string literal.
- Record
EUVD-2019-3497- Updated
- 2026-11-03
GitHub AdvisoriesGHSA-f8rc-mjx7-r7jf
9.8
cJSON before 1.7.11 allows out-of-bounds access, related to \x00 in a string literal.
cJSON before 1.7.11 allows out-of-bounds access, related to \x00 in a string literal.
- Record
GHSA-f8rc-mjx7-r7jf- CVSS 3.1
- 9.8 Critical
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - Weakness
- CWE-119, CWE-125
- Updated
- 2026-11-02
OSVAZL-41111
9.8
CVE-2019-11834 affecting package libglvnd for versions less than 1.7.0-2
cJSON before 1.7.11 allows out-of-bounds access, related to \x00 in a string literal.
- Record
AZL-41111- CVSS 3.1
- 9.8 Critical
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - Updated
- 2026-11-05
OSV
9.8
cJSON before 1.7.11 allows out-of-bounds access, related to \x00 in a string literal.
- Record
CVE-2019-11834- CVSS 3.1
- 9.8 Critical
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - Updated
- 2026-11-02
OSVDEBIAN-CVE-2019-11834
9.8
cJSON before 1.7.11 allows out-of-bounds access, related to \x00 in a string literal.
- Record
DEBIAN-CVE-2019-11834- CVSS 3.1
- 9.8 Critical
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - Updated
- 2026-11-02
Affected products
Affected packages
History
| Recorded | Changed | Sources |
|---|---|---|
| facts | OSV | |
| aliases | EUVD | |
| first indexed | CVE List, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2019-11834 is a critical vulnerability (CVSS 9.8) in Davegamble Cjson, published May 9, 2019. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 2.52%, the 84th percentile. Fixed in libglvnd 1.7.0-2.
References
oracle.com/security-alerts/cpuoct2020.html
github.com/DaveGamble/cJSON/issues/337
github.com/DaveGamble/cJSON/releases/tag/v1.7.11
github.com/DaveGamble/cJSON/compare/c69134d...93688cb
nvd.nist.gov/vuln/detail/CVE-2019-11834
github.com/advisories/GHSA-f8rc-mjx7-r7jf
security-tracker.debian.org/tracker/CVE-2019-11834