CVE-2019-11835
cJSON before 1.7.11 allows out-of-bounds access, related to multiline comments.
cJSON before 1.7.11 allows out-of-bounds access, related to multiline comments.
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- Low
- Privileges needed
- None
- User interaction
- None
What an attacker can affect
- Confidentiality
- High
- Integrity
- High
- Availability
- High
Exploit likelihood
What each source reports
NVD Score used
9.8
cJSON before 1.7.11 allows out-of-bounds access, related to multiline comments.
- Record
CVE-2019-11835- CVSS 3.1
- 9.8 Critical
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - CVSS 2.0
- 7.5 High
AV:N/AC:L/Au:N/C:P/I:P/A:P - Weakness
- CWE-125, CWE-787
- Updated
- 2026-11-02
CVE List No score
cJSON before 1.7.11 allows out-of-bounds access, related to multiline comments.
- Record
CVE-2019-11835- Updated
- 2026-11-02
EUVDEUVD-2019-3498 No score
cJSON before 1.7.11 allows out-of-bounds access, related to multiline comments.
- Record
EUVD-2019-3498- Updated
- 2026-11-03
GitHub AdvisoriesGHSA-3x2j-h977-v75r
9.8
cJSON before 1.7.11 allows out-of-bounds access, related to multiline comments.
cJSON before 1.7.11 allows out-of-bounds access, related to multiline comments.
- Record
GHSA-3x2j-h977-v75r- CVSS 3.1
- 9.8 Critical
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - Weakness
- CWE-119, CWE-125
- Updated
- 2026-11-02
OSVAZL-41390
9.8
CVE-2019-11835 affecting package libglvnd for versions less than 1.7.0-2
cJSON before 1.7.11 allows out-of-bounds access, related to multiline comments.
- Record
AZL-41390- CVSS 3.1
- 9.8 Critical
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - Updated
- 2026-11-05
OSV
9.8
cJSON before 1.7.11 allows out-of-bounds access, related to multiline comments.
- Record
CVE-2019-11835- CVSS 3.1
- 9.8 Critical
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - Updated
- 2026-11-02
OSVDEBIAN-CVE-2019-11835
9.8
cJSON before 1.7.11 allows out-of-bounds access, related to multiline comments.
- Record
DEBIAN-CVE-2019-11835- CVSS 3.1
- 9.8 Critical
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - Updated
- 2026-11-02
Affected products
Affected packages
History
| Recorded | Changed | Sources |
|---|---|---|
| facts | OSV | |
| aliases | EUVD | |
| first indexed | CVE List, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2019-11835 is a critical vulnerability (CVSS 9.8) in Davegamble Cjson, published May 9, 2019. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 2.56%, the 85th percentile. Fixed in libglvnd 1.7.0-2.
References
oracle.com/security-alerts/cpuoct2020.html
github.com/DaveGamble/cJSON/releases/tag/v1.7.11
github.com/DaveGamble/cJSON/compare/c69134d...93688cb
github.com/DaveGamble/cJSON/issues/338
nvd.nist.gov/vuln/detail/CVE-2019-11835
github.com/advisories/GHSA-3x2j-h977-v75r
security-tracker.debian.org/tracker/CVE-2019-11835