CVE-2019-12105
In supervisord in Supervisor through 4.0.2, an unauthenticated user can read log files or restart...
In Supervisor through 4.0.2, an unauthenticated user can read log files or restart a service. Note: The maintainer responded that the affected component, inet_http_server, is not enabled by default but if the user enables it and does not set a password, Supervisor logs a warning message. The maintainer indicated the ability to run an open server will not be removed but an additional warning was added to the documentation
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- Low
- Privileges needed
- None
- User interaction
- None
What an attacker can affect
- Confidentiality
- Low
- Integrity
- None
- Availability
- High
Exploit likelihood
What each source reports
NVD Score used
8.2
In Supervisor through 4.0.2, an unauthenticated user can read log files or restart a service. Note: The maintainer responded that the affected component, inet_http_server, is not enabled by default but if the user enables it and does not set a password, Supervisor logs a warning message. The maintainer indicated the ability to run an open server will not be removed but an additional warning was added to the documentation
- Record
CVE-2019-12105- CVSS 3.1
- 8.2 High
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:H - CVSS 2.0
- 6.4 Medium
AV:N/AC:L/Au:N/C:P/I:N/A:P - Weakness
- CWE-306
- Updated
- 2026-11-02
CVE List No score
In Supervisor through 4.0.2, an unauthenticated user can read log files or restart a service. Note: The maintainer responded that the affected component, inet_http_server, is not enabled by default but if the user enables it and does not set a password, Supervisor logs a warning message. The maintainer indicated the ability to run an open server will not be removed but an additional warning was added to the documentation
- Record
CVE-2019-12105- Updated
- 2026-11-02
EUVDEUVD-2019-0136 No score
In Supervisor through 4.0.2, an unauthenticated user can read log files or restart a service. Note: The maintainer responded that the affected component, inet_http_server, is not enabled by default but if the user enables it and does not set a password, Supervisor logs a warning message. The maintainer indicated the ability to run an open server will not be removed but an additional warning was added to the documentation
- Record
EUVD-2019-0136- Updated
- 2026-11-03
GitHub AdvisoriesGHSA-6x94-2xr2-xgw3 No score
In supervisord in Supervisor through 4.0.2, an unauthenticated user can read log files or restart...
In supervisord in Supervisor through 4.0.2, an unauthenticated user can read log files or restart a service. WARNING: This issue will not be fixed by the maintainer. The ability to run an open server will not be removed because users often use it for local development, therefore no action will be taken.
- Record
GHSA-6x94-2xr2-xgw3- Updated
- 2026-11-02
OSVALPINE-CVE-2019-12105
8.2
In Supervisor through 4.0.2, an unauthenticated user can read log files or restart a service. Note: The maintainer responded that the affected component, inet_http_server, is not enabled by default but if the user enables it and does not set a password, Supervisor logs a warning message. The maintainer indicated the ability to run an open server will not be removed but an additional warning was added to the documentation
- Record
ALPINE-CVE-2019-12105- CVSS 3.1
- 8.2 High
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:H - Updated
- 2026-11-02
OSV
8.2
In Supervisor through 4.0.2, an unauthenticated user can read log files or restart a service. Note: The maintainer responded that the affected component, inet_http_server, is not enabled by default but if the user enables it and does not set a password, Supervisor logs a warning message. The maintainer indicated the ability to run an open server will not be removed but an additional warning was added to the documentation
- Record
CVE-2019-12105- CVSS 3.1
- 8.2 High
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:H - Updated
- 2026-11-02
OSVDEBIAN-CVE-2019-12105
8.2
In Supervisor through 4.0.2, an unauthenticated user can read log files or restart a service. Note: The maintainer responded that the affected component, inet_http_server, is not enabled by default but if the user enables it and does not set a password, Supervisor logs a warning message. The maintainer indicated the ability to run an open server will not be removed but an additional warning was added to the documentation
- Record
DEBIAN-CVE-2019-12105- CVSS 3.1
- 8.2 High
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:H - Updated
- 2026-11-02
OSVopenSUSE-SU-2024:11414-1 No score
supervisor-4.1.0-1.8 on GA media
These are all security issues fixed in the supervisor-4.1.0-1.8 package on the GA media of openSUSE Tumbleweed.
- Record
openSUSE-SU-2024:11414-1- Updated
- 2026-11-02
OSVPYSEC-2019-126 No score
** DISPUTED ** In Supervisor through 4.0.2, an unauthenticated user can read log files or restart a service. Note: The maintainer responded that the affected component, inet_http_server, is not enabled by default but if the user enables it and does not set a password, Supervisor logs a warning message. The maintainer indicated the ability to run an open server will not be removed but an additional warning was added to the documentation.
- Record
PYSEC-2019-126- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
supervisorAlpine:v3.12 |
before 4.1.0-r0 | 4.1.0-r0 |
supervisorAlpine:v3.13 |
before 4.1.0-r0 | 4.1.0-r0 |
supervisorAlpine:v3.14 |
before 4.1.0-r0 | 4.1.0-r0 |
supervisorAlpine:v3.15 |
before 4.1.0-r0 | 4.1.0-r0 |
supervisorAlpine:v3.16 |
before 4.1.0-r0 | 4.1.0-r0 |
supervisorAlpine:v3.17 |
before 4.1.0-r0 | 4.1.0-r0 |
supervisorAlpine:v3.18 |
before 4.1.0-r0 | 4.1.0-r0 |
supervisorAlpine:v3.19 |
before 4.1.0-r0 | 4.1.0-r0 |
supervisorAlpine:v3.20 |
before 4.1.0-r0 | 4.1.0-r0 |
supervisorAlpine:v3.21 |
before 4.1.0-r0 | 4.1.0-r0 |
Show 8 moreShow less
| Package | Affected | Fixed |
|---|---|---|
supervisorAlpine:v3.22 |
before 4.1.0-r0 | 4.1.0-r0 |
supervisorAlpine:v3.23 |
before 4.1.0-r0 | 4.1.0-r0 |
supervisorAlpine:v3.24 |
before 4.1.0-r0 | 4.1.0-r0 |
supervisorDebian:12 |
All versions, plus listed versions 4.2.5-14.2.5-1.14.2.5-24.2.5-34.3.0-14.3.0-2 |
None known |
supervisorDebian:13 |
All versions, plus listed versions 4.2.5-34.3.0-14.3.0-2 |
None known |
supervisorDebian:14 |
All versions, plus listed versions 4.2.5-34.3.0-14.3.0-2 |
None known |
supervisorPyPI |
before 4.0.3, plus listed versions a32.0b12.02.1b12.1 Show 37 moreShow less2.2b13.0a13.0a23.0a33.0a43.0a53.0a63.0a73.0a83.0a93.0a103.0a113.0a123.0b13.0b23.03.0.13.1.03.1.13.1.23.1.33.1.43.2.03.2.13.2.23.2.33.2.43.3.03.3.13.3.23.3.33.3.43.3.53.4.04.0.04.0.14.0.2 |
4.0.3 |
supervisoropenSUSE:Tumbleweed |
before 4.1.0-1.8 | 4.1.0-1.8 |
History
| Recorded | Changed | Sources |
|---|---|---|
| aliases | EUVD | |
| first indexed | CVE List, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2019-12105 is a high vulnerability (CVSS 8.2) in Supervisord Supervisor, published September 10, 2019. Its validity is disputed. EPSS puts the chance of exploitation in the next 30 days at 2.31%, the 83rd percentile. Fixed in supervisor 4.1.0-r0.
References
github.com/Supervisor/supervisor/commit/4e334d9cf2a1daff685893e35e72398437df3dcb
github.com/Supervisor/supervisor/issues/1245
supervisord.org/configuration.html
nvd.nist.gov/vuln/detail/CVE-2019-12105
github.com/advisories/GHSA-6x94-2xr2-xgw3
security.alpinelinux.org/vuln/CVE-2019-12105
security-tracker.debian.org/tracker/CVE-2019-12105
suse.com/security/cve/CVE-2019-12105