CVE-2019-12106
The updateDevice function in minissdpd.c in MiniUPnP MiniSSDPd 1.4 and 1.5 allows a remote...
The updateDevice function in minissdpd.c in MiniUPnP MiniSSDPd 1.4 and 1.5 allows a remote attacker to crash the process due to a Use After Free vulnerability.
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- Low
- Privileges needed
- None
- User interaction
- None
What an attacker can affect
- Confidentiality
- None
- Integrity
- None
- Availability
- High
Exploit likelihood
What each source reports
NVD Score used
7.5
The updateDevice function in minissdpd.c in MiniUPnP MiniSSDPd 1.4 and 1.5 allows a remote attacker to crash the process due to a Use After Free vulnerability.
- Record
CVE-2019-12106- CVSS 3.0
- 7.5 High
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H - CVSS 2.0
- 5.0 Medium
AV:N/AC:L/Au:N/C:N/I:N/A:P - Weakness
- CWE-416
- Updated
- 2026-11-02
CVE List No score
The updateDevice function in minissdpd.c in MiniUPnP MiniSSDPd 1.4 and 1.5 allows a remote attacker to crash the process due to a Use After Free vulnerability.
- Record
CVE-2019-12106- Updated
- 2026-11-02
EUVDEUVD-2019-3757 No score
The updateDevice function in minissdpd.c in MiniUPnP MiniSSDPd 1.4 and 1.5 allows a remote attacker to crash the process due to a Use After Free vulnerability.
- Record
EUVD-2019-3757- Updated
- 2026-11-03
GitHub AdvisoriesGHSA-cwrg-89hf-2658 No score
The updateDevice function in minissdpd.c in MiniUPnP MiniSSDPd 1.4 and 1.5 allows a remote...
The updateDevice function in minissdpd.c in MiniUPnP MiniSSDPd 1.4 and 1.5 allows a remote attacker to crash the process due to a Use After Free vulnerability.
- Record
GHSA-cwrg-89hf-2658- Updated
- 2026-11-02
OSV
7.5
The updateDevice function in minissdpd.c in MiniUPnP MiniSSDPd 1.4 and 1.5 allows a remote attacker to crash the process due to a Use After Free vulnerability.
- Record
CVE-2019-12106- CVSS 3.0
- 7.5 High
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H - Updated
- 2026-11-02
OSVDEBIAN-CVE-2019-12106
7.5
The updateDevice function in minissdpd.c in MiniUPnP MiniSSDPd 1.4 and 1.5 allows a remote attacker to crash the process due to a Use After Free vulnerability.
- Record
DEBIAN-CVE-2019-12106- CVSS 3.0
- 7.5 High
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H - Updated
- 2026-11-02
OSVUBUNTU-CVE-2019-12106
7.5
The updateDevice function in minissdpd.c in MiniUPnP MiniSSDPd 1.4 and 1.5 allows a remote attacker to crash the process due to a Use After Free vulnerability.
- Record
UBUNTU-CVE-2019-12106- CVSS 3.0
- 7.5 High
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H - Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
minissdpdDebian:12 |
before 1.5.20190210-1 | 1.5.20190210-1 |
minissdpdDebian:13 |
before 1.5.20190210-1 | 1.5.20190210-1 |
minissdpdDebian:14 |
before 1.5.20190210-1 | 1.5.20190210-1 |
minissdpdDebian:8 |
before 1.2.20130907-3+deb8u2, plus listed versions 1.2.20130907-31.2.20130907-3+deb8u1 |
1.2.20130907-3+deb8u2 |
minissdpdUbuntu:16.04:LTS |
before 1.2.20130907-3+deb8u2build0.16.04.1, plus listed versions 1.2.20130907-31.2.20130907-3+deb8u1build0.16.04.1 |
1.2.20130907-3+deb8u2build0.16.04.1 |
minissdpdUbuntu:18.04:LTS |
All versions, plus listed versions 1.2.20130907-4.11.5.20161216-11.5.20161216-21.5.20180223-1 |
None known |
History
| Recorded | Changed | Sources |
|---|---|---|
| aliases | EUVD | |
| first indexed | CVE List, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2019-12106 is a high vulnerability (CVSS 7.5) in Miniupnp Project Miniupnpd, published May 15, 2019. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 2.83%, the 86th percentile. Fixed in minissdpd 1.5.20190210-1.
References
vdoo.com/blog/security-issues-discovered-in-miniupnp
github.com/miniupnp/miniupnp/commit/cd506a67e174a45c6a202eff182a712955ed6d6f
lists.debian.org/debian-lts-announce/2019/05/msg00037.html
nvd.nist.gov/vuln/detail/CVE-2019-12106
github.com/advisories/GHSA-cwrg-89hf-2658
security-tracker.debian.org/tracker/CVE-2019-12106
ubuntu.com/security/CVE-2019-12106
cve.org/CVERecord?id=CVE-2019-12106