CVE-2019-12107
The upnp_event_prepare function in upnpevents.c in MiniUPnP MiniUPnPd through 2.1 allows a remote...
The upnp_event_prepare function in upnpevents.c in MiniUPnP MiniUPnPd through 2.1 allows a remote attacker to leak information from the heap due to improper validation of an snprintf return value.
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- Low
- Privileges needed
- None
- User interaction
- None
What an attacker can affect
- Confidentiality
- High
- Integrity
- None
- Availability
- None
Exploit likelihood
What each source reports
NVD Score used
7.5
The upnp_event_prepare function in upnpevents.c in MiniUPnP MiniUPnPd through 2.1 allows a remote attacker to leak information from the heap due to improper validation of an snprintf return value.
- Record
CVE-2019-12107- CVSS 3.0
- 7.5 High
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N - CVSS 2.0
- 5.0 Medium
AV:N/AC:L/Au:N/C:P/I:N/A:N - Weakness
- CWE-252
- Updated
- 2026-11-02
CVE List No score
The upnp_event_prepare function in upnpevents.c in MiniUPnP MiniUPnPd through 2.1 allows a remote attacker to leak information from the heap due to improper validation of an snprintf return value.
- Record
CVE-2019-12107- Updated
- 2026-11-02
EUVDEUVD-2019-3758 No score
The upnp_event_prepare function in upnpevents.c in MiniUPnP MiniUPnPd through 2.1 allows a remote attacker to leak information from the heap due to improper validation of an snprintf return value.
- Record
EUVD-2019-3758- Updated
- 2026-11-03
GitHub AdvisoriesGHSA-wh92-hmx9-3mf2 No score
The upnp_event_prepare function in upnpevents.c in MiniUPnP MiniUPnPd through 2.1 allows a remote...
The upnp_event_prepare function in upnpevents.c in MiniUPnP MiniUPnPd through 2.1 allows a remote attacker to leak information from the heap due to improper validation of an snprintf return value.
- Record
GHSA-wh92-hmx9-3mf2- Updated
- 2026-11-02
OSV
7.5
The upnp_event_prepare function in upnpevents.c in MiniUPnP MiniUPnPd through 2.1 allows a remote attacker to leak information from the heap due to improper validation of an snprintf return value.
- Record
CVE-2019-12107- CVSS 3.0
- 7.5 High
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N - Updated
- 2026-11-02
OSVDEBIAN-CVE-2019-12107
7.5
The upnp_event_prepare function in upnpevents.c in MiniUPnP MiniUPnPd through 2.1 allows a remote attacker to leak information from the heap due to improper validation of an snprintf return value.
- Record
DEBIAN-CVE-2019-12107- CVSS 3.0
- 7.5 High
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N - Updated
- 2026-11-02
OSVUBUNTU-CVE-2019-12107
7.5
The upnp_event_prepare function in upnpevents.c in MiniUPnP MiniUPnPd through 2.1 allows a remote attacker to leak information from the heap due to improper validation of an snprintf return value.
- Record
UBUNTU-CVE-2019-12107- CVSS 3.0
- 7.5 High
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N - Updated
- 2026-11-02
OSVUSN-4542-1 No score
miniupnpd vulnerabilities
It was discovered that MiniUPnPd did not properly validate callback addresses. A remote attacker could possibly use this issue to expose sensitive information. (CVE-2019-12107)
It was discovered that MiniUPnPd incorrectly handled unpopulated user XML input. An attacker could possibly use this issue to cause MiniUPnPd to crash, resulting in a denial of service. (CVE-2019-12108, CVE-2019-12109)
It was discovered that MiniUPnPd incorrectly handled an empty description when port mapping. An attacker could possibly use this issue to cause MiniUPnPd to crash, resulting in a denial of service. (CVE-2019-12110)
It was discovered that MiniUPnPd did not properly parse certain PCP requests. An attacker could possibly use this issue to cause MiniUPnPd to crash, resulting in a denial of service. (CVE-2019-12111)
- Record
USN-4542-1- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
miniupnpdDebian:12 |
before 2.1-6 | 2.1-6 |
miniupnpdDebian:13 |
before 2.1-6 | 2.1-6 |
miniupnpdDebian:14 |
before 2.1-6 | 2.1-6 |
miniupnpdDebian:8 From an advisory covering 6 CVEs |
before 1.8.20140523-4+deb8u1, plus listed versions 1.8.20140523-4 |
1.8.20140523-4+deb8u1 |
miniupnpdUbuntu:16.04:LTS |
before 1.8.20140523-4.1+deb9u2build0.16.04.1, plus listed versions 1.8.20140523-41.8.20140523-4.1+deb9u1build0.16.04.1 |
1.8.20140523-4.1+deb9u2build0.16.04.1 |
miniupnpdUbuntu:Pro:18.04:LTS |
All versions, plus listed versions 1.8.20140523-4.11.8.20140523-4.22.0.20171212-12.0.20171212-22.0.20171212-2ubuntu0.1~esm1 |
None known |
miniupnpdUbuntu:16.04:LTS From an advisory covering 5 CVEs |
before 1.8.20140523-4.1+deb9u2build0.16.04.1, plus listed versions 1.8.20140523-41.8.20140523-4.1+deb9u1build0.16.04.1 |
1.8.20140523-4.1+deb9u2build0.16.04.1 |
History
| Recorded | Changed | Sources |
|---|---|---|
| affected, facts | ||
| aliases | EUVD | |
| first indexed | CVE List, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2019-12107 is a high vulnerability (CVSS 7.5) in Miniupnp.free Miniupnpd, published May 15, 2019. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 3.03%, the 87th percentile. Fixed in miniupnpd 2.1-6.
References
vdoo.com/blog/security-issues-discovered-in-miniupnp
github.com/miniupnp/miniupnp/commit/bec6ccec63cadc95655721bc0e1dd49dac759d94
lists.debian.org/debian-lts-announce/2019/05/msg00045.html
usn.ubuntu.com/4542-1
nvd.nist.gov/vuln/detail/CVE-2019-12107
github.com/advisories/GHSA-wh92-hmx9-3mf2