Every CVE Search/ Get API key

CVE-2019-12111

A Denial Of Service vulnerability in MiniUPnP MiniUPnPd through 2.1 exists due to a NULL pointer...

7.5 HighFix available

A Denial Of Service vulnerability in MiniUPnP MiniUPnPd through 2.1 exists due to a NULL pointer dereference in copyIPv6IfDifferent in pcpserver.c.

Attack profile

How easy it is to exploit

Attack vector
Network
Complexity
Low
Privileges needed
None
User interaction
None

What an attacker can affect

Confidentiality
None
Integrity
None
Availability
High

Exploit likelihood

3.40%Up 2.1 points since Apr 14, 2021
90%50%10%1%

What each source reports

NVD Score used 7.5

A Denial Of Service vulnerability in MiniUPnP MiniUPnPd through 2.1 exists due to a NULL pointer dereference in copyIPv6IfDifferent in pcpserver.c.

Record
CVE-2019-12111
CVSS 3.1
7.5 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
CVSS 2.0
5.0 MediumAV:N/AC:L/Au:N/C:N/I:N/A:P
Weakness
CWE-476
Updated
2026-11-02
CVE List No score

A Denial Of Service vulnerability in MiniUPnP MiniUPnPd through 2.1 exists due to a NULL pointer dereference in copyIPv6IfDifferent in pcpserver.c.

Record
CVE-2019-12111
Updated
2026-11-02
EUVDEUVD-2019-3762 No score

A Denial Of Service vulnerability in MiniUPnP MiniUPnPd through 2.1 exists due to a NULL pointer dereference in copyIPv6IfDifferent in pcpserver.c.

Record
EUVD-2019-3762
Updated
2026-11-03
GitHub AdvisoriesGHSA-c73r-f56x-5ph3 No score

A Denial Of Service vulnerability in MiniUPnP MiniUPnPd through 2.1 exists due to a NULL pointer...

A Denial Of Service vulnerability in MiniUPnP MiniUPnPd through 2.1 exists due to a NULL pointer dereference in copyIPv6IfDifferent in pcpserver.c.

Record
GHSA-c73r-f56x-5ph3
Updated
2026-11-02
OSV 7.5

A Denial Of Service vulnerability in MiniUPnP MiniUPnPd through 2.1 exists due to a NULL pointer dereference in copyIPv6IfDifferent in pcpserver.c.

Record
CVE-2019-12111
CVSS 3.1
7.5 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Updated
2026-11-02
OSVDEBIAN-CVE-2019-12111 7.5

A Denial Of Service vulnerability in MiniUPnP MiniUPnPd through 2.1 exists due to a NULL pointer dereference in copyIPv6IfDifferent in pcpserver.c.

Record
DEBIAN-CVE-2019-12111
CVSS 3.1
7.5 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Updated
2026-11-02
OSVUBUNTU-CVE-2019-12111 7.5

A Denial Of Service vulnerability in MiniUPnP MiniUPnPd through 2.1 exists due to a NULL pointer dereference in copyIPv6IfDifferent in pcpserver.c.

Record
UBUNTU-CVE-2019-12111
CVSS 3.1
7.5 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Updated
2026-11-02
OSVUSN-4542-1 No score

miniupnpd vulnerabilities

It was discovered that MiniUPnPd did not properly validate callback addresses. A remote attacker could possibly use this issue to expose sensitive information. (CVE-2019-12107)

It was discovered that MiniUPnPd incorrectly handled unpopulated user XML input. An attacker could possibly use this issue to cause MiniUPnPd to crash, resulting in a denial of service. (CVE-2019-12108, CVE-2019-12109)

It was discovered that MiniUPnPd incorrectly handled an empty description when port mapping. An attacker could possibly use this issue to cause MiniUPnPd to crash, resulting in a denial of service. (CVE-2019-12110)

It was discovered that MiniUPnPd did not properly parse certain PCP requests. An attacker could possibly use this issue to cause MiniUPnPd to crash, resulting in a denial of service. (CVE-2019-12111)

Record
USN-4542-1
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
miniupnpd
Debian:12
before 2.1-6
2.1-6
miniupnpd
Debian:13
before 2.1-6
2.1-6
miniupnpd
Debian:14
before 2.1-6
2.1-6
miniupnpd
Debian:8
From an advisory covering 6 CVEs
before 1.8.20140523-4+deb8u1, plus listed versions
1.8.20140523-4
1.8.20140523-4+deb8u1
miniupnpd
Ubuntu:16.04:LTS
before 1.8.20140523-4.1+deb9u2build0.16.04.1, plus listed versions
1.8.20140523-41.8.20140523-4.1+deb9u1build0.16.04.1
1.8.20140523-4.1+deb9u2build0.16.04.1
miniupnpd
Ubuntu:Pro:18.04:LTS
All versions, plus listed versions
1.8.20140523-4.11.8.20140523-4.22.0.20171212-12.0.20171212-22.0.20171212-2ubuntu0.1~esm1
None known
miniupnpd
Ubuntu:16.04:LTS
From an advisory covering 5 CVEs
before 1.8.20140523-4.1+deb9u2build0.16.04.1, plus listed versions
1.8.20140523-41.8.20140523-4.1+deb9u1build0.16.04.1
1.8.20140523-4.1+deb9u2build0.16.04.1

History

History
RecordedChangedSources
affected, facts
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2019-12111 is a high vulnerability (CVSS 7.5) in Miniupnp Project Miniupnpd, published May 15, 2019. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 3.40%, the 88th percentile. Fixed in miniupnpd 2.1-6.

References

Show 8 moreShow less
MoveEnter Open