CVE-2019-12385
An issue was discovered in Ampache through 3.9.1. The search engine is affected by a SQL...
An issue was discovered in Ampache through 3.9.1. The search engine is affected by a SQL Injection, so any user able to perform lib/class/search.class.php searches (even guest users) can dump any data contained in the database (sessions, hashed passwords, etc.). This may lead to a full compromise of admin accounts, when combined with the weak password generator algorithm used in the lostpassword functionality.
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- Low
- Privileges needed
- Low
- User interaction
- None
What an attacker can affect
- Confidentiality
- High
- Integrity
- High
- Availability
- High
Exploit likelihood
What each source reports
NVD Score used
8.8
An issue was discovered in Ampache through 3.9.1. The search engine is affected by a SQL Injection, so any user able to perform lib/class/search.class.php searches (even guest users) can dump any data contained in the database (sessions, hashed passwords, etc.). This may lead to a full compromise of admin accounts, when combined with the weak password generator algorithm used in the lostpassword functionality.
- Record
CVE-2019-12385- CVSS 3.0
- 8.8 High
CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H - CVSS 2.0
- 6.5 Medium
AV:N/AC:L/Au:S/C:P/I:P/A:P - Weakness
- CWE-89
- Updated
- 2026-11-02
CVE List No score
An issue was discovered in Ampache through 3.9.1. The search engine is affected by a SQL Injection, so any user able to perform lib/class/search.class.php searches (even guest users) can dump any data contained in the database (sessions, hashed passwords, etc.). This may lead to a full compromise of admin accounts, when combined with the weak password generator algorithm used in the lostpassword functionality.
- Record
CVE-2019-12385- Updated
- 2026-11-02
EUVDEUVD-2019-4019 No score
An issue was discovered in Ampache through 3.9.1. The search engine is affected by a SQL Injection, so any user able to perform lib/class/search.class.php searches (even guest users) can dump any data contained in the database (sessions, hashed passwords, etc.). This may lead to a full compromise of admin accounts, when combined with the weak password generator algorithm used in the lostpassword functionality.
- Record
EUVD-2019-4019- Updated
- 2026-11-03
GitHub AdvisoriesGHSA-p72w-3684-2crg
8.8
An issue was discovered in Ampache through 3.9.1. The search engine is affected by a SQL...
An issue was discovered in Ampache through 3.9.1. The search engine is affected by a SQL Injection, so any user able to perform lib/class/search.class.php searches (even guest users) can dump any data contained in the database (sessions, hashed passwords, etc.). This may lead to a full compromise of admin accounts, when combined with the weak password generator algorithm used in the lostpassword functionality.
- Record
GHSA-p72w-3684-2crg- CVSS 3.0
- 8.8 High
CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H - Weakness
- CWE-89
- Updated
- 2026-11-02
OSVUBUNTU-CVE-2019-12385
8.8
An issue was discovered in Ampache through 3.9.1. The search engine is affected by a SQL Injection, so any user able to perform lib/class/search.class.php searches (even guest users) can dump any data contained in the database (sessions, hashed passwords, etc.). This may lead to a full compromise of admin accounts, when combined with the weak password generator algorithm used in the lostpassword functionality.
- Record
UBUNTU-CVE-2019-12385- CVSS 3.0
- 8.8 High
CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H - Updated
- 2026-11-02
OSVUSN-4693-1 No score
ampache vulnerabilities
It was discovered that an SQL injection vulnerability exists in the Ampache search engine. Any user able to perform searches could dump any data contained in the database. An attacker could use this to disclose sensitive information. (CVE-2019-12385)
It was discovered that an XSS vulnerability in Ampache. An attacker could use this vulnerability to force an admin to create a new privileged user. (CVE-2019-12386)
- Record
USN-4693-1- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
ampacheDebian:8 |
before 3.6-rzb2752+dfsg-5+deb8u1, plus listed versions 3.6-rzb2752+dfsg-5 |
3.6-rzb2752+dfsg-5+deb8u1 |
ampacheUbuntu:16.04:LTS |
before 3.6-rzb2779+dfsg-0ubuntu9.2, plus listed versions 3.6-rzb2779+dfsg-0ubuntu53.6-rzb2779+dfsg-0ubuntu63.6-rzb2779+dfsg-0ubuntu73.6-rzb2779+dfsg-0ubuntu83.6-rzb2779+dfsg-0ubuntu93.6-rzb2779+dfsg-0ubuntu9.1 |
3.6-rzb2779+dfsg-0ubuntu9.2 |
History
| Recorded | Changed | Sources |
|---|---|---|
| aliases | EUVD | |
| first indexed | CVE List, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2019-12385 is a high vulnerability (CVSS 8.8) in Ampache, published August 22, 2019. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 1.63%, the 76th percentile. Fixed in ampache 3.6-rzb2752+dfsg-5+deb8u1.
References
tarlogic.com/en/blog/vulnerabilities-in-ampache
lists.debian.org/debian-lts-announce/2019/11/msg00008.html
nvd.nist.gov/vuln/detail/CVE-2019-12385
github.com/advisories/GHSA-p72w-3684-2crg
ubuntu.com/security/CVE-2019-12385
ubuntu.com/security/notices/USN-4693-1
cve.org/CVERecord?id=CVE-2019-12385
ubuntu.com/security/CVE-2019-12386