Every CVE Search/ Get API key

CVE-2019-12412

A flaw in the libapreq2 v2.07 to v2.13 multipart parser can deference a null pointer leading to a...

7.5 HighFix available

A flaw in the libapreq2 v2.07 to v2.13 multipart parser can deference a null pointer leading to a process crash. A remote attacker could send a request causing a process crash which could lead to a denial of service attack.

Attack profile

How easy it is to exploit

Attack vector
Network
Complexity
Low
Privileges needed
None
User interaction
None

What an attacker can affect

Confidentiality
None
Integrity
None
Availability
High

Exploit likelihood

4.11%Up 1.2 points since Apr 14, 2021
90%50%10%1%

What each source reports

NVD Score used 7.5

A flaw in the libapreq2 v2.07 to v2.13 multipart parser can deference a null pointer leading to a process crash. A remote attacker could send a request causing a process crash which could lead to a denial of service attack.

Record
CVE-2019-12412
CVSS 3.1
7.5 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
CVSS 2.0
5.0 MediumAV:N/AC:L/Au:N/C:N/I:N/A:P
Weakness
CWE-476
Updated
2026-11-02
CVE List No score

A flaw in the libapreq2 v2.07 to v2.13 multipart parser can deference a null pointer leading to a process crash. A remote attacker could send a request causing a process crash which could lead to a denial of service attack.

Record
CVE-2019-12412
Updated
2026-11-02
EUVDEUVD-2019-4032 No score

A flaw in the libapreq2 v2.07 to v2.13 multipart parser can deference a null pointer leading to a process crash. A remote attacker could send a request causing a process crash which could lead to a denial of service attack.

Record
EUVD-2019-4032
Updated
2026-11-03
GitHub AdvisoriesGHSA-239h-283c-gxph No score

A flaw in the libapreq2 v2.07 to v2.13 multipart parser can deference a null pointer leading to a...

A flaw in the libapreq2 v2.07 to v2.13 multipart parser can deference a null pointer leading to a process crash. A remote attacker could send a request causing a process crash which could lead to a denial of service attack.

Record
GHSA-239h-283c-gxph
Weakness
CWE-476
Updated
2026-11-02
OSV 7.5

A flaw in the libapreq2 v2.07 to v2.13 multipart parser can deference a null pointer leading to a process crash. A remote attacker could send a request causing a process crash which could lead to a denial of service attack.

Record
CVE-2019-12412
CVSS 3.1
7.5 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Updated
2026-11-02
OSVDEBIAN-CVE-2019-12412 7.5

A flaw in the libapreq2 v2.07 to v2.13 multipart parser can deference a null pointer leading to a process crash. A remote attacker could send a request causing a process crash which could lead to a denial of service attack.

Record
DEBIAN-CVE-2019-12412
CVSS 3.1
7.5 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Updated
2026-11-02
Show 4 moreShow less
OSVUBUNTU-CVE-2019-12412 7.5

A flaw in the libapreq2 v2.07 to v2.13 multipart parser can deference a null pointer leading to a process crash. A remote attacker could send a request causing a process crash which could lead to a denial of service attack.

Record
UBUNTU-CVE-2019-12412
CVSS 3.1
7.5 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Updated
2026-11-02
OSVMGASA-2019-0327 No score

Updated libapreq2 packages fix security vulnerability

Updated libapreq2 packages fix security vulnerability:

Max Kellermann reported a NULL pointer dereference flaw in libapreq2, allowing a remote attacker to cause a denial of service against an application using the library (application crash) if an invalid nested "multipart" body is processed (CVE-2019-12412).

Record
MGASA-2019-0327
Updated
2026-11-02
OSVUSN-4558-1 No score

libapreq2 vulnerabilities

It was discovered that libapreq2 did not properly sanitize the Content-Type field in certain, crafted HTTP requests. An attacker could use this vulnerability to cause libapreq2 to crash.

Record
USN-4558-1
Updated
2026-11-02
OSVUSN-5041-1 No score

libapreq2 vulnerability

It was discovered that libapreq2 did not properly sanitize the Content-Type field in certain crafted HTTP requests. An attacker could possibly use the vulnerability to cause libapreq2 to crash.

Record
USN-5041-1
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
libapreq2
Debian:13
before 2.13-6
2.13-6
libapreq2
Debian:8
before 2.13-4+deb8u1, plus listed versions
2.13-4
2.13-4+deb8u1
libapreq2
Debian:9
before 2.13-7~deb9u1, plus listed versions
2.13-52.13-6
2.13-7~deb9u1
libapreq2
Debian:10
before 2.13-7~deb10u1, plus listed versions
2.13-52.13-62.13-7~deb9u1
2.13-7~deb10u1
libapreq2
Mageia:7
before 2.130.0-28.1.mga7
2.130.0-28.1.mga7
libapreq2
Ubuntu:Pro:14.04:LTS
before 2.13-3ubuntu2+esm1, plus listed versions
2.13-2.12.13-2.1build12.13-32.13-3ubuntu2
2.13-3ubuntu2+esm1
libapreq2
Ubuntu:Pro:16.04:LTS
before 2.13-4ubuntu2+esm1, plus listed versions
2.13-4ubuntu12.13-4ubuntu2
2.13-4ubuntu2+esm1
libapreq2
Ubuntu:18.04:LTS
before 2.13-7~deb10u1build0.18.04.1, plus listed versions
2.13-5build22.13-5build3
2.13-7~deb10u1build0.18.04.1

History

History
RecordedChangedSources
aliases, productsEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2019-12412 is a high vulnerability (CVSS 7.5) in Apache Libapreq2, published September 30, 2019. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 4.11%, the 90th percentile. Fixed in libapreq2 2.13-6.

References

Show 7 moreShow less
MoveEnter Open