Every CVE Search/ Get API key

CVE-2019-12790

In radare2 through 3.5.1, there is a heap-based buffer over-read in the r_egg_lang_parsechar...

7.8 HighFix available

In radare2 through 3.5.1, there is a heap-based buffer over-read in the r_egg_lang_parsechar function of egg_lang.c. This allows remote attackers to cause a denial of service (application crash) or possibly have unspecified other impact because of missing length validation in libr/egg/egg.c.

Attack profile

How easy it is to exploit

Attack vector
Local
Complexity
Low
Privileges needed
None
User interaction
Required

What an attacker can affect

Confidentiality
High
Integrity
High
Availability
High

Exploit likelihood

1.67%Up 0.4 points since Apr 14, 2021
90%50%10%1%

What each source reports

NVD Score used 7.8

In radare2 through 3.5.1, there is a heap-based buffer over-read in the r_egg_lang_parsechar function of egg_lang.c. This allows remote attackers to cause a denial of service (application crash) or possibly have unspecified other impact because of missing length validation in libr/egg/egg.c.

Record
CVE-2019-12790
CVSS 3.0
7.8 HighCVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
CVSS 2.0
6.8 MediumAV:N/AC:M/Au:N/C:P/I:P/A:P
Weakness
CWE-125
Updated
2026-11-02
CVE List No score

In radare2 through 3.5.1, there is a heap-based buffer over-read in the r_egg_lang_parsechar function of egg_lang.c. This allows remote attackers to cause a denial of service (application crash) or possibly have unspecified other impact because of missing length validation in libr/egg/egg.c.

Record
CVE-2019-12790
Updated
2026-11-02
EUVDEUVD-2019-4373 No score

In radare2 through 3.5.1, there is a heap-based buffer over-read in the r_egg_lang_parsechar function of egg_lang.c. This allows remote attackers to cause a denial of service (application crash) or possibly have unspecified other impact because of missing length validation in libr/egg/egg.c.

Record
EUVD-2019-4373
Updated
2026-11-03
GitHub AdvisoriesGHSA-599w-55gq-8q3f 7.8

In radare2 through 3.5.1, there is a heap-based buffer over-read in the r_egg_lang_parsechar...

In radare2 through 3.5.1, there is a heap-based buffer over-read in the r_egg_lang_parsechar function of egg_lang.c. This allows remote attackers to cause a denial of service (application crash) or possibly have unspecified other impact because of missing length validation in libr/egg/egg.c.

Record
GHSA-599w-55gq-8q3f
CVSS 3.0
7.8 HighCVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
Weakness
CWE-125
Updated
2026-11-02
OSVALPINE-CVE-2019-12790 7.8

In radare2 through 3.5.1, there is a heap-based buffer over-read in the r_egg_lang_parsechar function of egg_lang.c. This allows remote attackers to cause a denial of service (application crash) or possibly have unspecified other impact because of missing length validation in libr/egg/egg.c.

Record
ALPINE-CVE-2019-12790
CVSS 3.0
7.8 HighCVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
Updated
2026-11-03
OSV 7.8

In radare2 through 3.5.1, there is a heap-based buffer over-read in the r_egg_lang_parsechar function of egg_lang.c. This allows remote attackers to cause a denial of service (application crash) or possibly have unspecified other impact because of missing length validation in libr/egg/egg.c.

Record
CVE-2019-12790
CVSS 3.0
7.8 HighCVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
Updated
2026-11-02
OSVUBUNTU-CVE-2019-12790 7.8

In radare2 through 3.5.1, there is a heap-based buffer over-read in the r_egg_lang_parsechar function of egg_lang.c. This allows remote attackers to cause a denial of service (application crash) or possibly have unspecified other impact because of missing length validation in libr/egg/egg.c.

Record
UBUNTU-CVE-2019-12790
CVSS 3.0
7.8 HighCVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
Updated
2026-11-02
OSVMGASA-2020-0024 No score

Updated radare2 packages fix security vulnerabilities

Updated radare2 packages fix security vulnerabilities:

In radare2 through 3.5.1, there is a heap-based buffer over-read in the r_egg_lang_parsechar function of egg_lang.c. This allows remote attackers to cause a denial of service (application crash) or possibly have unspecified other impact because of missing length validation in libr/egg/egg.c (CVE-2019-12790).

In radare2 through 3.5.1, the rcc_context function of libr/egg/egg_lang.c mishandles changing context. This allows remote attackers to cause a denial of service (application crash) or possibly have unspecified other impact (invalid memory access in r_egg_lang_parsechar; invalid free in rcc_pusharg) (CVE-2019-12802).

In radare2 through 3.5.1, cmd_mount in libr/core/cmd_mount.c has a double free for the ms command (CVE-2019-12865).

By using a crafted executable file, it's possible to execute arbitrary shell commands with the permissions of the victim. This vulnerability is due to improper handling of symbol names embedded in executables (CVE-2019-14745).

The radare2 package has been updated to version 3.9.0, fixing these issues and other bugs.

Also, the radare2-cutter package has been updated to version 1.9.0.

Record
MGASA-2020-0024
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
radare2
Alpine:v3.11
before 3.9.0
3.9.0
radare2
Alpine:v3.12
before 3.9.0-r0
3.9.0-r0
radare2
Alpine:v3.13
before 3.9.0-r0
3.9.0-r0
radare2
Alpine:v3.14
before 3.9.0-r0
3.9.0-r0
radare2
Alpine:v3.15
before 3.9.0-r0
3.9.0-r0
radare2
Alpine:v3.16
before 3.9.0-r0
3.9.0-r0
radare2
Alpine:v3.17
before 3.9.0-r0
3.9.0-r0
radare2
Alpine:v3.18
before 3.9.0-r0
3.9.0-r0
radare2
Alpine:v3.19
before 3.9.0-r0
3.9.0-r0
radare2
Alpine:v3.20
before 3.9.0-r0
3.9.0-r0
Show 13 moreShow less
Affected packages
PackageAffectedFixed
radare2
Alpine:v3.21
before 3.9.0-r0
3.9.0-r0
radare2
Alpine:v3.22
before 3.9.0-r0
3.9.0-r0
radare2
Alpine:v3.23
before 3.9.0-r0
3.9.0-r0
radare2
Alpine:v3.24
before 3.9.0-r0
3.9.0-r0
radare2
Mageia:7
From an advisory covering 4 CVEs
before 3.9.0-1.mga7
3.9.0-1.mga7
radare2-cutter
Mageia:7
From an advisory covering 4 CVEs
before 1.9.0-1.1.mga7
1.9.0-1.1.mga7
radare2
Ubuntu:16.04:LTS
All versions, plus listed versions
0.9.6-3.1ubuntu1
None known
radare2
Ubuntu:Pro:18.04:LTS
All versions, plus listed versions
1.6.0+dfsg-12.0.0+dfsg-12.1.0+dfsg-12.3.0+dfsg-12.3.0+dfsg-22.3.0+dfsg-2ubuntu0.1~esm1
None known
radare2
Ubuntu:Pro:20.04:LTS
All versions, plus listed versions
3.2.1+dfsg-5build14.0.0+dfsg-14.2.1+dfsg-14.2.1+dfsg-24.2.1+dfsg-2ubuntu0.1~esm1
None known
radare2
Ubuntu:Pro:24.04:LTS
All versions, plus listed versions
5.5.0+dfsg-1ubuntu15.5.0+dfsg-1.1ubuntu25.5.0+dfsg-1.1ubuntu35.5.0+dfsg-1.1ubuntu3+esm1
None known
radare2
Ubuntu:25.10
All versions, plus listed versions
5.9.8+dfsg-25.9.8+dfsg-2ubuntu0.25.10.15.9.8+dfsg-2ubuntu0.25.10.2
None known
radare2
Ubuntu:26.10
All versions, plus listed versions
6.0.7+ds-16.1.6+ds-26.1.6+ds-36.1.8+ds-1
None known
radare2
Ubuntu:26.04:LTS
All versions, plus listed versions
5.9.8+dfsg-26.0.4+dfsg-16.0.7+ds-1
None known

History

History
RecordedChangedSources
affected, facts
affected, aliases, referencesOSV
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2019-12790 is a high vulnerability (CVSS 7.8) in Radare Radare2, published June 10, 2019. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 1.67%, the 76th percentile. Fixed in radare2 3.9.0.

References

Show 8 moreShow less
MoveEnter Open