Every CVE Search/ Get API key

CVE-2019-13217

A heap buffer overflow in the start_decoder function in stb_vorbis through 2019-03-04 allows an...

7.8 HighFix available

A heap buffer overflow in the start_decoder function in stb_vorbis through 2019-03-04 allows an attacker to cause a denial of service or execute arbitrary code by opening a crafted Ogg Vorbis file.

Attack profile

How easy it is to exploit

Attack vector
Local
Complexity
Low
Privileges needed
None
User interaction
Required

What an attacker can affect

Confidentiality
High
Integrity
High
Availability
High

Exploit likelihood

1.54%Down 0.3 points since Apr 14, 2021
90%50%10%1%

What each source reports

NVD Score used 7.8

A heap buffer overflow in the start_decoder function in stb_vorbis through 2019-03-04 allows an attacker to cause a denial of service or execute arbitrary code by opening a crafted Ogg Vorbis file.

Record
CVE-2019-13217
CVSS 3.1
7.8 HighCVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
CVSS 2.0
6.8 MediumAV:N/AC:M/Au:N/C:P/I:P/A:P
Weakness
CWE-787
Updated
2026-11-02
CVE List No score

A heap buffer overflow in the start_decoder function in stb_vorbis through 2019-03-04 allows an attacker to cause a denial of service or execute arbitrary code by opening a crafted Ogg Vorbis file.

Record
CVE-2019-13217
Updated
2026-11-02
EUVDEUVD-2019-4730 No score

A heap buffer overflow in the start_decoder function in stb_vorbis through 2019-03-04 allows an attacker to cause a denial of service or execute arbitrary code by opening a crafted Ogg Vorbis file.

Record
EUVD-2019-4730
Updated
2026-11-03
GitHub AdvisoriesGHSA-mx8v-jv43-26h4 7.8

A heap buffer overflow in the start_decoder function in stb_vorbis through 2019-03-04 allows an...

A heap buffer overflow in the start_decoder function in stb_vorbis through 2019-03-04 allows an attacker to cause a denial of service or execute arbitrary code by opening a crafted Ogg Vorbis file.

Record
GHSA-mx8v-jv43-26h4
CVSS 3.0
7.8 HighCVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
Weakness
CWE-119, CWE-787
Updated
2026-11-02
OSV 7.8

A heap buffer overflow in the start_decoder function in stb_vorbis through 2019-03-04 allows an attacker to cause a denial of service or execute arbitrary code by opening a crafted Ogg Vorbis file.

Record
CVE-2019-13217
CVSS 3.1
7.8 HighCVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
Updated
2026-11-02
OSVDEBIAN-CVE-2019-13217 7.8

A heap buffer overflow in the start_decoder function in stb_vorbis through 2019-03-04 allows an attacker to cause a denial of service or execute arbitrary code by opening a crafted Ogg Vorbis file.

Record
DEBIAN-CVE-2019-13217
CVSS 3.1
7.8 HighCVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
Updated
2026-11-02
OSVUBUNTU-CVE-2019-13217 7.8

A heap buffer overflow in the start_decoder function in stb_vorbis through 2019-03-04 allows an attacker to cause a denial of service or execute arbitrary code by opening a crafted Ogg Vorbis file.

Record
UBUNTU-CVE-2019-13217
CVSS 3.1
7.8 HighCVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
CVSS 3.0
7.8 HighCVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
Updated
2026-11-02
OSVopenSUSE-SU-2024:11409-1 No score

stb-devel-2.36.1594640766.b42009b-1.4 on GA media

These are all security issues fixed in the stb-devel-2.36.1594640766.b42009b-1.4 package on the GA media of openSUSE Tumbleweed.

Record
openSUSE-SU-2024:11409-1
Updated
2026-11-02
OSVopenSUSE-SU-2025:0039-1 No score

Security update for stb

This update for stb fixes the following issues:

Addressing the follow security issues (boo#1216478):

  • CVE-2019-13217: heap buffer overflow in start_decoder()
  • CVE-2019-13218: stack buffer overflow in compute_codewords()
  • CVE-2019-13219: uninitialized memory in vorbis_decode_packet_rest()
  • CVE-2019-13220: out-of-range read in draw_line()
  • CVE-2019-13221: issue with large 1D codebooks in lookup1_values()
  • CVE-2019-13222: unchecked NULL returned by get_window()
  • CVE-2019-13223: division by zero in predict_point()
Record
openSUSE-SU-2025:0039-1
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
libstb
Debian:12
before 0.0~git20190817.1.052dce1-1
0.0~git20190817.1.052dce1-1
libstb
Debian:13
before 0.0~git20190817.1.052dce1-1
0.0~git20190817.1.052dce1-1
libstb
Debian:14
before 0.0~git20190817.1.052dce1-1
0.0~git20190817.1.052dce1-1
libstb
Debian:10
From an advisory covering 13 CVEs
before 0.0~git20180212.15.e6afb9c-1+deb10u1, plus listed versions
0.0~git20180212.15.e6afb9c-1
0.0~git20180212.15.e6afb9c-1+deb10u1
stb
openSUSE:Tumbleweed
From an advisory covering 7 CVEs
before 2.36.1594640766.b42009b-1.4
2.36.1594640766.b42009b-1.4
stb
SUSE:Package Hub 15 SP6
From an advisory covering 7 CVEs
before 20240910-bp156.2.3.1
20240910-bp156.2.3.1
stb
openSUSE:Leap 15.6
From an advisory covering 7 CVEs
before 20240910-bp156.2.3.1
20240910-bp156.2.3.1

History

History
RecordedChangedSources
affected, facts
affected
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2019-13217 is a high vulnerability (CVSS 7.8) in Stb Vorbis Project Vorbis, published August 15, 2019. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 1.54%, the 75th percentile. Fixed in libstb 0.0~git20190817.1.052dce1-1.

References

Show 12 moreShow less
MoveEnter Open