Every CVE Search/ Get API key

CVE-2019-13274

In Xymon through 4.3.28, an XSS vulnerability exists in the csvinfo CGI script due to...

6.1 MediumFix available

In Xymon through 4.3.28, an XSS vulnerability exists in the csvinfo CGI script due to insufficient filtering of the db parameter.

Attack profile

How easy it is to exploit

Attack vector
Network
Complexity
Low
Privileges needed
None
User interaction
Required

What an attacker can affect

Confidentiality
Low
Integrity
Low
Availability
None

Exploit likelihood

0.91%Up 0.3 points since Apr 14, 2021
90%50%10%1%

What each source reports

NVD Score used 6.1

In Xymon through 4.3.28, an XSS vulnerability exists in the csvinfo CGI script due to insufficient filtering of the db parameter.

Record
CVE-2019-13274
CVSS 3.0
6.1 MediumCVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
CVSS 2.0
4.3 MediumAV:N/AC:M/Au:N/C:N/I:P/A:N
Weakness
CWE-79
Updated
2026-11-02
CVE List No score

In Xymon through 4.3.28, an XSS vulnerability exists in the csvinfo CGI script due to insufficient filtering of the db parameter.

Record
CVE-2019-13274
Updated
2026-11-02
EUVDEUVD-2019-4781 No score

In Xymon through 4.3.28, an XSS vulnerability exists in the csvinfo CGI script due to insufficient filtering of the db parameter.

Record
EUVD-2019-4781
Updated
2026-11-03
GitHub AdvisoriesGHSA-23f8-vj3q-65w6 6.1

In Xymon through 4.3.28, an XSS vulnerability exists in the csvinfo CGI script due to...

In Xymon through 4.3.28, an XSS vulnerability exists in the csvinfo CGI script due to insufficient filtering of the db parameter.

Record
GHSA-23f8-vj3q-65w6
CVSS 3.0
6.1 MediumCVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
Weakness
CWE-79
Updated
2026-11-02
OSV 6.1

In Xymon through 4.3.28, an XSS vulnerability exists in the csvinfo CGI script due to insufficient filtering of the db parameter.

Record
CVE-2019-13274
CVSS 3.0
6.1 MediumCVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
Updated
2026-11-02
OSVDEBIAN-CVE-2019-13274 6.1

In Xymon through 4.3.28, an XSS vulnerability exists in the csvinfo CGI script due to insufficient filtering of the db parameter.

Record
DEBIAN-CVE-2019-13274
CVSS 3.0
6.1 MediumCVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
Updated
2026-11-02
OSVUBUNTU-CVE-2019-13274 6.1

In Xymon through 4.3.28, an XSS vulnerability exists in the csvinfo CGI script due to insufficient filtering of the db parameter.

Record
UBUNTU-CVE-2019-13274
CVSS 3.0
6.1 MediumCVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
xymon
Debian:12
before 4.3.29-1
4.3.29-1
xymon
Debian:13
before 4.3.29-1
4.3.29-1
xymon
Debian:14
before 4.3.29-1
4.3.29-1
xymon
Debian:8
before 4.3.17-6+deb8u2, plus listed versions
4.3.17-64.3.17-6+deb8u1
4.3.17-6+deb8u2
xymon
Ubuntu:16.04:LTS
All versions, plus listed versions
4.3.21-14.3.21-24.3.22~beta-14.3.24-14.3.24-24.3.25-1
None known
xymon
Ubuntu:18.04:LTS
All versions, plus listed versions
4.3.28-24.3.28-34.3.28-3build1
None known
xymon
Ubuntu:20.04:LTS
before 4.3.29-1
4.3.29-1

History

History
RecordedChangedSources
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2019-13274 is a medium vulnerability (CVSS 6.1) in Xymon, published August 26, 2019. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.91%, the 59th percentile. Fixed in xymon 4.3.29-1.

References

MoveEnter Open