Every CVE Search/ Get API key

CVE-2019-14692

AdPlug 2.3.1 has a heap-based buffer overflow in CmkjPlayer::load() in mkj.cpp.

8.8 HighFix available

AdPlug 2.3.1 has a heap-based buffer overflow in CmkjPlayer::load() in mkj.cpp.

Attack profile

How easy it is to exploit

Attack vector
Network
Complexity
Low
Privileges needed
None
User interaction
Required

What an attacker can affect

Confidentiality
High
Integrity
High
Availability
High

Exploit likelihood

1.72%Up 0.9 points since Apr 14, 2021
90%50%10%1%

What each source reports

NVD Score used 8.8

AdPlug 2.3.1 has a heap-based buffer overflow in CmkjPlayer::load() in mkj.cpp.

Record
CVE-2019-14692
CVSS 3.1
8.8 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
CVSS 2.0
6.8 MediumAV:N/AC:M/Au:N/C:P/I:P/A:P
Weakness
CWE-787
Updated
2026-11-02
CVE List No score

AdPlug 2.3.1 has a heap-based buffer overflow in CmkjPlayer::load() in mkj.cpp.

Record
CVE-2019-14692
Updated
2026-11-02
EUVDEUVD-2019-5842 No score

AdPlug 2.3.1 has a heap-based buffer overflow in CmkjPlayer::load() in mkj.cpp.

Record
EUVD-2019-5842
Updated
2026-11-03
GitHub AdvisoriesGHSA-xxq3-764r-q6rm No score

AdPlug 2.3.1 has a heap-based buffer overflow in CmkjPlayer::load() in mkj.cpp.

AdPlug 2.3.1 has a heap-based buffer overflow in CmkjPlayer::load() in mkj.cpp.

Record
GHSA-xxq3-764r-q6rm
Weakness
CWE-787
Updated
2026-11-02
OSV 8.8

AdPlug 2.3.1 has a heap-based buffer overflow in CmkjPlayer::load() in mkj.cpp.

Record
CVE-2019-14692
CVSS 3.1
8.8 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
Updated
2026-11-02
OSVDEBIAN-CVE-2019-14692 8.8

AdPlug 2.3.1 has a heap-based buffer overflow in CmkjPlayer::load() in mkj.cpp.

Record
DEBIAN-CVE-2019-14692
CVSS 3.1
8.8 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
Updated
2026-11-02
OSVUBUNTU-CVE-2019-14692 8.8

AdPlug 2.3.1 has a heap-based buffer overflow in CmkjPlayer::load() in mkj.cpp.

Record
UBUNTU-CVE-2019-14692
CVSS 3.1
8.8 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
Updated
2026-11-02
OSVopenSUSE-SU-2024:12762-1 No score

adplugdb-2.3.3-1.1 on GA media

These are all security issues fixed in the adplugdb-2.3.3-1.1 package on the GA media of openSUSE Tumbleweed.

Record
openSUSE-SU-2024:12762-1
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
adplug
Debian:12
before 2.3.3+dfsg-2
2.3.3+dfsg-2
adplug
Debian:13
before 2.3.3+dfsg-2
2.3.3+dfsg-2
adplug
Debian:14
before 2.3.3+dfsg-2
2.3.3+dfsg-2
adplug
Ubuntu:16.04:LTS
All versions, plus listed versions
2.2.1+dfsg3-0.2ubuntu22.2.1+dfsg3-0.32.2.1+dfsg3-1~build0.16.04.1
None known
adplug
Ubuntu:18.04:LTS
All versions, plus listed versions
2.2.1+dfsg3-0.42.2.1+dfsg3-1~build0.18.04.1
None known
adplug
Ubuntu:20.04:LTS
All versions, plus listed versions
2.2.1+dfsg3-12.3.1+dfsg-22.3.1+dfsg-2build1
None known

History

History
RecordedChangedSources
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2019-14692 is a high vulnerability (CVSS 8.8) in Adplug Project Adplug, published August 6, 2019. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 1.72%, the 77th percentile. Fixed in adplug 2.3.3+dfsg-2.

References

Show 11 moreShow less
MoveEnter Open